Announcement

Collapse
No announcement yet.

Issues controlling TCL Roku TV

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Control of TV is still working here so I am assuming it is fixed. It would be good to know if the change came from the recent update in the plug-in or a firmware change on the Roku. But all working as expected here.

    Comment


      #17
      sirmeili any thoughts on the IP address issue?

      Comment


        #18
        The plugins should see that the serial number is the same and update the configs. Let me check that it's saving the settings correctly. Now that I think of it, I changed part of that code and it was causing an issue somewhere else.
        MeiAutomtion Home

        Comment


          #19
          Originally posted by Ltek View Post
          sirmeili any thoughts on the IP address issue?
          Can you try the 3.2.0.11 beta version and let me know if adjusting the IP works now? If not, can you give me a debug log?
          MeiAutomtion Home

          Comment


            #20
            Originally posted by sirmeili View Post
            Can you try the 3.2.0.11 beta version and let me know if adjusting the IP works now? If not, can you give me a debug log?
            I did on one of them. The other didnt work so I deleted the non-working Roku from the plugin, then the HS devices. Then click Discover button, it didnt find anything. I manually input the IP, then it said it was already added... and it was added. It looks to be showing the status properly at the moment too.

            Comment


              #21
              I had a situation with my Roku TCL today and thought I would post to get advice.

              Of note this is not a Meiku issue.

              I tried to turn on the TV by Alexa, which in turn calls homeseer. It didn’t work. Next I loaded the Roku app on my phone and it couldn’t connect.

              So I turned the TV on with the remote. The TV showed it was connected to Wi-Fi etc. After turning it on with the remote the Roku app recognized the TV and Meiku was able to control it.

              It appears that the TV was in some state that prevented it being turned on over the network. My assumption is that when off it is always listening for a network signal?

              Has anyone else experience this? Thanks.


              Sent from my iPhone using Tapatalk

              Comment


                #22
                There is a setting which allows the TV to go into low power mode which disconnects the Wifi after 15 minutes.

                I believe it is in Settings -> Power -> Fast TV Start should be enabled
                MeiAutomtion Home

                Comment


                  #23
                  Got it - thanks. I have enabled this

                  Comment


                    #24
                    Just installed the plugin at my mom’s house (on hs4). Very happy that I can turn the tv on/off from the plugin.

                    works perfect.

                    Unfortunately her isp router is garbage , and I do not have acess to dhcp. Do you think that a change of ip could cause an issue?

                    One day...in the future, I’ll give her my linksys 3200acm, when i’ll move to something else. But for now, do you think an ip change could cause issues?

                    thanks

                    Comment


                      #25
                      Originally posted by MattL0 View Post
                      Just installed the plugin at my mom’s house (on hs4). Very happy that I can turn the tv on/off from the plugin.

                      works perfect.

                      Unfortunately her isp router is garbage , and I do not have acess to dhcp. Do you think that a change of ip could cause an issue?

                      One day...in the future, I’ll give her my linksys 3200acm, when i’ll move to something else. But for now, do you think an ip change could cause issues?

                      thanks
                      it should find the new IP during discovery and associate the IP with the existing roku, but I would have to test this out (I remember doing this). However it won't notice immediately. If I remember correctly there is a polling option for "discovery" and it should discover during start up as well.
                      MeiAutomtion Home

                      Comment

                      Working...
                      X