Announcement

Collapse
No announcement yet.

Sonos announcement questions and Sonos Alexa support

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • bartbakels
    replied
    same issues here, hopefully they will implement the local announce function

    Leave a comment:


  • dcorsus
    replied
    Originally posted by srodgers View Post
    Dirk,

    Thank you looking at this.


    Sent from my iPad using Tapatalk
    Just a quick follow up. After doing a lot of coding, all I tried just failed. I found some postings on the Sonos forum stating similar inability to restore one of these special queues Sonos uses to play music that was instructed through Alexa. It appears that Sonos has been adding a function to play an announcement OVER what is currently playing but as far as I can tell it is only available through what they call their cloud interface and not the local UPNP interface. If this becomes available, it may make the implementation of TTS (and associated delays) all become very simple, so let's keep our fingers crossed that Sonos doesn't go the other way and starts removing things from the UPNP interface or worse, close (encrypt) this at some point.

    Leave a comment:


  • drparker151
    replied
    Originally posted by Rvtravlr View Post

    We have a Sonos One but after a while, disabled the Alexa option because it just didn’t work as well as our Dots - it couldn’t “hear” as well.
    Yes, I decided to get the regular Sonos 1 devices and not the Sonos One. The Sonos One is not a full echo device. It is an Alexa enabled device. It cannot a do lot of Echo based features like messages and drop in. I would have loved to replace my echo devices with the Sonos One but with the missing features I could not.

    Leave a comment:


  • Rvtravlr
    replied
    Originally posted by dcorsus View Post
    Just a quick update....

    I started looking at this last night, I can reproduce easily. At first glance, it appears Sonos introduced some totally new (and strange?) mechanism to use new kind of queues and if solvable will require a lot of changes.

    At this point trying to see if it can actually be made to work

    Stay tuned!

    Dirk
    We have a Sonos One but after a while, disabled the Alexa option because it just didn’t work as well as our Dots - it couldn’t “hear” as well.

    Leave a comment:


  • srodgers
    replied
    Dirk,

    Thank you looking at this.


    Sent from my iPad using Tapatalk

    Leave a comment:


  • dcorsus
    replied
    Just a quick update....

    I started looking at this last night, I can reproduce easily. At first glance, it appears Sonos introduced some totally new (and strange?) mechanism to use new kind of queues and if solvable will require a lot of changes.

    At this point trying to see if it can actually be made to work

    Stay tuned!

    Dirk

    Leave a comment:


  • srodgers
    replied
    Thank you. This is very repeatable. Any Alexa initiated playback to Sonos speakers gets interrupted by plugin announcements. Sonos music initiated by HS or Sonos app works normally and plugin announcements pause the music, play announcement and resume music playback.

    For now my work around is just not to use Alexa to start playback to Sonos. I use Alexa commands to trigger HS events to start playback so the announcements work good.


    Sent from my iPhone using Tapatalk

    Leave a comment:


  • dcorsus
    replied
    Originally posted by srodgers View Post

    Here is the debug log.
    I'm currently out of town. Will look at it later this week, might be a Sonos issue or hard to fix

    Leave a comment:


  • srodgers
    replied
    Originally posted by dcorsus View Post

    Are there errors in the log file?
    Perhaps turn debug flag on, log to disk on, do your announcement, turn logging to disk off and post the log file (<hs root>\html\sonos\logs)
    Here is the debug log.
    Attached Files

    Leave a comment:


  • srodgers
    replied
    Originally posted by dcorsus View Post

    Are there errors in the log file?
    Perhaps turn debug flag on, log to disk on, do your announcement, turn logging to disk off and post the log file (<hs root>\html\sonos\logs)
    Ok here is the error messages form the HS Log:
    Feb-17 6:22:30 PM Sonos Error ERROR in PlayURI for zoneplayer = Office with UPNP Error = Read only tag / Transport is locked / Access denied. URI=x-rincon-queue:RINCON_000E588138E601400#6 and isObjectID = False, MetaData=object.item.audioItem.audioBroadcasthttps://ab-us.ws.sonos.com/cloudqueue/householdId/Sonos_LQDFVBpI8SigbC0MpQje7N4xbX.afUHcewkoAIu15h6lIDv/groupId/RINCON_000E588138E601400:309/v2.1/, Error =MyUPnPService.InvokeAction for ServiceID = http://192.168.2.42:1400/xml/AVTransport1.xml while sending Action = SetAVTransportURI for URI = http://192.168.2.42:1400/MediaRender...nsport/Control and Request = 0 x-rincon-queue:RINCON_000E588138E601400#6 <DIDL-Lite xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/" xmlns:r="urn:schemas-rinconnetworks-com:metadata-1-0/" xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/"><item id="-1" parentID="-1" restricted="true"><upnp:class>object.item.audioItem.audioBro adcast</upnp:class><desc id="cdudn" nameSpace="urn:schemas-rinconnetworks-com:metadata-1-0/">https://ab-us.ws.sonos.com/cloudqueue/householdId/Sonos_LQDFVBpI8SigbC0MpQje7N4xbX.afUHcewkoAIu15h6lIDv/groupId/RINCON_000E588138E601400:309/v2.1/</desc></item></DIDL-Lite> UPNP Error = faultcode = s:Client, faultstring = UPnPError, detail = 714 with error = The remote server returned an error: (500) Internal Server Error.
    Feb-17 6:22:24 PM Warning File does not exist: C:\Program Files (x86)\HomeSeer HS3\html\images\Sonos\Artwork\CoverRINCON_000E588138E601400_ 4684.jpg

    Leave a comment:


  • dcorsus
    replied
    Originally posted by srodgers View Post
    Mine work great so far making announcements. One small issue is if Alexa has initiated something playing on the Sonos then the announcements interrupt the playback and it does not restart.

    If playback was started via the sonos app then plugin and announcements work as expected. Playback pauses, group is built and announcement is played and the sonos return to what they we playing before.

    Only have issues with Alexa initiated playback to Sonos like a pandora channel. Start it with Alexa and problem. Start same pandora channel via sonos app and announcements don’t kill the playback and it resumes.
    Are there errors in the log file?
    Perhaps turn debug flag on, log to disk on, do your announcement, turn logging to disk off and post the log file (<hs root>\html\sonos\logs)

    Leave a comment:


  • srodgers
    replied
    Mine work great so far making announcements. One small issue is if Alexa has initiated something playing on the Sonos then the announcements interrupt the playback and it does not restart.

    If playback was started via the sonos app then plugin and announcements work as expected. Playback pauses, group is built and announcement is played and the sonos return to what they we playing before.

    Only have issues with Alexa initiated playback to Sonos like a pandora channel. Start it with Alexa and problem. Start same pandora channel via sonos app and announcements don’t kill the playback and it resumes.

    Leave a comment:


  • rprade
    replied
    I have been asked to share my script for dynamic Linkgroups. I started a new thread here.

    Leave a comment:


  • Rvtravlr
    replied
    Randy,

    Thanks for the detailed write up. Now you’ve got me thinking...

    Michael

    Leave a comment:


  • rprade
    replied
    Originally posted by socalsharky View Post
    The Profit

    rprade

    I'm just getting started with announcements. Can you guys direct me to a post that describes how to do this? Do I need a plugin? Thanks again.
    Yes you need the plug-in that this forum refers to. With the plug-in you can build groups of speakers to send announcements to, pick the source device and set the volume for each speaker. Then you use a standard HomeSeer speak action with the linkgroup as the destination device. The plug-in has a concise help manual to walk you through setup and configuration.

    Leave a comment:

Working...
X