Announcement

Collapse
No announcement yet.

Running Sonos PI as admin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Running Sonos PI as admin

    I'm having a problem getting TTS working - the announcement plays OK, but nothing gets restored afterwards. Linkgroups etc look OK. Having trawled the forums, I keep seeing "run HS3 and the PI as administrator". I *think* HS3 is running as administrator on my Windows 10 machine (it seems to have full access rights). However I suspect the Sonos PI isn't (the process seems to have limited rights). So my question is how do I make sure the PI starts as administrator? (And how can I check?) There's no point in trying to debug my problem further until I make sure this issue isn't the root cause.

    If only I understood windows 10 (or Sonos, or Homeseer) all this would be easy. Sadly I'm lacking in all respects, so I need an idiot-level response please!

  • #2
    Have you checked your firewall? If the announcement works but unlinking doesn’t, I’d bet it to be a firewall issue and not a admin issue. Make sure the pi has ALL allowance in your firewall.
    Dirk

    Comment


    • #3
      If HS3 is running as administrator, then all the plugins (including Sonos) will also run as administrator. You can verify HS3 is running as administrator by right clicking the HS3 shortcut and clicking "Run as Administrator".

      From what I have seen on this forum, the majority of issues people have with the Sonos plugin are Windows Firewall related, so I would check into that. First, just disable it altogether and see if problems go away. If so, and if you would rather have Windows Firewall running, then we can work on getting the proper exceptions configured.

      Comment


      • #4
        Thanks for the super-quick answers! I disabled the firewall, and things are better (not perfect). Music now resumes, although where it restarts the queue seems to be a bit random (a three times it went to the start of the queue, a couple of times it restarted a few seconds before where it left off for the message, once it didn't restart).

        This PC is dedicated to home automation, so firewall isn't critical for me (although I do feel a little bit bad turning it off).

        I'll have a further play and see if I can work out exactly what is happening. Thanks for putting me on the right track.

        Comment


        • #5
          Originally posted by boardgamer View Post
          Thanks for the super-quick answers! I disabled the firewall, and things are better (not perfect). Music now resumes, although where it restarts the queue seems to be a bit random (a three times it went to the start of the queue, a couple of times it restarted a few seconds before where it left off for the message, once it didn't restart).

          This PC is dedicated to home automation, so firewall isn't critical for me (although I do feel a little bit bad turning it off).

          I'll have a further play and see if I can work out exactly what is happening. Thanks for putting me on the right track.
          Don’t turn off the firewall!! Allow the hspi_sonos.exe to have outgoing and incoming allowances!
          Can’t comment on the erratic behavior where it resumes but do note that premium services cannot typically resume where they left off and for this PI to resume properly it needs to know where it was properly before the TTS. If you just disabled the firewall there is a lot of info still missing in the pi so restart the pi or HS to make sure that all info was received and not dropped by the firewall.
          Dirk

          Comment


          • #6
            OK I configured the firewall to allow the Sonos PI app through (I only had the choice of Public or Private, so I ticked both). Is that the same as giving a specific exe file i/c & o/g permission?? (You are dealing with a windows numbskull here....). Afterwards, I tried an announcement about 5 times, and each time, it worked perfectly! (I was just playing music tracks from my NAS, so no premium services involved.) I'll keep testing in the new config. I haven't given the box a restart yet, but I will if anything isn't behaving. Thanks again!

            Comment

            Working...
            X