Announcement

Collapse
No announcement yet.

Plugin trouble

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Plugin trouble

    Have had some trouble with the plugin lately.
    using the TTS function, it stops half way in the first word.
    The sentence is not completed.
    Don't know what the problem can be, because I haven't done any changes lately.

  • #2
    Originally posted by Groot View Post
    Have had some trouble with the plugin lately.
    using the TTS function, it stops half way in the first word.
    The sentence is not completed.
    Don't know what the problem can be, because I haven't done any changes lately.
    Can you attach a log file?

    Comment


    • #3
      Originally posted by dcorsus View Post

      Can you attach a log file?
      Off course.

      I turned on "Debug Flag" and then ran an notification/TTS event.
      Click image for larger version

Name:	Capture.JPG
Views:	11
Size:	43.0 KB
ID:	1290413

      The TTS stopped after "Hi, Don't........"

      My linkgroup setup:
      Click image for larger version

Name:	Capture.JPG
Views:	9
Size:	49.8 KB
ID:	1290414


      I don't understand what all this means, but here you go.
      Hope you are able to get something useful out of this.

      The log had to many characters for a forum post, so I added it as a txt.
      [ATTACH]n1290415[/ATTACH]

      Comment


      • #4
        Originally posted by Groot View Post

        Off course.

        I turned on "Debug Flag" and then ran an notification/TTS event.
        Click image for larger version

Name:	Capture.JPG
Views:	11
Size:	43.0 KB
ID:	1290413

        The TTS stopped after "Hi, Don't........"

        My linkgroup setup:
        Click image for larger version

Name:	Capture.JPG
Views:	9
Size:	49.8 KB
ID:	1290414


        I don't understand what all this means, but here you go.
        Hope you are able to get something useful out of this.

        The log had to many characters for a forum post, so I added it as a txt.
        [ATTACH]n1290415[/ATTACH]
        Can you check your other events. As soon as the announcement starts I see some event to stop a player
        mar-06 20:58:19 Event Event Trigger "Video/audio Radio på bad - AV"

        Comment


        • #5
          What network equipment are you using? If UniFi you’ll need to make some changes. See this post https://forums.homeseer.com/forum/me...network-matrix

          Once we tuned our network, the announcements are extremely reliable.
          Michael

          HS3 Pro 3.0.0.470 | 849 devices | 349 events | OpenSprinkler | BLShutdown | EasyTrigger | NetCAM | Harmony Hub | Sonos | SDJ-Health | BLUPS | PHLocation | BLBackup | BLLock | Z-Wave 3.0.1.243 | weatherXML | Pushover 3P | Blue-Iris | AirPlaySpeak

          Comment


          • #6
            Originally posted by dcorsus View Post

            Can you check your other events. As soon as the announcement starts I see some event to stop a player
            mar-06 20:58:19 Event Event Trigger "Video/audio Radio på bad - AV"
            That seams to be the problem

            It is a event that should stop the music played in the bathroom when there have been no motion in there for the last 5 minutes.
            Don't know why it stops the TTS though.
            Click image for larger version

Name:	Capture.JPG
Views:	9
Size:	44.1 KB
ID:	1290656

            Since the condition and the action is set to Bad(Bathroom), I don't understand why it stops TTS on all speakers?
            Attached Files

            Comment


            • #7
              Originally posted by Rvtravlr View Post
              What network equipment are you using? If UniFi you’ll need to make some changes. See this post https://forums.homeseer.com/forum/me...network-matrix

              Once we tuned our network, the announcements are extremely reliable.
              I DO use UniFi, but that looks to advanced for me at this stage

              Comment


              • #8
                Originally posted by Groot View Post

                That seams to be the problem


                Since the condition and the action is set to Bad(Bathroom), I don't understand why it stops TTS on all speakers?
                Sonos has this implementation, that if players are grouped or paired only one player (I call it the master) accepts commands, all other players (I call them slaves), just ignore commands UNLESS you remove them from the group.
                The PI was designed that when a command is issued to a player AND that player is grouped or paired, that command is automatically forwarded to the master of the group and therefore, in this case, it stops the announcement. Right or wrong, it is AN implementation to serves most users who else complain that events don't work because someone in the household grouped or regrouped players and suddenly events don't work at all.

                Dirk

                Comment


                • #9
                  I see.
                  That's no problem. As long as I have found the fault, I just have to try to work around it.

                  Just have to see if I can come up with another way to have a speaker play a playlist triggered by motion and that stops when people have left the room

                  Comment


                  • #10
                    Originally posted by Groot View Post
                    I see.
                    That's no problem. As long as I have found the fault, I just have to try to work around it.

                    Just have to see if I can come up with another way to have a speaker play a playlist triggered by motion and that stops when people have left the room
                    I think your other event could use some change. Its trigger is more of a condition: if something is more > 5 minutes in a specific state do something .....
                    I tend to make events that check for a state change, say: something goes from motion to no-motion and now add a time component to it, so it becomes if xyz goes from say motion to no-motion for 5 minutes now do xxxx. I think your event just checks if there is no-motion for 5 minutes then stop player ....
                    Makes sense? If you change it to trigger on a state-change, it will not mess up your announcements but do keep in mind if the Bathroom player is grouped you will have other side effect that you may not like. You can get around this by adding a Sonos action to your event(s) to unlink the bathroom player before you issue the action to stop or start playing a playlist based on motion in the bathroom.

                    Dirk

                    Comment


                    • #11
                      Originally posted by Groot View Post

                      I DO use UniFi, but that looks to advanced for me at this stage
                      It was a little daunting for me, too. However, it’s my understanding that, out of the box, UniFi is set for RSTP (reverse spanning tree protocol) and Sonos does not do well with it. If you change your switches to STP and give a priority of 4096 to your first switch, 8192 (4096 x 2) to your second switch, 12288 (4096 x 3) to your third switch down line, etc, you will get considerable ROI for your efforts, which are not much.

                      Click image for larger version  Name:	DFA0AF2D-E2AA-4284-8222-696C5ED4F9B5.png Views:	2 Size:	116.7 KB ID:	1290792
                      Here is our network...

                      Click image for larger version  Name:	934D36D7-D889-4449-B2A2-D05A4EEB3FC7.jpeg Views:	1 Size:	40.8 KB ID:	1290793
                      Michael

                      HS3 Pro 3.0.0.470 | 849 devices | 349 events | OpenSprinkler | BLShutdown | EasyTrigger | NetCAM | Harmony Hub | Sonos | SDJ-Health | BLUPS | PHLocation | BLBackup | BLLock | Z-Wave 3.0.1.243 | weatherXML | Pushover 3P | Blue-Iris | AirPlaySpeak

                      Comment


                      • #12
                        Originally posted by Rvtravlr View Post

                        It was a little daunting for me, too. However, it’s my understanding that, out of the box, UniFi is set for RSTP (reverse spanning tree protocol) and Sonos does not do well with it. If you change your switches to STP and give a priority of 4096 to your first switch, 8192 (4096 x 2) to your second switch, 12288 (4096 x 3) to your third switch down line, etc, you will get considerable ROI for your efforts, which are not much.

                        Click image for larger version Name:	DFA0AF2D-E2AA-4284-8222-696C5ED4F9B5.png Views:	2 Size:	116.7 KB ID:	1290792
                        Here is our network...

                        Click image for larger version Name:	934D36D7-D889-4449-B2A2-D05A4EEB3FC7.jpeg Views:	1 Size:	40.8 KB ID:	1290793
                        Will this have any effect when all my Sonos is using WiFi?

                        Comment


                        • #13
                          Originally posted by dcorsus View Post

                          I think your other event could use some change. Its trigger is more of a condition: if something is more > 5 minutes in a specific state do something .....
                          I tend to make events that check for a state change, say: something goes from motion to no-motion and now add a time component to it, so it becomes if xyz goes from say motion to no-motion for 5 minutes now do xxxx. I think your event just checks if there is no-motion for 5 minutes then stop player ....
                          Makes sense? If you change it to trigger on a state-change, it will not mess up your announcements but do keep in mind if the Bathroom player is grouped you will have other side effect that you may not like. You can get around this by adding a Sonos action to your event(s) to unlink the bathroom player before you issue the action to stop or start playing a playlist based on motion in the bathroom.

                          Dirk
                          I think I understand where you are going with this.
                          I do something similar with my lights. They are based on state changes.
                          Tried to use the same setup with the sonos as with the lights, but I quickly saw that there is no "Delayed Event" feature in the Sonos plugin.

                          But have changed to this now, so will see if this works.
                          Click image for larger version

Name:	Capture.JPG
Views:	9
Size:	27.1 KB
ID:	1291597
                          Attached Files

                          Comment


                          • #14
                            Originally posted by Groot View Post

                            Will this have any effect when all my Sonos is using WiFi?
                            If you are using all wifi, then you are not using SonosNet. I would think that RSTP would then be fine, but not certain.

                            Comment


                            • #15
                              Originally posted by Groot View Post

                              Will this have any effect when all my Sonos is using WiFi?
                              We are all WiFi with no Sonosnet. Implementing the changes helped us.
                              Michael

                              HS3 Pro 3.0.0.470 | 849 devices | 349 events | OpenSprinkler | BLShutdown | EasyTrigger | NetCAM | Harmony Hub | Sonos | SDJ-Health | BLUPS | PHLocation | BLBackup | BLLock | Z-Wave 3.0.1.243 | weatherXML | Pushover 3P | Blue-Iris | AirPlaySpeak

                              Comment

                              Working...
                              X