Announcement

Collapse
No announcement yet.

Plugin Stopped working?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Plugin Stopped working?

    Hi, I noticed in the past week or so, nothing was happening through the Sonos plugin. It was working fine up to that point. I am not aware of anything that might have changed, and i'm the only one in the controller. I'm on a SEL version (Linux). Here's the logs (8 zone system). This all looks normal to me. The last 3 items, I tried to manually change the volume (3x) and nothing happened....

    I've restarted the plugin (included below) and nothing. What else can I look at?
    Mar-16 4:41:39 PM Device Control Device: Sonos Office Volume to Up (1001) by/from: CAPI Control Handler
    Mar-16 4:41:38 PM Device Control Device: Sonos Office Volume to Up (1001) by/from: CAPI Control Handler
    Mar-16 4:41:37 PM Device Control Device: Sonos Office Volume to Up (1001) by/from: CAPI Control Handler
    Mar-16 4:37:52 PM Starting Plug-In Plugin Sonos started successfully in 7 milliseconds
    Mar-16 4:37:52 PM Starting Plug-In Initializing plugin Sonos ...
    Mar-16 4:37:52 PM Info Plugin Sonos with instance RINCON_347E5C00DBAE01400 has connected. IP:127.0.0.1:37693
    Mar-16 4:37:51 PM Starting Plug-In Plugin Sonos started successfully in 7 milliseconds
    Mar-16 4:37:51 PM Starting Plug-In Initializing plugin Sonos ...
    Mar-16 4:37:51 PM Info Plugin Sonos with instance RINCON_949F3EB8265801400 has connected. IP:127.0.0.1:37691
    Mar-16 4:37:50 PM Starting Plug-In Plugin Sonos started successfully in 9 milliseconds
    Mar-16 4:37:50 PM Starting Plug-In Initializing plugin Sonos ...
    Mar-16 4:37:50 PM Info Plugin Sonos with instance RINCON_347E5C00313201400 has connected. IP:127.0.0.1:37689
    Mar-16 4:37:48 PM Starting Plug-In Plugin Sonos started successfully in 7 milliseconds
    Mar-16 4:37:48 PM Starting Plug-In Initializing plugin Sonos ...
    Mar-16 4:37:48 PM Info Plugin Sonos with instance RINCON_347E5C0030FC01400 has connected. IP:127.0.0.1:37687
    Mar-16 4:37:47 PM Starting Plug-In Plugin Sonos started successfully in 8 milliseconds
    Mar-16 4:37:47 PM Starting Plug-In Initializing plugin Sonos ...
    Mar-16 4:37:47 PM Info Plugin Sonos with instance RINCON_949F3EB828F801400 has connected. IP:127.0.0.1:37685
    Mar-16 4:37:46 PM Starting Plug-In Plugin Sonos started successfully in 9 milliseconds
    Mar-16 4:37:46 PM Starting Plug-In Initializing plugin Sonos ...
    Mar-16 4:37:46 PM Info Plugin Sonos with instance RINCON_347E5C00316B01400 has connected. IP:127.0.0.1:37683
    Mar-16 4:37:45 PM Starting Plug-In Plugin Sonos started successfully in 8 milliseconds
    Mar-16 4:37:45 PM Starting Plug-In Initializing plugin Sonos ...
    Mar-16 4:37:45 PM Info Plugin Sonos with instance RINCON_949F3EB84C1601400 has connected. IP:127.0.0.1:37681
    Mar-16 4:37:44 PM Starting Plug-In Plugin Sonos started successfully in 12 milliseconds
    Mar-16 4:37:44 PM Starting Plug-In Initializing plugin Sonos ...
    Mar-16 4:37:44 PM Info Plugin Sonos with instance RINCON_347E5C00315601400 has connected. IP:127.0.0.1:37679
    Mar-16 4:37:01 PM Plug-In Finished initializing plug-in Sonos
    Mar-16 4:37:01 PM Starting Plug-In Sonos loaded in 1006 milliseconds
    Mar-16 4:37:01 PM Starting Plug-In Plugin Sonos started successfully in 196 milliseconds
    Mar-16 4:37:00 PM Starting Plug-In Initializing plugin Sonos ...
    Mar-16 4:37:00 PM Info Plugin Sonos has connected. IP:127.0.0.1:37494
    Mar-16 4:36:49 PM Info Plugin Sonos with instance: has disconnected
    Mar-16 4:36:49 PM Info Plugin Sonos with instance: RINCON_347E5C00DBAE01400 has disconnected
    Mar-16 4:36:49 PM Info Plugin Sonos with instance: RINCON_949F3EB8265801400 has disconnected
    Mar-16 4:36:49 PM Info Plugin Sonos with instance: RINCON_347E5C00313201400 has disconnected
    Mar-16 4:36:49 PM Info Plugin Sonos with instance: RINCON_347E5C0030FC01400 has disconnected
    Mar-16 4:36:49 PM Info Plugin Sonos with instance: RINCON_949F3EB828F801400 has disconnected
    Mar-16 4:36:49 PM Info Plugin Sonos with instance: RINCON_347E5C00316B01400 has disconnected
    Mar-16 4:36:49 PM Info Plugin Sonos with instance: RINCON_949F3EB84C1601400 has disconnected
    Mar-16 4:36:49 PM Info Plugin Sonos with instance: RINCON_347E5C00315601400 has disconnected
    Mar-16 4:36:49 PM Plug-In Shutting down Plug-In: Sonos

  • #2
    oh, and here's my HS3 info:


    Current Date/Time: 3/16/2019 4:49:13 PM
    HomeSeer Version: HS3 Pro Edition 3.0.0.500
    Linux version: Linux hometrollerSEL 3.16.0-031600-generic #201408031935 SMP Sun Aug 3 23:56:17 UTC 2014 i686 i686 i686 GNU/Linux System Uptime: 4 Days 19 Hours 20 Minutes 12 Seconds
    IP Address: 127.0.0.1
    Number of Devices: 671
    Number of Events: 59
    Available Threads: 199
    HSTouch Enabled: True
    Event Threads: 1
    Event Trigger Eval Queue: 0
    Event Trigger Priority Eval Queue: 0
    Device Exec Queue: 0
    HSTouch Event Queue: 0
    Email Send Queue: 0

    Enabled Plug-Ins
    3.0.19.0: BLLock
    2.0.27.0: BLRing
    3.0.0.31: Nest
    3.0.2.20: OMNI
    3.1.0.28: Sonos
    3.0.1.252: Z-Wave

    The reboot was me trying to get the plugin working...

    Comment


    • #3
      can you post the player table (PI's config page at bottom). I you want to post a log first turn the debug log on and then capture log at startup. Wouldn't be surprised that the PI discovered zero players. Network issue?

      Comment


      • #4
        Debug logging was enabled. I was surprised there was not more in the log either. two screenshots. 1) the player table you requested and 2) the log settings. All my Sonos devices are hardwired. My network matrix is all clear... don't "think" it is a network issue....

        Comment


        • #5
          Originally posted by bbos View Post
          Debug logging was enabled. I was surprised there was not more in the log either. two screenshots. 1) the player table you requested and 2) the log settings. All my Sonos devices are hardwired. My network matrix is all clear... don't "think" it is a network issue....
          the player tables shows all ok. Log above is absolutely NOT with debug or superdebug on. It actually shows ZERO log entries from the PI itself. Running multiple instances or some other mistake?

          Comment


          • #6
            Originally posted by bbos View Post
            oh, and here's my HS3 info:


            Current Date/Time: 3/16/2019 4:49:13 PM
            HomeSeer Version: HS3 Pro Edition 3.0.0.500
            Linux version: Linux hometrollerSEL 3.16.0-031600-generic #201408031935 SMP Sun Aug 3 23:56:17 UTC 2014 i686 i686 i686 GNU/Linux System Uptime: 4 Days 19 Hours 20 Minutes 12 Seconds
            IP Address: 127.0.0.1
            Number of Devices: 671
            Number of Events: 59
            Available Threads: 199
            HSTouch Enabled: True
            Event Threads: 1
            Event Trigger Eval Queue: 0
            Event Trigger Priority Eval Queue: 0
            Device Exec Queue: 0
            HSTouch Event Queue: 0
            Email Send Queue: 0

            Enabled Plug-Ins
            3.0.19.0: BLLock
            2.0.27.0: BLRing
            3.0.0.31: Nest
            3.0.2.20: OMNI
            3.1.0.28: Sonos
            3.0.1.252: Z-Wave

            The reboot was me trying to get the plugin working...
            Is it normal that your setup shows that it uses the loopback IP (127.0.0.1)? Did you select a different network setting? This PI only works when you select the subnet that has the Sonos players on it.

            Comment


            • #7
              Ok, restarting the plugin does not appear to trigger the logging changes made on the config page. I restarted the whole system and got these log entries. I do see the one error. As for your question on the network IP, the system is assigned a static IP in my router, but I don't believe i have ever set anything on the HS3 side. Where would I look for that?
              Mar-16 6:09:13 PM Starting Plug-In Plugin Sonos started successfully in 7 milliseconds
              Mar-16 6:09:13 PM Starting Plug-In Initializing plugin Sonos ...
              Mar-16 6:09:13 PM Info Plugin Sonos with instance RINCON_347E5C00DBAE01400 has connected. IP:127.0.0.1:47342
              Mar-16 6:09:12 PM Starting Plug-In Plugin Sonos started successfully in 7 milliseconds
              Mar-16 6:09:12 PM Starting Plug-In Initializing plugin Sonos ...
              Mar-16 6:09:12 PM Info Plugin Sonos with instance RINCON_949F3EB8265801400 has connected. IP:127.0.0.1:47340
              Mar-16 6:09:11 PM Starting Plug-In Plugin Sonos started successfully in 7 milliseconds
              Mar-16 6:09:11 PM Starting Plug-In Initializing plugin Sonos ...
              Mar-16 6:09:10 PM Info Plugin Sonos with instance RINCON_347E5C00313201400 has connected. IP:127.0.0.1:47337
              Mar-16 6:09:10 PM Starting Plug-In Plugin Sonos started successfully in 7 milliseconds
              Mar-16 6:09:10 PM Starting Plug-In Initializing plugin Sonos ...
              Mar-16 6:09:10 PM Starting Plug-In Plugin Sonos started successfully in 16 milliseconds
              Mar-16 6:09:10 PM Starting Plug-In Initializing plugin Sonos ...
              Mar-16 6:09:09 PM Info Plugin Sonos with instance RINCON_347E5C0030FC01400 has connected. IP:127.0.0.1:47335
              Mar-16 6:09:08 PM Info Plugin Sonos with instance RINCON_949F3EB828F801400 has connected. IP:127.0.0.1:47333
              Mar-16 6:09:07 PM Starting Plug-In Plugin Sonos started successfully in 7 milliseconds
              Mar-16 6:09:07 PM Starting Plug-In Initializing plugin Sonos ...
              Mar-16 6:09:07 PM Info Plugin Sonos with instance RINCON_347E5C00316B01400 has connected. IP:127.0.0.1:47330
              Mar-16 6:09:06 PM Starting Plug-In Plugin Sonos started successfully in 6 milliseconds
              Mar-16 6:09:06 PM Starting Plug-In Initializing plugin Sonos ...
              Mar-16 6:09:06 PM Info Plugin Sonos with instance RINCON_949F3EB84C1601400 has connected. IP:127.0.0.1:47328
              Mar-16 6:09:05 PM Starting Plug-In Plugin Sonos started successfully in 10 milliseconds
              Mar-16 6:09:05 PM Starting Plug-In Initializing plugin Sonos ...
              Mar-16 6:09:05 PM Info Plugin Sonos with instance RINCON_347E5C00315601400 has connected. IP:127.0.0.1:47326
              Mar-16 6:09:05 PM Sonos Error Error in BuildHSSonosDevices while finding the zoneplayers : Object reference not set to an instance of an object
              Mar-16 6:08:58 PM Plug-In Finished initializing plug-in Sonos
              Mar-16 6:08:58 PM Starting Plug-In Sonos loaded in 1202 milliseconds
              Mar-16 6:08:58 PM Starting Plug-In Plugin Sonos started successfully in 235 milliseconds
              Mar-16 6:08:58 PM Starting Plug-In Initializing plugin Sonos ...
              Mar-16 6:08:58 PM Info Plugin Sonos has connected. IP:127.0.0.1:47324
              Mar-16 6:08:39 PM Plug-In Found plug-in: Sonos, version: 3.1.0.28
              Mar-16 6:07:38 PM Info Plugin Sonos with instance: has disconnected
              Mar-16 6:07:38 PM Info Plugin Sonos with instance: RINCON_347E5C00DBAE01400 has disconnected
              Mar-16 6:07:38 PM Info Plugin Sonos with instance: RINCON_949F3EB8265801400 has disconnected
              Mar-16 6:07:38 PM Info Plugin Sonos with instance: RINCON_347E5C00313201400 has disconnected
              Mar-16 6:07:38 PM Info Plugin Sonos with instance: RINCON_347E5C0030FC01400 has disconnected
              Mar-16 6:07:38 PM Info Plugin Sonos with instance: RINCON_949F3EB828F801400 has disconnected
              Mar-16 6:07:38 PM Info Plugin Sonos with instance: RINCON_347E5C00316B01400 has disconnected
              Mar-16 6:07:38 PM Info Plugin Sonos with instance: RINCON_949F3EB84C1601400 has disconnected
              Mar-16 6:07:38 PM Info Plugin Sonos with instance: RINCON_347E5C00315601400 has disconnected
              Mar-16 6:07:37 PM Shutdown Shutting down plug-in: Sonos
              Mar-16 6:07:37 PM Shutdown Shutting down plug-in: Sonos
              Mar-16 6:07:37 PM Shutdown Shutting down plug-in: Sonos
              Mar-16 6:07:37 PM Shutdown Shutting down plug-in: Sonos
              Mar-16 6:07:37 PM Shutdown Shutting down plug-in: Sonos
              Mar-16 6:07:37 PM Shutdown Shutting down plug-in: Sonos
              Mar-16 6:07:37 PM Shutdown Shutting down plug-in: Sonos
              Mar-16 6:07:37 PM Shutdown Shutting down plug-in: Sonos
              Mar-16 6:07:37 PM Shutdown Shutting down plug-in: Sonos

              Comment


              • #8
                I am also able to access the web interface for the SEL system using the static IP assigned by the router... I've never noticed it reporting the loopback IP...

                Also, find.homeseer.com finds the system... all Sonos and the SEL are on the same network segment....

                Comment


                • #9
                  Maybe the PI's ini file is corrupt somehow. Without logs, I have no idea what is happening. The error you see, suggest corruption. Nothing happened to this system? I see a fairly new HS version; was this done recently? Power outage perhaps? Deleted some players from the HS devices management page perhaps? What baffles me is that the config page seems to indicate that the debug flag(s) are set, but they are not because the only log there is (the error entry) is an entry that does not check a debug flag.
                  Do you have events and/or other things you created like linkgroups? If not, the easiest way to deal with corruption is to stop HS (!!!!), go to <hs root>\config and delete the sonos.ini file. If you now restart HS, the PI will delete all devices and recreate everything from scratch. Any event will have to be recreated because HS will assign different reference numbers to the newly created devices.

                  Comment


                  • #10
                    If you don't want to delete the .ini file yet, you can post it here and I'll look at it. I also looked up the error, it shows that the discovery object is not existing ... why .... no idea .. result .. no players detected.

                    Comment


                    • #11
                      ok, i'll try that, thx. I'm pretty much in kindergarten with my Ubuntu skills.... what's the easiest way to get to the root directory to delete the sonos.ini file or get a copy to post here? (Thanks for your help)!

                      Comment


                      • #12
                        Suggest you post your Linux questions in the Linux forum. Pete appears to be quite an expert

                        Comment


                        • #13
                          Originally posted by bbos View Post
                          ok, i'll try that, thx. I'm pretty much in kindergarten with my Ubuntu skills.... what's the easiest way to get to the root directory to delete the sonos.ini file or get a copy to post here? (Thanks for your help)!
                          Search for and Download a program called WinSCP.


                          Sent from my SM-N960U using Tapatalk

                          HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
                          Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
                          Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

                          Comment

                          Working...
                          X