Announcement

Collapse
No announcement yet.

Error when playing Apple Music Playlists

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error when playing Apple Music Playlists

    I've added my Apple Music "Favorites Mix" playlist to my Sonos Favorites in hopes of triggering this playlist from events, but every time I run an event with this action, the playlist fails to play and I get the error below...

    Here is the event action:

    Click image for larger version  Name:	Screenshot 2019-05-21 15.44.05.png Views:	0 Size:	7.3 KB ID:	1306415

    And here is the error:

    Code:
    May-21 3:39:23 PM           Sonos Error     ERROR in PlayURI for zoneplayer = Master Bedroom with UPNP Error = Read only tag / Transport is locked / Access denied. URI=x-rincon-cpcontainer:1006206clibraryplaylist%3ap.Ba0YDCeV1r3Y?sid=204&flags=8300&sn=10 and isObjectID = True, MetaData=Favorites Mixobject.container.playlistContainer.#PlaylistViewSA_RINCON52231_X_#Svc52231-0-Token, Error =MyUPnPService.InvokeAction for ServiceID = http://10.3.11.182:1400/xml/AVTransport1.xml while sending Action = SetAVTransportURI for URI = http://10.3.11.182:1400/MediaRenderer/AVTransport/Control and Request = 0 x-rincon-cpcontainer:1006206clibraryplaylist%3ap.Ba0YDCeV1r3Y?sid=204&flags=8300&sn=10 <DIDL-Lite xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/" xmlns:r="urn:schemas-rinconnetworks-com:metadata-1-0/" xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/"><item id="1006206clibraryplaylist%3ap.Ba0YDCeV1r3Y" parentID="10082066libraryfolder%3af.6" restricted="true"><dc:title>Favorites Mix</dc:title><upnp:class>object.container.playlistContainer.#PlaylistView</upnp:class><desc id="cdudn" nameSpace="urn:schemas-rinconnetworks-com:metadata-1-0/">SA_RINCON52231_X_#Svc52231-0-Token</desc></item></DIDL-Lite> UPNP Error = faultcode = s:Client, faultstring = UPnPError, detail = 714 with error = The remote server returned an error: (500) Internal Server Error.

    I also get the same error, and the playlist fails to populate, when I try to play from the HS3 Sonos player page:


    Click image for larger version  Name:	Screenshot 2019-05-21 15.39.57.png Views:	0 Size:	128.2 KB ID:	1306416


    If I initiate the same Apple Music playlist from the Sonos app, it plays fine and the player page populates normally:


    Click image for larger version  Name:	Screenshot 2019-05-21 15.51.07.png Views:	0 Size:	181.8 KB ID:	1306417

    Anyone else have any luck playing Apple Music playlists?

  • #2
    Unfortunately, I don't have Apple Music so I can't test it but it doesn't really surprise me to be honest. I suspect if you were to save the queue, you would be able to select and play it that way, not sure that's what you want to do but I think the result is give or take the same.

    Comment


    • #3
      Originally posted by dcorsus View Post
      Unfortunately, I don't have Apple Music so I can't test it but it doesn't really surprise me to be honest. I suspect if you were to save the queue, you would be able to select and play it that way, not sure that's what you want to do but I think the result is give or take the same.
      The "Favorites Mix" is one of the dynamic playlists that updates periodically based on listening habits (not sure of the update interval, but I think it's weekly for the Favorites Mix). So saving the queue and converting to a static playlist is not desirable in this case.

      Comment


      • #4
        Originally posted by teladog01 View Post

        The "Favorites Mix" is one of the dynamic playlists that updates periodically based on listening habits (not sure of the update interval, but I think it's weekly for the Favorites Mix). So saving the queue and converting to a static playlist is not desirable in this case.
        I figured that would be the case ....

        I'll have a look at it, but suspect without signing up for Apple Music, I won't be able to do anything, let's see if there is a free trial or something ....

        Comment


        • #5
          Originally posted by dcorsus View Post
          I'll have a look at it, but suspect without signing up for Apple Music, I won't be able to do anything, let's see if there is a free trial or something ....
          Yep, Apple Music has a three month free trial if you’ve not signed up before. Thanks very much for looking into this, Dirk. Let me know if you need me to test anything.

          Comment


          • #6
            Just tried it with the PI's player and it works for me. Makes me wonder whether the info that I retrieve from Sonos and put in the DB becomes stale; as you pointed out, the playlists are dynamically.

            Comment


            • #7
              Which PI version are you using and which OS is this running on?

              Comment


              • #8
                HS3 Pro v3.0.0.531, Windows Server 2016, Sonos v3.1.0.28

                Comment


                • #9
                  Originally posted by teladog01 View Post
                  HS3 Pro v3.0.0.531, Windows Server 2016, Sonos v3.1.0.28
                  Not sure what to do next, maybe go back and start from beginning:

                  1/ are other services working? If you go to the PI's player and you select other content, does that work?
                  2/ Assuming all other services work, can you rebuild the Music DB. What is your setting?
                  3/ If that still doesn't work, can you do another "save queue" on the Sonos App. I just realize that I saved this as a queue but used the playlist name to select it and if i did this a few times, the queue content was different so I assumed it did what it was supposed to do. How do you save the playlist to your Sonos favorites?

                  Dirk

                  Comment


                  • #10
                    Never mind, it has been a while but figured out how to add the playlist as a favorite. I now have same error. This has all the hall marks of an authentication thing, where the UPNP info provided doesn't have the right info to play the service, let's see if we get lucky this time .....

                    Comment


                    • #11
                      I just released version .30 under the BETA section of the updater. Can you install it and let me know whether it now works.

                      Comment


                      • #12
                        Originally posted by dcorsus View Post
                        I just released version .30 under the BETA section of the updater. Can you install it and let me know whether it now works.
                        Initial testing looks good, Dirk. The error message is gone and the player page populates the playlist and the music plays as expected. Seems to be working as expected now.

                        Thanks so much for this!

                        Comment

                        Working...
                        X