Announcement

Collapse
No announcement yet.

AquaConnect Plugin Overview

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AquaConnect Plugin Overview

    Description:

    A plugin designed for HomeSeer users who have a Goldline Controls (by Hayward) swimming pool controller and the Aqua Connect Serial Home Automation Interface Module (AQ-CO-SERIAL).

    Basic Features:
    • Creates Devices for all controller buttons
    • Creates additional virtual devices not found on the pool controller (useful for Events):
      • Pool temp
      • Spa temp
      • Chlorinator Setting
      • Spa Heater Setpoint
      • Pool Heater Setpoint
      • Salt Level
      • Heater Status
      • Filter Pump Status (displays speed and RPM for multispeed pump configurations)
      • Solar Temperature (if have Solar Heater installed)
      • Salt Cell Temperature
      • pH and ORP (if have Sense and Dispense unit installed)
    • Has macros for single button adjustments to Spa/Pool heater set point (amazing this feature is not built into controller)
    • Mobile device friendly control screen accessible through HomeSeer with real-time device status.
    • User can configure control screen to display Spa Heater Controls and individual Auxiliary Devices
    • User selectable option to log AquaConnect device changes





    Requirements:
    • HomeSeer Version 3.0.0.0 or higher must be installed.
    • Hayward Aqua Logic or Pro Logic models PS-4, PS-8, PS-8V, and PS-16 pool controllers (with compatible firmware) ***MUST BE "PS" Series Model***
    • AquaConnect serial home automation interface module (model AQ-CO-SERIAL). Note: Plugin is NOT compatible with AquaConnect Home Network (AQ-CO-HOMENET)


    ScreenShots:

    Global Plugin Configuration:


    Device Customization:


    Control Screen:



    Example HSTouch Screen Created with Plugin Devices:
    Last edited by Mister2t; May 12th, 2016, 05:39 PM. Reason: Updated list of features

  • #2
    Praise you!

    Well, I think this will be my ticket to finally moving over to HS3!!! I have HS3 but I have been still running HS2 as I have been waiting for plugins for Insteon Thermostats (solved) and the Goldline controls. I have been using Pete's awesome plugin for HS2 for some time.

    I will give this a whirl... THANK YOU!!!

    -BD

    Comment


    • #3
      Thanks BrunDog. Happy to be the catalyst to push you over the edge to HS3 Let me know how it goes with AquaConnect or if you have any suggestions for improvements.

      Cheers!

      Mike

      Comment


      • #4
        Boom!

        Up and running! My 1st plugin, and so my (likely slow and laborious) transition to HS3 begins. Thank you!!

        I do have one question. My setup has the aquaconnect interfaced to a Global Cache serial -> network adapter. Then, on the server, I have a virtual com port set up, and your plug-in communicates through that. This prevented me from having to run a hardwire from the pool panel outside into the house and generally works beautifully.

        However, every once and again, magical electronical gremlins throw murphy's law dust on my setup, and the somewhere the transmission halts. I think it is a virtual com port software problem as the hardware never needs addressing. I have a watchdog script that runs once an hour (or more if desired) in HS to make sure the data is updating. Specifically, I check that the LCD display has updated recently. If it doesn't, HS runs another script which stops the plugin, kills the virtual com port app, restarts the virtual com port app, then restarts the plugin.

        So my specific question is... what is the script code required to stop and start your plugin? Looking through the (new) help file, I do not see anything generic. The function was specific to the goldline plugin I previously used.

        Thanks in advance!

        -BD

        Comment


        • #5
          I did a quick test and use an event script to try to stop my plugin using a call to the "ShutdownIO" plugin API function...

          Code:
          hs.PluginFunction("AquaConnect", "", "ShutdownIO", nothing)
          which successfully shuts down the AquaConnect plugin, however it appears as though HS3 senses that the plugin executable has stopped and then attempts to restart it immediately.

          I will have to do a little checking to see how we can prevent HS3 from automatically attempting to restart the plugin.

          Comment


          • #6
            BrunDog,

            I found a solution which I tested to work fine...

            "Jon00 Plugin Enable/Disable utility for Homeseer 3"

            If you install his Jon00PluginSet.vben script and call it with an event using

            Sub or Function: "Main"

            Parameters: "AquaConnect;0" to disable
            or
            Parameters: "AquaConnect;1" to disable

            Hope this helps!

            Mike

            Comment


            • #7
              Originally posted by Mister2t View Post
              BrunDog,

              I found a solution which I tested to work fine...

              "Jon00 Plugin Enable/Disable utility for Homeseer 3"

              If you install his Jon00PluginSet.vben script and call it with an event using

              Sub or Function: "Main"

              Parameters: "AquaConnect;0" to disable
              or
              Parameters: "AquaConnect;1" to disable

              Hope this helps!

              Mike
              Mike,

              Thanks! I didn't realize you had responded to this, trying to help me out!

              I had already d/l this, but I am not having any luck for some reason. I keep getting error "Plugin "AquaConnect" not located in plugin list ". I have tried parameters AquaConnect;0 and "AquaConnect;0", aka with and without quotes, but no success no matter what.

              Going to try to research more on the script.

              -BD

              Comment


              • #8
                Hi M2t,

                I have a "hiccup" that I am wondering if you could look into.

                I have events that trigger off the pool salt level changing, or the check system coming ON. But for some reason, when I add the event to trigger off their changes, they start changing every few seconds, even though the values don't actually change. In other words, in device management, the "Last Change" field starts updating every few seconds, although the value is not actually changing. When I delete the event, the Last Change field stops updating.

                Can you take a look and see if this can be fixed? As you could likely understand, this wreaks havoc with event triggers, because they will trigger constantly, not just when the actual device value changes.

                Regards,

                BD
                Last edited by BrunDog; May 20th, 2014, 07:55 AM.

                Comment


                • #9
                  Thanks BD. I tweaked the logic used to update devices to only attempt an update when something has changed...as opposed to whenever the controller sends an update.

                  You should see updated version 3.0.0.9 available in the Manage Plugins page. I would recommend you disable and reenable the plugin to ensure a smooth update.

                  Let me know if this solves your issue.

                  Thanks!

                  Mike

                  Comment


                  • #10
                    Originally posted by Mister2t View Post
                    Thanks BD. I tweaked the logic used to update devices to only attempt an update when something has changed...as opposed to whenever the controller sends an update.

                    You should see updated version 3.0.0.9 available in the Manage Plugins page. I would recommend you disable and reenable the plugin to ensure a smooth update.

                    Let me know if this solves your issue.

                    Thanks!

                    Mike
                    It did! You the man! Brilliant!

                    -BD

                    Comment


                    • #11
                      Now, do you know of a way to disable / enable your plugin via a script or function call? As I mentioned elsewhere, my virtual com port glitches from time to time, and I need to disable the plugin, restart the virtual com port emulator, then restart your plugin. jon00's plugin enable/disable script does not work for some reason, and I need a workaround.

                      Thanks again, will be $$ this shortly.

                      -BD

                      Comment


                      • #12
                        Glad to hear the triggering issue is solved!

                        I have made a posting in the HS3 forum to see if someone has a solution to the autorestart issue I described below.

                        In the mean time... you might want to play with the sequence you described below using "hs.PluginFunction("AquaConnect", "", "ShutdownIO", nothing)" to restart the plugin.
                        kills the virtual com port app, restarts the virtual com port app, then restarts the plugin

                        if you can restart the virtual comport app with AquaConnect still running, then this may work. Can't hurt to give it a shot if you have not tried already.

                        fingers crossed...

                        Comment


                        • #13
                          Aqua Logic AQL-P-4 Unable to send commands

                          Hi Mister2t,

                          Your plugin really impresses me!

                          So, I have the AQL-P-4 model and when I tested the plugin I realized that I can received all data without any issue but I'm unable to send any command to the system. I used the same wires used for the Aqua Logic P-4 Wired Remote Display AQL-WW-P-4 (Version 4.20) and I checked the order of the wires and all seem to be connected properly.

                          I used a software to see the serial port data and I can see the command when I hit the web button. I can't compare the data sent by the Remote Display but I suspect that this model is not compatible with the AQ-CO-SERIAL.

                          I opened the AQ-CO-SERIAL and I say some dip switch probably for the Serial Port configuration but not sure.

                          I want to know if you already tested this model with your plugin.

                          Thanks for your help

                          Mikuni

                          P.S.: I just found a Hayward brochure and he say that tha P-4 do not have the Remote Control VIA Automation

                          See table in the middle.
                          http://www.hayward-pool.ca/pdf/liter...Bro%203.23.pdf

                          Comment


                          • #14
                            Oh No! I'm so sorry to hear that your model is not compatible.

                            I will change the model compatibility list on my plugin to reflect your discovery.

                            There may be some differences between the aqua logic and pro logic. For the prologic's they share the same main board and to switch between the two (PS-4 and PS-8) is a simple swap-out of the local display controller. You may be able to do the same for the aqualogic if you want the remote functionality. But, not sure as I don't have that model.
                            Attached Files

                            Comment


                            • #15
                              Thanks for the quick reply and for the parts list. I will check if it's possible to only change the display to the AQL-PS-4 model, and if it's work I will probably need to replace the remote display also.

                              I don't know why that Hayward make 2 different method to send the data, maybe that it's a little difference because I can receive the data from the main controller and the remote display can send any commands to the main controller.

                              I'm just curious to see the steam data on the RS-485 cable...

                              Comment

                              Working...
                              X