Announcement

Collapse
No announcement yet.

pH and ORP devices and hide buttons

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • pH and ORP devices and hide buttons


  • #2
    Hi Mats,

    Been away on business and finally got a chance to try to implement the new features you suggest below. Give it a shot and let me know how it goes.

    Changes:
    • Added Sense and Dispense configuration option
    • Added option to selectively display Valve and Aux devices on control screen
    • Added Spa configuration option


    Regards,

    Mike
    Attached Files

    Comment


    • #3
      I tried the posted version and I still see the devices being created when I click Update all devices.
      Attached Files
      If it ain't broke, don't fix it!

      Comment


      • #4
        Also, I'm a little confused. Is there no action to turn a pump on or off, only toggle?
        If it ain't broke, don't fix it!

        Comment


        • #5
          I should have probably explained better what the configuration options actually do...

          The devices affected by the "Spa" configuration checkbox will only be the "Spa Temp" and "Spa Heater Setpoint" devices. So, these devices should not get created when you click "Update Devices" unless the "Spa" option is enabled.

          The last section on the configuration menu allows you the select whether or not the device shows up on the control screen...it does not affect whether or not the device gets created.

          You are correct about the toggle feature for the control buttons. The buttons all work the same way as they do as if you were pressing them from the physical control panel.

          Hope this helps,

          Mike

          Comment


          • #6
            Got it. The devices make sense the way you explained them, thank you.

            With respect to the toggling how are you handling events? For instance, I used to have two zwave switches wired to 220V relays to control my pumps. I could have a daily schedule for running my main filter pump, however if I had a party for instance I could run an event that would turn on the pump even if it was at a time when it was normally off, and I wouldn't have to worry about the pump resuming it's normal schedule the next day. With just toggling, isn't it possible to get out of sync? Should I be using the ps4's built in schedule?
            If it ain't broke, don't fix it!

            Comment


            • #7
              I use the built-in ps4 schedule for routine daily pump/filter runs. But, I also use HomeSeer events to do things outside the normal daily schedule.

              See the attached screen shot ..."Start Filter Pump". Once you create a number of these manual events you could assign them to buttons on an HStouch screen to perform the action, or you could just call them from any other automated action. For example if you wanted to ensure the pump was running at a certain time of the day, you could create "time triggered event" that ran the "Start Filer Pump" event.
              Attached Files

              Comment


              • #8
                Thanks for the example, I understand the logic now and should be able to create events for all the scenarios that I'm used to. I've only been using the new system for a couple days as I'm starting up my pool for the season and converting to salt but it looks like the research I did over the winter is really paying off. Having full control of my pool through homeseer is awesome!

                I did notice on the new version that even though I have valve3 unchecked it still shows on the control page.

                Next to create HSTouch screens!
                If it ain't broke, don't fix it!

                Comment


                • #9
                  Thanks for letting me know about the Valve3 issue. I found a problem in the code. try the attached version.

                  On the topic of creating HSTouch screens for the pool controller. In case you were unaware, you can just create a screen that simply displays the AquaConnect control page...it makes your life much easier. Assuming you are happy using that design in your HSTouch.
                  Attached Files

                  Comment


                  • #10
                    Valve3 is still there in the new version.

                    Great idea on hstouch but I don't seam to be able to get the control page to scale properly. I have to either cut off the top or the bottom.
                    Last edited by happnatious1; May 16th, 2015, 02:36 PM.
                    If it ain't broke, don't fix it!

                    Comment


                    • #11
                      Very strange...Just tested mine again and everything is working fine? Only thing I can think of there is to completely remove the AquaConnect installation and then install again from uploader. Then replace the HSPI file using the version I uploaded to try again.

                      The screenshot you showed seems to indicate that css file is missing. Let me know if ac.css is located in html/css/aquaconnect folder. If it is there, I could send you a teamviewer invite, so I could look at your computer realtime to troubleshoot.

                      Either way...I'm sure we will figure it out.

                      Thanks,

                      Mike

                      Comment


                      • #12
                        Also noticed that the latest file I uploaded shows 0 views...which seems to indicate no one has downloaded it yet? Perhaps you uploaded one of the previous versions? Either way...just be sure to use the latest version I posted.

                        Comment


                        • #13
                          ac.css is there, should that be resizing the webpage in hstouch?
                          If it ain't broke, don't fix it!

                          Comment


                          • #14
                            Does the aquaconnect control page look correct when looking at it from a browser? If you resize browser you should see the layout change to accommodate smaller widths.

                            This may also just be an artifact of the hstouch design interface. Have you tried pushing the hstouch project to your device to actually see what it lookalike on it running?

                            Did the valve3 issue get resolved?

                            Comment


                            • #15
                              You are right about the designer screwing up the display, it looks fine on the client.

                              Valve 3 is working properly as well.

                              Thanks for all your help and a terrific plugin!

                              and my apologies to Mats for high jacking this thread.

                              Pool is open!
                              If it ain't broke, don't fix it!

                              Comment

                              Working...
                              X