Announcement

Collapse
No announcement yet.

Plugin crashes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mister2t
    replied
    Hi Mats,

    No idea what could be causing it. Would need to see more diagnostics to be able to help. Suggest you turn on detailed logging and post appropriate sections of the log to help narrow down the cause.

    Thanks,

    Mike

    Leave a comment:


  • Mats2
    replied
    Hi,

    I haven't had many problems with the plugin lately, about one crash per month.
    But, I've now had 6 crashes in November.
    I've not done any changes to the system other than installing Windows updates.

    What could be causing this?

    thanks in advance
    Mats

    Leave a comment:


  • Mats2
    replied
    Hi,

    Today the Aquaplugin crashed again, first one in about a month...
    The log file says:



    It was at 11:13 that I found out and clicked "Close the program" and the plugin restarted.

    Any ideas on what could be causing this?

    regards
    Mats

    Leave a comment:


  • Mats2
    replied
    Hi,

    I've now run this plugin for almost two weeks and not had a crash yet .

    I do see in the log that I've had several of these error messages (12 the past week):
    Aug-29 8:45:07 PM AquaConnect Error: Macro for capturing solar sensor temperature did not get the Default Menu...Aborting


    I'm not sure if the new exception handling is taking care of it when this earlier caused the plug in to crash?

    Since the Plugin doesn't crash, I'm happy !

    thanks
    Mats

    Leave a comment:


  • Mats2
    replied
    Many thanks,

    I've installed this version and re-enabled Solar and Salt.

    I will keep you posted.

    thanks again
    Mats

    Leave a comment:


  • Mister2t
    replied
    One more thing...Go ahead and reenable salt and solar options.

    Leave a comment:


  • Mister2t
    replied
    No clue what could be happening. Before asking you to turn on debug mode and flooding your logs with entries...I added a little more exception handling to the version attached. Just shutdown HS3, replace the file you have with the unzipped version of file attached to this post, and restart HS3. Give that a try and let me know how it goes.

    Thanks,

    Mike
    Attached Files

    Leave a comment:


  • Mats2
    replied
    Hi,

    I've have and have had the Solar temp and Salt options turned off but I got another crash on August 10th 6:48:56 PM.
    I was not home and I was not able to capture this until today.

    The event viewer says:
    Application: HSPI_AQUACONNECT.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.NullReferenceException
    Stack:
    at System.Runtime.Remoting.Messaging.LogicalCallContext.Propaga teIncomingHeadersToCallContext(System.Runtime.Remoting.Messa ging.IMessage)
    at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Syst em.Runtime.Remoting.Proxies.MessageData ByRef, Int32)
    at HomeSeerAPI.IHSApplication.WriteLog(System.String, System.String)
    at HSPI_AQUACONNECT.HSPI.RPollThread()
    at System.Threading.ThreadHelper.ThreadStart_Context(System.Obj ect)
    at System.Threading.ExecutionContext.RunInternal(System.Threadi ng.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
    at System.Threading.ExecutionContext.Run(System.Threading.Execu tionContext, System.Threading.ContextCallback, System.Object, Boolean)
    at System.Threading.ExecutionContext.Run(System.Threading.Execu tionContext, System.Threading.ContextCallback, System.Object)
    at System.Threading.ThreadHelper.ThreadStart()


    Follow by a:

    Faulting application name: HSPI_AQUACONNECT.exe, version: 3.0.2.0, time stamp: 0x56a81152
    Faulting module name: mscorlib.ni.dll, version: 4.0.30319.18444, time stamp: 0x52717edc
    Exception code: 0xc0000005
    Fault offset: 0x00343a42
    Faulting process id: 0x1654
    Faulting application start time: 0x01d1f2ef14e74cab
    Faulting application path: C:\Program Files (x86)\HomeSeer HS3\HSPI_AQUACONNECT.exe
    Faulting module path: C:\Windows\assembly\NativeImages_v4.0.30319_32\mscorlib\ce5f 61c5754789df97be8dc991c47d07\mscorlib.ni.dll
    Report Id: 66c8a088-5f4d-11e6-b631-001e37f30b8e


    The last entry from AquaConnect in the HS3 log is:

    Any thoughts on what could have caused this?

    thanks
    Mats

    Leave a comment:


  • Mats2
    replied

    thanks
    Mats
    Attached Files

    Leave a comment:


  • Mister2t
    replied
    Sorry to hear that. I have not seen this before. Have you changed anything in your configuration? Are there any unusual items being displayed in the display as it cycles through?

    The crash log indicates it could possibly have something to do with the thread which periodically retrieves the Solar Temp / Salt Cell temp devices at predefined intervals. Please share what options you have selected and the interval value from the Global Configuration screen.

    Also...deselect both the Solar Temp and Salt Cell options to see if the errors stop. Obviously this will prevent the devices from being updated.

    Thanks,

    Mike

    Leave a comment:


  • Mats2
    started a topic Plugin crashes

    Plugin crashes

    Hi,

    The past month or two, I've had problems with the Aqua plugin crashing every few days.
    I've attached the Eventlog entries from one occurrence.
    I see a message that the plug in has stopped working (see attached screenshot).
    I press "close the program" and everything goes back to normal.
    Plug in version is 3.0.2
    HS Pro 3.0.0.258

    What can cause this problem?

    thanks in advance
    Mats
    Attached Files
Working...
X