Announcement

Collapse
No announcement yet.

pH and ORP devices

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pH and ORP devices

    Hi Spud,

    I have been using the plug-in for several years and all is great. I plan on adding pH control, however I don't see the devices for pH and ORP created in HS3 by the plugin as I can see in your user guide.

    I plan on adding the Pentair intellichem and connect it to the Suntouch (through the comm port) as indicated in their manual.

    I have a Pentair Suntouch controller connected to the Autelis device.

    The Autelis device has firmware version 1.6.6
    The Autelis plug-in is version: 3.0.0.26
    Homeseer version HS3 Pro Edition 3.0.0.293

    In the log I see:

    INFO CMD SENT: http://10.0.0.123:80/chem.xml?

    then

    DEBUG 1 0 0 0 0 00,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0 ,0,0,0,128,0,2,0,0,0,0,0

    Through the Autelis web page I see the value of pH and ORP as zero, shouldn't I have a device pH = 0 and ORP =0?

    As always thanks for your help

    Chris

    Click image for larger version

Name:	ph.png
Views:	36
Size:	2.9 KB
ID:	1303646
    Attached Files

  • #2
    Hi Spud,

    I updated the Autelis firmware to the latest which is 1.6.7, restarted the plug-in and it didn't create the pH and ORP devices.

    Thanks
    Chris

    Comment


    • #3
      I can't really see what's going with the log line you posted because HS is stripping out the xml tags.

      Could you either
      paste this url in a browser: http://10.0.0.123:80/chem.xml? and post the reponse you get
      or
      enable log to file and post the content of Logs/Autelis.txt

      thanks

      Comment


      • #4
        Hi ,

        I used the browser and got this response.

        <response>
        <chlor>
        <chloren>0</chloren>
        <poolsp/>
        <spasp/>
        <salt/>
        <super/>
        <chlorerr/>
        <chlorname/>
        </chlor>
        <ichem>
        0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0, 0,0,0,128,0,2,0,0,0,0,0
        </ichem>
        </response>


        Thanks for your help,

        Chris

        Comment


        • #5
          I tried to simulate this on my system by importing the xml you posted, and I successfully got the pH and ORP devices created :Click image for larger version

Name:	chem_devices.png
Views:	37
Size:	23.8 KB
ID:	1303867

          In the config page you have type set to "Pentair Intellitouch , EasyTouch or SunTouch" right?

          Are you sure the device are not created? make sure the filters on the device management are not hiding them

          Comment


          • #6
            1000 Apologies, yes they had been created and they had been "filtered" on the device management page.

            Sorry to bother you...a rookie mistake by someone who should know better.

            Thanks
            Chris

            Comment

            Working...
            X