Announcement

Collapse
No announcement yet.

Autelis Pool Control Plug-in - Beta Testing

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • lpcalcaterra
    replied
    Yes that is correct. That is how the app works. Even the Haywood wireless controller works in that fashion. Looks like it is a Hayward limitation.

    I will attempt to create some events to simulate direct button push.

    Leave a comment:


  • spud
    replied
    Originally posted by lpcalcaterra View Post
    Is there a way to create buttons or a dropdown for the valves. Currently, the only option is next. I tried editing the the status graphics of the valve device to add button for pool / spa / spillover, but no change. ??
    unfortunately the only available control is to cycle through the options. I guess it's the same thing in the Autelis app, right?

    Leave a comment:


  • lpcalcaterra
    replied
    Dropdown or buttons for valves

    Is there a way to create buttons or a dropdown for the valves. Currently, the only option is next. I tried editing the the status graphics of the valve device to add button for pool / spa / spillover, but no change. ??

    Leave a comment:


  • spud
    replied
    Originally posted by steveng View Post
    I get 404: File not found for both files

    and I assume you were talking about Autelis IP not homeseer (but i tried it too)

    Thanks
    Steven G
    then I guess the answer to both your questions is no.
    Anyway, I will confirm with Autelis directly.

    Leave a comment:


  • steveng
    replied
    I get 404: File not found for both files

    and I assume you were talking about Autelis IP not homeseer (but i tried it too)

    Thanks
    Steven G

    Leave a comment:


  • spud
    replied
    Originally posted by steveng View Post
    Hey,

    Just got my Autelis for Hayward/Goldline and everything works great

    Few questions:
    1) can the device be named per Autelis app entry?
    2) I have a salt cell can we get Salt Level?

    Thanks, Steven G
    could you paste the following urls in a browser (replacing "your.ip.address" by the actual ip address of your Autelis controller) and post the xml results:
    http://your.ip.address/names.xml
    http://your.ip.address/chem.xml

    thanks

    Leave a comment:


  • steveng
    replied
    Hey,

    Just got my Autelis for Hayward/Goldline and everything works great

    Few questions:
    1) can the device be named per Autelis app entry?
    2) I have a salt cell can we get Salt Level?

    Thanks, Steven G

    Leave a comment:


  • mmagri
    replied
    Thanks

    Understood! Thanks!

    Leave a comment:


  • mmagri
    replied
    Additional info

    Logs
    _________________________________

    Oct-28 9:41:01 AM Autelis DEBUG 1.0.2 1477665658
    Oct-28 9:41:01 AM Plug-In Finished initializing plug-in Autelis
    Oct-28 9:41:01 AM Autelis INFO CMD SENT: http://192.168.2.18:80/status.xml?
    Oct-28 9:41:01 AM Autelis INFO Autelis version 3.0.0.8
    Oct-28 9:41:00 AM Info Plugin Autelis has connected. IP:127.0.0.1:54356
    Oct-28 9:41:00 AM Plug-In Interface Autelis is running as a trial, 30 days remaining.
    Oct-28 9:40:25 AM Info Plugin Autelis with instance: has disconnected
    Oct-28 9:40:25 AM Plug-In Shutting down Plug-In: Autelis

    --------
    http://192.168.2.18/status.xml?
    <?xml version="1.0"?>
    -<response>

    -<system>
    <version>1.0.2</version>
    <time>1477665714</time>
    </system>
    </response>

    Leave a comment:


  • spud
    replied
    Originally posted by mmagri View Post
    Here you go.

    Not so verbose ... Please let me know if you need anything else ...

    Trying it before I buy it.

    Thanks.

    Oct-28 7:29:32 AM Autelis DEBUG 1.0.2 1477657768

    Oct-28 7:29:32 AM Autelis INFO CMD SENT: http://192.168.2.18:80/status.xml?

    Oct-28 7:28:32 AM Plug-In Finished initializing plug-in Autelis

    Oct-28 7:28:32 AM Autelis DEBUG 1.0.2 1477657708

    Oct-28 7:28:32 AM Autelis INFO CMD SENT: http://192.168.2.18:80/status.xml?

    Oct-28 7:28:32 AM Autelis INFO Autelis version 3.0.0.8

    Oct-28 7:28:32 AM Info Plugin Autelis has connected. IP:127.0.0.1:61628

    Oct-28 7:28:32 AM Plug-In Interface Autelis is running as a trial, 30 days remaining.

    Oct-28 7:28:26 AM Plug-In Shutting down Plug-In: Autelis



    http://192.168.2.18/status.xml?

    <?xml version="1.0"?>

    -<response>


    -<system>

    <version>1.0.2</version>

    <time>1477657750</time>

    </system>

    </response>
    The problem is that the PDA system does not support the API, read this thread: http://board.homeseer.com/showthread.php?t=173677

    Leave a comment:


  • mmagri
    replied
    Autelis Pool Control and Setup (additional info)

    Here you go.

    Not so verbose ... Please let me know if you need anything else ...

    Trying it before I buy it.

    Thanks.

    Oct-28 7:29:32 AM Autelis DEBUG 1.0.2 1477657768

    Oct-28 7:29:32 AM Autelis INFO CMD SENT: http://192.168.2.18:80/status.xml?

    Oct-28 7:28:32 AM Plug-In Finished initializing plug-in Autelis

    Oct-28 7:28:32 AM Autelis DEBUG 1.0.2 1477657708

    Oct-28 7:28:32 AM Autelis INFO CMD SENT: http://192.168.2.18:80/status.xml?

    Oct-28 7:28:32 AM Autelis INFO Autelis version 3.0.0.8

    Oct-28 7:28:32 AM Info Plugin Autelis has connected. IP:127.0.0.1:61628

    Oct-28 7:28:32 AM Plug-In Interface Autelis is running as a trial, 30 days remaining.

    Oct-28 7:28:26 AM Plug-In Shutting down Plug-In: Autelis



    http://192.168.2.18/status.xml?

    <?xml version="1.0"?>

    -<response>


    -<system>

    <version>1.0.2</version>

    <time>1477657750</time>

    </system>

    </response>

    Leave a comment:


  • spud
    replied
    Originally posted by mmagri View Post
    Hello,

    I have just installed an Autelis Pool Control For Jandy/Zodiac PDA module. I have installed your plugin and configured as shown below:

    Autelis Settings
    Type: Jandy/Zodiac
    IP Address: 192.168.2.18
    Port: 80
    Password: *******
    General Settings
    Poll for status every: 1 minutes
    Log Level: Debug

    I see on the logs:
    Oct-27 7:29:40 PM Autelis DEBUG 1.0.2 1477614576
    Oct-27 7:29:40 PM Autelis INFO CMD SENT: http://192.168.2.18:80/status.xml?

    So, that means the connectivity is good.

    However, HomeSeer did not create my device. Any idea:
    Unknown Autelis Root

    Am I missing anything?

    Thanks,

    Marcus
    can you restart the plugin and post all the debug logs you get

    also what do you get when you paste this url in a browser running on your HS3 server: http://192.168.2.18:80/status.xml

    Leave a comment:


  • mmagri
    replied
    Autelis Pool Control and Setup

    Hello,

    I have just installed an Autelis Pool Control For Jandy/Zodiac PDA module. I have installed your plugin and configured as shown below:

    Autelis Settings
    Type: Jandy/Zodiac
    IP Address: 192.168.2.18
    Port: 80
    Password: *******
    General Settings
    Poll for status every: 1 minutes
    Log Level: Debug

    I see on the logs:
    Oct-27 7:29:40 PM Autelis DEBUG 1.0.2 1477614576
    Oct-27 7:29:40 PM Autelis INFO CMD SENT: http://192.168.2.18:80/status.xml?

    So, that means the connectivity is good.

    However, HomeSeer did not create my device. Any idea:
    Unknown Autelis Root

    Am I missing anything?

    Thanks,

    Marcus

    Leave a comment:


  • zsima
    replied
    Thanks for the quick reply.

    I didn't see the + or - at the bottom of the list. I thought it only takes a
    specific number.

    Works fine Thanks again

    Leave a comment:


  • spud
    replied
    Originally posted by zsima View Post
    Hi Spudd

    I have your plugin installed and working.

    If I would want to set up an immediate command ( or a script) to say (for example)
    raise pool temperature setting

    is there a way of doing that?

    I tried an immedicate command of " http://192.168.1.189:80set.cgi?name=poolsp&temp=up " but got the following in the log

    Action of Control a Device could not be carried out because its configuration is not complete.

    Thanks
    Why don't you use the "-" and "+" controls attached to the pool setpoint device.
    You can use them from an event using the "Control A device" action

    Leave a comment:

Working...
X