Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Feature request - intellichlor/intellichem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • lakemirror
    replied
    Originally posted by lakemirror View Post
    3.0.0.11 did the trick. Chlorinator on/off now shows the correct status text. Can I assume that if there's an error it will show up there also, as in your screenprint above?
    You can ignore that question. I see that it does....when the pump shut off, the chlorinator text status shows "CheckFlowPCB".

    Leave a comment:


  • lakemirror
    replied
    3.0.0.11 did the trick. Chlorinator on/off now shows the correct status text. Can I assume that if there's an error it will show up there also, as in your screenprint above?

    Thanks for the link to the lag time tips. I'll do some tweaking tonight.

    Thanks also for getting this done for me (us).

    Tom

    Leave a comment:


  • spud
    replied
    here is version 3.0.0.11, that should fix the status of the chlorinator device

    regarding the refresh delays, there are 2 settings you can try to adjust to make things better: the polling frequency from the config page and the refresh_status_delay that you can set from the ini file read this: https://forums.homeseer.com/showthread.php?t=184881

    also if refreshing the browser page fixes the problem then probably the problem is with HS3 itself or the browser.

    Thank you for all the tests. Next time please post debug logs along with the description of the problem.

    Leave a comment:


  • lakemirror
    replied
    Originally posted by spud View Post
    Could you test again with version 3.0.0.10
    thanks!
    Upgraded successfully to 3.0.0.10

    Able to turn chlorinator on and off from plugin, verified via Autelis. The status icon changes from yellow to dark, but the status text stays stuck at "ON:OK" no matter if the chlorinator is on or off. I get an error in the log that reads "cannot parse chlorerr value".

    Able to change setpoints of pool and spa chlorination levels from the plugin, verified via Autelis. However, at times there is a significant lag time between changing the value in the plugin and it showing in Autelis. Same is true if I change the value via Autelis; sometimes it takes a long time to reflect the new value in the plugin. Sometimes it never changes the value in the plugin, and I have to refresh the browser page to get it to show the value that is set in the Autelis.

    Also, at times the plugin stops accepting changes, either to values or on/off. I have to refresh the plugin browser page to get it to work again. For example, I change the spa value in the plugin from 4% to 10% and the change never takes place. I get the "cannot parse chlorerr value" in the log. I refresh the browser page and once again I can change the values.

    Hope this helps.

    Tom

    Leave a comment:


  • lakemirror
    replied
    Wilco!

    Leave a comment:


  • spud
    replied
    Could you test again with version 3.0.0.10
    thanks!

    Leave a comment:


  • lakemirror
    replied
    No, sorry, they don't. Like the others, though, they do reflect the status correctly if changes are made elsewhere.

    Leave a comment:


  • spud
    replied
    do the on/off controls for chlorinator work?

    Leave a comment:


  • lakemirror
    replied
    Thanks for doing this, Spud!

    The status displays (chlorinator on, pool and spa chlorination setpoints, salt level, pH, SI and ORP) all agree with the displays on the panel and directly from the Autelis.

    However, when I tried to change the spa and pool chlorination setpoints, I got no response. The status display on the plugin never changed, nor did the status displays on the panel or direct from the Autelis.

    Anything you want me to try from this end?

    Thanks again, BTW.

    Edit: If I change chlorination setpoints directly through Autelis, the change shows up in the plugin. Just can't change from the plugin.

    Leave a comment:


  • spud
    replied
    it's implemented in version 3.0.0.9 available here. You should see new devices as in the screenshot below. Please test (in particular the controls to change chlorination setpoint) and let me know. Thanks!

    Click image for larger version

Name:	chemistry_Devices.png
Views:	2
Size:	41.0 KB
ID:	1188906

    Leave a comment:


  • lakemirror
    replied
    Originally posted by clafa View Post
    Tom,

    Yes Its a thought but for only measuring, again $800 is an overkill. I may go the Arduino route for around $200.

    Let me know how yours end up working..you never know I may find a used intellichem at some point.

    thanks
    Chris
    If you're asking how the intellichem works, so far so good. Installed with new pool in July so 6 months now. It injects the acid upstream from the salt chlorine generator so the cell gets an automatic de-scaling. I'm happy with it.

    Tom

    Leave a comment:


  • clafa
    replied
    Its a thought

    Tom,

    Yes Its a thought but for only measuring, again $800 is an overkill. I may go the Arduino route for around $200.

    Let me know how yours end up working..you never know I may find a used intellichem at some point.

    thanks
    Chris

    Leave a comment:


  • lakemirror
    replied
    Originally posted by spud View Post
    FYI, it's in the works, I have the new chemistry devices (pH, ORP, SI, etc...) implemented, I'm just waiting they tell me how I can change the chlorination setpoints from the API before I release the new version of the plugin.
    Spud, that's great news. Looking forward to seeing it!

    Tom

    Leave a comment:


  • lakemirror
    replied
    Originally posted by clafa View Post
    Tom,

    What setup do you have?
    Easy touch connected to a Pentair intellichem and a pentair intellichlor?

    I have been very interested in reading pH values but the $850 cost for an Intellichem is the negative part for me.

    I have a non salt, non chlorine pool (its ecosmart) and I only need to check pH and Water hardness.

    I also have a suntouch connected to an Autelis device to capture temps (air and water) and some day I will setup my variable pump.

    Thanks
    Chris


    Sent from my iPhone using Tapatalk
    Yes, that's my setup. I have the Autelis wired into the Easy Touch controller and my LAN. So far the intellichem has worked flawlessly (after some tweaking with setup) and keeps my pool within the pH range it's set for.

    Are you saying you'd use the intellichem just to monitor pH?

    Leave a comment:


  • clafa
    replied
    Tom,

    What setup do you have?
    Easy touch connected to a Pentair intellichem and a pentair intellichlor?

    I have been very interested in reading pH values but the $850 cost for an Intellichem is the negative part for me.

    I have a non salt, non chlorine pool (its ecosmart) and I only need to check pH and Water hardness.

    I also have a suntouch connected to an Autelis device to capture temps (air and water) and some day I will setup my variable pump.

    Thanks
    Chris


    Sent from my iPhone using Tapatalk

    Leave a comment:

Working...
X