Announcement

Collapse
No announcement yet.

Plugin Status Incorrect

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Plugin Status Incorrect

    Matt,

    Yesterday I noticed the plugin shows Freeze Protection as being on, even though it is not. I tried re-initializing the plugin, but same result. I also uninstalled it, restarted HS3, then reinstalled, with same result. You can see the status shows no devices are on. Screenshot attached here.

    Let me know if there is something you need from me to help in troubleshooting. Thank you.
    MD
    Click image for larger version

Name:	Screenshot 2020-01-23 13.40.50.png
Views:	40
Size:	322.1 KB
ID:	1356097
    Attached Files

  • #2
    Hi Mdavison,

    Yep this one was my bad, there was a typo... Some systems report "" and some report "0" so it caught both and took them as "Off", However when it set the device it said anything thats not "" is "On".... Apologies for that... My Fault.

    All fixed and released in Beta 1.2.0.3

    Please let me know if there are any issues.

    Thanks.
    Mat

    Comment


    • #3
      That fixed the error. Will let you know next time it kicks in that it shows it working correctly. Might be a few days before our temperatures in NC go back down.

      Comment


      • #4
        Freeze Protection status is working correctly, as we had a 25 degF night last night and the pump is on, and status is Freeze Protection. Just saw the new beta, have installed it, and will let you know of any issues. Thanks for getting this done!

        Comment


        • #5
          I’m getting events based on status now! Thanks for getting that fixed! This is going to be a great app with lots of uses. Thanks!

          Comment


          • #6
            Hi Mdavison,

            Thanks for the feedback, Can you check one thing for me, Are you getting double triggers for your events? Tahl another user has reported his events triggering twice.

            Thanks
            Mat

            Comment


            • #7
              Hi Matt,

              I am NOT having double triggers on my events.

              On another subject - the light colors - I've determined that "ON" does nothing for the lights. The "OFF" and colors work, but having an event that turns the lights on, or just turning them"ON", does not work, at least not for my Jandy LEDs. And on my iAquaLink app, when I go to turn on the lights, I only have "OFF" and the colors as options,but no ON. I'm thinking that's because it cycles through the colors each time until it reaches the color that is selected. Don't know why it is not smart enough to remember the last color selected, but mine does not. But maybe there are other lights out there that are not LEDs and use the ON function.

              Anyway, everything seems to be working for me as of now! Thanks again.

              Comment

              Working...
              X