No announcement yet.

spa_temp device missing

  • Filter
  • Time
  • Show
Clear All
new posts

    spa_temp device missing

    I know Mat has bowed out with respect to this plugin (and don't blame him) but I am looking to resolve an issue with a missing spa_temp device. Hopefully someone else has run into this issue. The "spa_temp" check box is available on the plugin config screen.

    I have created some pool and spa graphing charts using Jon00's graphing utility to monitor and display the various pool and spa setpoints, temperatures and equipment status using the iAqualink plugin as the data source.

    The pool system is a "pool/spa combined spillover" system with a single VS pump and heater. Normal operation is pool mode but can be configured to isolate spa with the valves reconfigured to convert to spa heat where VS pump and heater are diverted to the spa only. All pool mode related plugin devices and data are available and function as desired. The issue arises when the system is switched to the spa mode.

    Although there is a "spa_temp" device listed in the plugin configuration the device is missing or not actually created when the plugin is started. The spa_temp data is present and accurate in the debug files under the home screen section. So the question is how do you get access to a device that contains the spa temp data (when the spa is running in the spa mode). I realize the spa water temp and pool water temp go inactive (or not displayed in the app) when the mode is switched with only the active mode (pool or spa water temp) displayed depending on the system mode called up by the app.

    Any ideas or help would be appreciated

    Have you checked to make sure it is not hidden? Easy to just do a show all, unhide all devices, and ctrl-f just to make sure you see everything with the word spa in it. I have a pool/spa with a similar set up and it works as it should. As you note the devices don't update unless the relevant mode is on.


      Thanks for the response. I did check to see if hidden but not there.

      May try to delete all iAqualink devices and rebuild from scratch.

      It is odd as I can enable an unused AUX feature in the plugin and the the plugin creates the device but the “spa_temp” device doesn’t behave the same way.

      Edit: I'm beginning to think it is an issue in the code since the "spa_temp" box is at the top of the list in the config section and is the only box with the "xxx_xxxx" format.

      Sent from my iPhone using Tapatalk


        I only know enough to be dangerous, but maybe it is a corrupt config file. Take a look at the config file hspi_zodiac.ini and make sure you have the right entry there.

        Pool / Spa - XXXXX - Pool Temp=true
        Pool / Spa - XXXXX- Spa Temp=true
        Pool / Spa - XXXXX - Air Temp=true
        Pool / Spa - XXXXX - Spa Temp Setting=true
        Pool / Spa - XXXXX - Pool Temp Setting=true


          Good idea but the entry

          "Pool / Spa - XXXXX - spa_temp=true"

          is first of the enabling structure in the hspi_zodiac.ini file.

          It cycles to "false" if the box on the config page is disabled.

          However, my line entry is "spa_temp=true" vs your example "Spa Temp=true". But the actual data from the home screen inquiry in the debug file for the spa water temp is

          12/6/2021 11:29:01 AM Start of Message
          {"message":"","home_screen":[{"status":"Online"},{"response":"AQU='70','0B 00 01 02 03 05 06 07 09 0E 0F 1A 01 00 01 01 00 48 00 65 00 38 00 56 00 00 00'"},{"system_type":"0"},{"temp_scale":"F"},{"spa_temp":"86 "},{"pool_temp":""},{"air_temp":"56"},{"spa_set_point":"101" },{"pool_set_point":"72"},{"cover_pool":""},{"freeze_protec t ion":"0"},{"spa_pump":"1"},{"pool_pump":"1"},{"spa_heater": " 1"},{"pool_heater":"0"},{"solar_heater":""},{"spa_salinit y": ""},{"pool_salinity":""},{"orp":""},{"ph":""}]}
          End of Message

          so... the "spa_temp" variable scraped seems correct


            Hi Cbryan,

            From memory the Temps only populate when Pool has a temp in it... But i may be wrong.

            If your willing to share a login to your system i can debug and fix it for you. Best way is to change your password to a temp pass and then change it back when im done.... If your willing flick me a private message.



              You are correct. The temps only show up in app depending on mode and the filter pump must be running.

              When I configure there is a "spa_temp" box but it really doesn't do anything even though the debug shows data available.

              Will PM you with access.



                Hi Mat

                PM'd you a pool log in. Just making sure you received and the pool system login was what is requested.




                  Were you able to fix this? I'm having the same issue. The setting is in the ini file, no devices are hidden..


                    Well... it's back... not sure what I did...