Announcement

Collapse
No announcement yet.

BLRoombaWifi

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can you turn on debug logging and capture that happening
    Then turn off debug logging and attach the log zipped
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • Bob, the graphic at the top was set to "Genny" then when I went to Lucie event and changed the its name to Lucie, Genny's event changed to Luice. Mike
      Attached Files
      Computer: CUK Intel NUC7i7BNH
      Op System: Windows 10 Pro - Work Station
      HS Version: HS3 Pro Edition 3.0.0.435

      Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

      Comment


      • Hmmm ok - let me check into it
        Cheers,
        Bob
        Web site | Help Desk | Feature Requests | Message Board

        Comment


        • Bob, This sounds a lot like "No good deed (your efforts) goes unpunished!", Mike
          Computer: CUK Intel NUC7i7BNH
          Op System: Windows 10 Pro - Work Station
          HS Version: HS3 Pro Edition 3.0.0.435

          Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

          Comment


          • Yea it would not be the first time lol

            Try out 2.0.29 in the beta section
            I would delete the existing events first, then load the beta and re-create them
            It is hard for me to test because I only have one Roomba
            Let me know
            Cheers,
            Bob
            Web site | Help Desk | Feature Requests | Message Board

            Comment


            • Bob, sorry for the lag in response, v.29 works as advertised, I just purchased a 3rd Roomba (i7) I noticed that when I attempted to get the password of the i7 the Dorita screen was abbreviated from my usual 980 display but it did provide the i7's password. I also noticed that my two 980 populated their devices immediately, but the i7 did not sure if there's something I need to do in order to wake the i7 up? (tomorrows problem). One additional observation is that after you add a new Robot you are unable to modify the Password field in any Roomba Robot also the password field nomenclature is missing. Mike
              Computer: CUK Intel NUC7i7BNH
              Op System: Windows 10 Pro - Work Station
              HS Version: HS3 Pro Edition 3.0.0.435

              Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

              Comment


              • Try out 2.0.30 in the beta section - should fix password issue
                Cheers,
                Bob
                Web site | Help Desk | Feature Requests | Message Board

                Comment


                • Bob, have downloaded your v.30, and now see the "Password:" nomenclature +1, however if you hover and select your cursor over the Password field (in order to update it) you do not get a "Edit Value" box to change/update ones Password. I do get "Edit Value" boxes for Name:, IP Address: and Username/Blid: and have confirm the same for my two other Roomba Robots.

                  i7 Roomba still doesn't seem to communicate with Roomba PI, it does create the same devices (as expected) but the i7 Robot devices are all empty even though I can communicate with the IOS app and command the i7 to do all things it looks like S/W version 1.6.6 is the latest for (Aug 19) also it appears that the Clean Base (base plus vacuum) has software associated with it S/W version is 0.10.20 for (Aug 19). Mike
                  Computer: CUK Intel NUC7i7BNH
                  Op System: Windows 10 Pro - Work Station
                  HS Version: HS3 Pro Edition 3.0.0.435

                  Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                  Comment


                  • Well that is odd - mine does it too
                    It works on an add for me
                    Very odd
                    Cheers,
                    Bob
                    Web site | Help Desk | Feature Requests | Message Board

                    Comment


                    • Try 2.0.31 in the beta section
                      Cheers,
                      Bob
                      Web site | Help Desk | Feature Requests | Message Board

                      Comment


                      • Bob, ver .31 seems to have solved it, I had posted this issue some time ago and simply worked around it by deleting and re-adding the affected Robot, this make life simpler, many thanxs for the updates, Mike

                        I noticed that you avoided my 2nd enquire re i7, any thoughts (other than PIA)? Mike
                        Computer: CUK Intel NUC7i7BNH
                        Op System: Windows 10 Pro - Work Station
                        HS Version: HS3 Pro Edition 3.0.0.435

                        Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                        Comment


                        • I am not sure right now why the i7 does not communicate - the plugin was written for the 980 originally and I am sure that Roomba must use the same interface to them
                          Can you capture me a debug log of the plugin startup

                          1. Disable plugin
                          2. Edit BLRoombaWifi.xml and change debugLevel to true and save the xml file
                          3. Re-enable the plugin

                          Let it run for a few minutes then disable debug logging and attach the log zipped
                          Cheers,
                          Bob
                          Web site | Help Desk | Feature Requests | Message Board

                          Comment


                          • Bob, as per your request... if you need more please do not hesitate to ask..
                            Attached Files
                            Computer: CUK Intel NUC7i7BNH
                            Op System: Windows 10 Pro - Work Station
                            HS Version: HS3 Pro Edition 3.0.0.435

                            Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                            Comment


                            • That debug log contains stuff from yesterday
                              Can u delete it and then capture it again

                              Also make sure you done the steps in this thread

                              https://forums.homeseer.com/forum/3r...-debug-logging
                              Cheers,
                              Bob
                              Web site | Help Desk | Feature Requests | Message Board

                              Comment


                              • Sorry Bob, I got hung up with Admin rights could not delete the BLRoombaWifi-detail file (learning curve) I believe I now have a proper file, Mike
                                Attached Files
                                Computer: CUK Intel NUC7i7BNH
                                Op System: Windows 10 Pro - Work Station
                                HS Version: HS3 Pro Edition 3.0.0.435

                                Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                                Comment

                                Working...
                                X