No announcement yet.

No status updates...

  • Filter
  • Time
  • Show
Clear All
new posts

    No status updates...

    Since August 10th my Roomba is not updating the status in HS3.
    I probably got the new firmware on the 10th.

    Any updates? It's been a couple of months since this plugin worked for me?

    Current Date/Time: 9/29/2017 7:10:20 AM
    HomeSeer Version: HS3 Pro Edition
    Operating System: Microsoft Windows Server 2016 Datacenter - Server
    System Uptime: 1 Day 18 Hours 16 Minutes 25 Seconds
    IP Address:
    Number of Devices: 1916
    Number of Events: 135
    Available Threads: 800

    Enabled Plug-Ins APCUPSD BLBackup BLGData BLLock BLML2HS BLPlugins BLRoombaWifi Blue-Iris BULLET Chromecast Device History EasyTrigger EnvisaLink
    1.0.16302.20: EventGhost IFTTT Insteon JowiHue LaMetric 3P MediaController MQTT
    1.1.17267.112: MyQ Nest PHLocation SCREPOSITORY SCSIP SDJ-Health Sonos SYNOLOGDM Tasker Plugin
    3.0.6132.16975: UltraGCIR3
    3.0.5917.35093: UltraLog3
    3.0.6440.19101: UltraMon3
    3.0.6159.37431: UltraNetatmo3
    3.0.6104.19146: UltraRachio3
    3.0.6171.18152: UltraTivo3
    3.0.6377.20892: UltraWeatherWU3 Z-Wave


      Sorry must have missed this one
      Mine has been working fine
      Can u check that you have your Roomba defined in the plugin. Once time I found mine was gone. I am trying to determine how that happened.
      Web site | Help Desk | Feature Requests | Message Board


        No worries.

        I have deleted and readded the Roomba several times.
        It's on the base and fully charged and the status of the plugin is OK, however the battery shows 0% in the plugin.

        Here is a screenshot:


          I will check my battery status tonight and see if it is reporting properly
          Web site | Help Desk | Feature Requests | Message Board


            So the plugin works well...but I have to restart the plugin at least once a day.
            It stops communicating with the Roomba otherwise.


              I have not noticed that I need to restart here.
              I will check and see if I notice that as well.

              Do you get any errors in the log at all?
              Web site | Help Desk | Feature Requests | Message Board


                I have not seen any, but I do get tons of these daily.

                Roomba message rcvd --> topic: wifistat; message: {"state":{"reported":{"signal":{"rssi":-36,"snr":52}}}}

                I just emailed you a screenshot, as you can see the bin status was updated at a time before I restarted the plugin.
                The other few status updates in the screenshot occurred after restarting the plugin, and then some, such as the battery, never updated?



                  So today I came home from work to test your plugin by clicking on 'Clean' in HS3.
                  It worked, however the status of all of the root / sub-devices hadn't updated since the last time the Roomba was off base...yesterday afternoon; as soon as it started cleaning today, it updated the status.


                    Do you still see these messages

                    topic: wifistat; message: {"state":{"reported":{"signal":{"rssi":-36,"snr":52}}}}

                    The plugin only processes what it is sent from the Roomba. If you are receiving the above messages then the Roomba is communicating
                    Web site | Help Desk | Feature Requests | Message Board


                      Well I guess it only sends messages off base...

                      Thanks for your time.


                        Devices not updating


                        I also have issues with the devices not updating. The Roomba 980 is communicating with HomeSeer.

                        For instance I got this update:
                        Roomba message rcvd --> topic: $aws/things/3117450410730660/shadow/update; message: {"state":{"reported":{"batPct":70}}}

                        And other updates as it is finished cleaning and I get wifi signal strength updates all the time.

                        However, none of the devices gets updated, all values are 0 and have not changed since I added the Roomba.

                        I am able to use the buttons to start and stop the Roomba.

                        Edit: I have tried to restart homeseer multiple times, adding and removing the roomba multiple times, restarting the plugin multiple times without luck.

                        Any ideas?


                          Got it to work!

                          The problem was that there was an extra Roomba in the plugin. It had no name IP or anything and I could not click on the Edit button to delete it.

                          Stopped the plugin, and deleted the: hspi_BLRoombaWifi.ini config file, restarted the plugin and added my Roomba again. New restart of plugin, and it is connected and updating the status of the devices.


                            I have the same problem with no updated devices.

                            I got a new 980 yesterday and tried to get it in the PI.
                            Got the BLID and password on first try with dorita.
                            Password is the :1:1111111111:xxxxxxxxxxxxxxxx format (I should use the whole string?)

                            980 Firmware is v2.4.4-4
                            PI is version

                            I have tried to add roomba to the PI and it gets added and creates devices, but I have no status updates.
                            I have enabled debug logging, but so far I have not got a single line of logging.

                            Any ideas?

                            PS: I have re-installed the plugin several times. Added and removed devices and roombas. Tried pretty much everything.