Announcement

Collapse
No announcement yet.

HS3 average CPU use rises when I use BLRoombaWifi

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    I ran the updater again...

    BLRoombaWifi
    Add a new instance of this plugin Uninstall this plug-In
    N/A 2.0.0.0 (2.0.10.0) Included Disabled

    Can you just post it for me at the moment, so I can test?

    Comment


      #17
      http://bladeplugins.no-ip.org/betas/...i_2-0-11-0.zip

      Just extract the HSPI_BLRoombaWifi.exe file to your HS3 root folder
      You will need to shutdown HS3 for this
      Cheers,
      Bob
      Web site | Help Desk | Feature Requests | Message Board

      Comment


        #18
        I don't know whats going on! So I stopped BLRoombaWifi, I verified the process was no longer running, I deleted the plugin, I deleted the devices for the plugin, I stopped HS3, I deleted every file associated with BLRoombaWifi, I manually moved the files to the correct HS3 directories, I started HS3, and it still shows .10!!!

        I even tried it in another browser to make sure it wasn't the browser cache...

        What the heck is going on?

        Comment


          #19
          The plugin is here also still reporting version 10. I bet Bob did not raise the version.

          But the change sure did good to the response here. CPU usage during the night is now 10% (not fluctuating) instead of 20% minimum. So whatever you did Bob, it is saving CPU

          Still a bit higher then before, but this works ok for me!

          Questions after playing for a few days:
          I have tried changing options through the plugin, like "carpet boost" and "cleaning passes" as those are enabled for control, and I would have use for them for dynamic settings. But whenever I press a button to change the setting they won't change. If I use the irobot app, the device changes instantly.
          I had set up an event that triggers on the status (5) "Returning to Base after Clean". This event would set a virtual device here that a complete clean is done. But this status seems not to be set on the device? Did you see this status? I would need this as the Roomba is doing its job when I am out and either stop the job because I am coming home, or it finished all.
          If it finished all a next start could wait for say 24 hours, where if it stopped because of me coming home it should start at the next opportunnity?

          Thanks,

          Wim
          -- Wim

          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
          650 devices ---- 336 events ----- 40 scripts

          Comment


            #20
            My bad - I may have forgotten to change the version.

            Glad you are seeing some improvements.

            I know the carpet boost and cleaning passes are not working - still trying to figure out the commands for those.

            I will check into the status for you as soon as I can.
            Cheers,
            Bob
            Web site | Help Desk | Feature Requests | Message Board

            Comment


              #21
              CPU usage is still 12% once I add my Roomba?
              I have 30 other plugins that only use 1 or 2% CPU, why is this one so CPU intensive?

              Still no status update from my Roomba, and I still can't control it from HS3.

              Comment


                #22
                Here is the latest debug log...look at the end.
                I have taken out my BLID / Password for this post.

                10/06/2017 06:32:52:533 AM : v2.0.10.0 - Activate_Roomba_Publish_Received_Thread() started
                10/06/2017 06:32:52:537 AM : v2.0.10.0 - Activate_Roomba_Publish_Received_Thread() finished
                10/06/2017 06:32:52:537 AM : v2.0.10.0 - InitIO finished
                10/06/2017 06:32:55:046 AM : v2.0.10.0 - Create_Mqtt_Client_For_Roomba() finished
                10/06/2017 06:32:55:046 AM : v2.0.10.0 - Homeseer_Started_Check(): DONE creating devices for roombas
                10/06/2017 06:33:00:047 AM : v2.0.10.0 - Homeseer_Started_Check(): homeseer started Thread has finished!
                10/06/2017 06:33:00:047 AM : v2.0.10.0 - Homeseer_Started_Check() finished
                10/06/2017 06:33:01:547 AM : v2.0.10.0 - Check_Roombas() started
                10/06/2017 06:33:01:547 AM : v2.0.10.0 - Roombas() started
                10/06/2017 06:33:01:547 AM : v2.0.10.0 - Roombas(): allRoombas.length --> 1
                10/06/2017 06:33:01:547 AM : v2.0.10.0 - Roombas() finished
                10/06/2017 06:33:01:547 AM : v2.0.10.0 - Check_Roombas(): ** processing roomba --> Celeste (ipaddress: 10.0.0.154)
                10/06/2017 06:33:01:547 AM : v2.0.10.0 - Build_Roomba_Device_Address() started
                10/06/2017 06:33:01:547 AM : v2.0.10.0 - Build_Roomba_Device_Address(): name --> Root
                10/06/2017 06:33:01:547 AM : v2.0.10.0 - Build_Roomba_Device_Address(): address --> BLRoombaWifi-**********************************-Root
                10/06/2017 06:33:01:547 AM : v2.0.10.0 - Build_Roomba_Device_Address() finished
                10/06/2017 06:33:01:550 AM : v2.0.10.0 - Check_Roombas(): rechargeMinutes -->
                10/06/2017 06:33:01:550 AM : v2.0.10.0 - Build_Roomba_Device_Address() started
                10/06/2017 06:33:01:550 AM : v2.0.10.0 - Build_Roomba_Device_Address(): name --> Cleaning Recharge Minutes
                10/06/2017 06:33:01:550 AM : v2.0.10.0 - Build_Roomba_Device_Address(): address --> BLRoombaWifi-***************************-CleaningRechargeMinutes
                10/06/2017 06:33:01:550 AM : v2.0.10.0 - Build_Roomba_Device_Address() finished
                10/06/2017 06:33:01:553 AM : v2.0.10.0 - Check_Roombas(): ERROR - Caught this exception - Input string was not in a correct format.
                10/06/2017 06:33:01:553 AM : v2.0.10.0 - Check_Roombas() finished
                10/06/2017 06:33:11:554 AM : v2.0.10.0 - Check_Roombas() started
                10/06/2017 06:33:11:554 AM : v2.0.10.0 - Roombas() started
                10/06/2017 06:33:11:554 AM : v2.0.10.0 - Roombas(): allRoombas.length --> 1
                10/06/2017 06:33:11:554 AM : v2.0.10.0 - Roombas() finished
                10/06/2017 06:33:11:554 AM : v2.0.10.0 - Check_Roombas(): ** processing roomba --> Celeste (ipaddress: 10.0.0.154)
                10/06/2017 06:33:11:554 AM : v2.0.10.0 - Build_Roomba_Device_Address() started
                10/06/2017 06:33:11:554 AM : v2.0.10.0 - Build_Roomba_Device_Address(): name --> Root
                10/06/2017 06:33:11:554 AM : v2.0.10.0 - Build_Roomba_Device_Address(): address --> BLRoombaWifi-********************************-Root
                10/06/2017 06:33:11:554 AM : v2.0.10.0 - Build_Roomba_Device_Address() finished
                10/06/2017 06:33:11:555 AM : v2.0.10.0 - Check_Roombas(): rechargeMinutes -->
                10/06/2017 06:33:11:555 AM : v2.0.10.0 - Build_Roomba_Device_Address() started
                10/06/2017 06:33:11:555 AM : v2.0.10.0 - Build_Roomba_Device_Address(): name --> Cleaning Recharge Minutes
                10/06/2017 06:33:11:555 AM : v2.0.10.0 - Build_Roomba_Device_Address(): address --> BLRoombaWifi-***********************-CleaningRechargeMinutes
                10/06/2017 06:33:11:555 AM : v2.0.10.0 - Build_Roomba_Device_Address() finished
                10/06/2017 06:33:11:557 AM : v2.0.10.0 - Check_Roombas(): ERROR - Caught this exception - Input string was not in a correct format.
                10/06/2017 06:33:11:557 AM : v2.0.10.0 - Check_Roombas() finished

                Comment


                  #23
                  Can u attach the complete debug log zipped
                  Better yet - email it to me directly

                  blade9123 at gmail dot com

                  I will have to check the log tonight when I am home
                  Cheers,
                  Bob
                  Web site | Help Desk | Feature Requests | Message Board

                  Comment


                    #24
                    I just emailed it to you.

                    Comment


                      #25
                      Bob,

                      I don't know what changed in 2.0.12, but last night the HS3 CPU was normal again - 6 to 10 percent and fluctuating. Looking good from here

                      Thanks

                      Wim
                      -- Wim

                      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                      650 devices ---- 336 events ----- 40 scripts

                      Comment

                      Working...
                      X