Announcement

Collapse
No announcement yet.

Behavior when Roomba is stuck

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Behavior when Roomba is stuck

    Bob:

    Something happened during my Roomba's cleaning run today that I am seeking some explanation of (even if it is "yeah, that is the way it works"). Our Roomba, Ricky, has gotten stuck a few times over the past few weeks - so I added an event to try to handle it - by stopping the cleaning run if the Roomba status goes to Stuck and stays at that for 3 minutes. So today, I was at work and got a message from the Roomba app that Ricky was stuck - and so I waited the 3 minutes for HS to stop the run -- but that never happened. When I checked HS, I saw that the "Root" device still showed "Clean" with the Ready/Not Ready status at Not Ready. I then manually stopped the cleaning job, at which time the HS Root device status changed to "Stuck". Is that the way things are supposed to work?

    Regards,
    Paul

  • #2
    It should have changed to stuck when it happened. I will check into it.
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      Bob,

      That sounds familiar to my issue that the status of the device does not change when the Roomba is returning home after clean.... Maybe these are related?

      Wim
      -- Wim

      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
      650 devices ---- 336 events ----- 40 scripts

      Comment


      • #4
        I will check into it as soon as I can and see if I can notice anything.
        I will try and get my Roomba stuck and trace what is coming back from it and see if it is something that can be fixed.
        I have seen mine say it is returning home before but not all the time.
        Cheers,
        Bob
        Web site | Help Desk | Feature Requests | Message Board

        Comment


        • #5
          It would be good if you could capture this in a debug log.
          That way I can trace what the plugin is seeing from the Roomba
          Cheers,
          Bob
          Web site | Help Desk | Feature Requests | Message Board

          Comment


          • #6

            Comment


            • #7
              Bob,

              I did not have the debug trace on, but just now the Roomba got stuck as the iRobot home app reported, the event I had set on the device status change to (5) Stuck never triggered. But in the log the plugin is seeing the change:

              okt-12 15:23:48 Warning File does not exist: C:\HS3\html\squeezebox
              okt-12 15:23:11 BLRoombaWifi Roomba: Robbie - error - Move Roomba to a new location then press CLEAN to restart. The cliff sensors are dirty, it is hanging over a drop, or it is stuck on a dark surface.
              okt-12 15:23:11 BLRoombaWifi Roomba: Robbie - status changed to Near a cliff

              Do you set the devicevalue without the true parameter maybe (true to trigger events when status changes)?

              Wim
              -- Wim

              Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
              650 devices ---- 336 events ----- 40 scripts

              Comment


              • #8
                Bob:

                I have debug tracing turned on, but of course now it doesn't get stuck...
                I'll continue to monitor for recreation of the conditions.

                Regards,
                Paul

                Comment


                • #9
                  Of course that is the way - if you capture it let me know
                  Cheers,
                  Bob
                  Web site | Help Desk | Feature Requests | Message Board

                  Comment


                  • #10
                    TO stick or not to Stick

                    So by engineering logic....

                    If I post here my roomba will simply quit sticking....

                    Blade you are awesome....



                    Sorry was just reading this post back to October and no more issues surfaced..... Couldn't resist the humor


                    Devoir

                    Comment


                    • #11
                      Blade:

                      "Ricky" did get stuck on Jan 10, and I have snipped out the records from the detailed debug log into a ZIPped text file; however, the 3.48 MB ZIP file will not successfully upload to the forum. I don't know what I am doing wrong, as the small file upload window says the upload limit for ZIP files is 9.54 MB. Is there another way to get the file to you?

                      P.S. : I had mistakenly left debug logging on over a few weeks - that is not a good thing! The detailed log file had grown to 28.5 GB!

                      Regards,
                      BBB

                      Comment


                      • #12
                        Log a help desk ticket on my site and then attach it zipped
                        Cheers,
                        Bob
                        Web site | Help Desk | Feature Requests | Message Board

                        Comment


                        • #13
                          There is no drop-down for the BLRoombaWiFi plug-in so it won't let me enter the ticket.

                          BBB

                          Comment


                          • #14
                            OK I will add one - give me a few
                            Cheers,
                            Bob
                            Web site | Help Desk | Feature Requests | Message Board

                            Comment


                            • #15
                              Ok I added it
                              Cheers,
                              Bob
                              Web site | Help Desk | Feature Requests | Message Board

                              Comment

                              Working...
                              X