Announcement

Collapse
No announcement yet.

Interface not found error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Interface not found error

    I installed the plug-in 2.0.12.0 added the IP address of the Roomba

    I get an error I can't seem to make go away..any thoughts on what I'm missing?


    Click image for larger version

Name:	roomba.jpg
Views:	1
Size:	14.6 KB
ID:	1211911


    Click image for larger version

Name:	crack o dawn.jpg
Views:	1
Size:	84.7 KB
ID:	1211912


    Devoir

  • #2
    Is this Linux or Windows?
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      Blade thanks for the update, I'm on a Windows platform


      Current Date/Time: 1/10/2018 10:37:59 AM
      HomeSeer Version: HS3 Pro Edition 3.0.0.318
      Operating System: Microsoft Windows 8.1 Pro - Work Station
      System Uptime: 0 Days 0 Hours 3 Minutes 26 Seconds
      IP Address: 192.168.199.208
      Number of Devices: 551
      Number of Events: 188
      Available Threads: 400

      Enabled Plug-Ins
      2.0.49.0: BLBackup
      2.0.12.0: BLRoombaWifi
      2.0.12.0: BLRoombaWifi
      3.0.0.75: HSTouch Server
      3.0.0.25: ImperiHome
      3.0.6.0: Insteon
      2.0.1.6: JowiHue
      0.0.0.35: Pushover 3P
      3.1.0.18: Sonos
      3.0.6542.35207: UltraWeatherWU3
      3.0.1.130: Z-Wave

      Comment


      • #4
        That is odd
        Have you tried restarting HS3? Do you still see that error?
        Cheers,
        Bob
        Web site | Help Desk | Feature Requests | Message Board

        Comment


        • #5
          REboot

          Blade,


          1 Shutdown HS3
          2 made backup of entire HS3 directory
          3 Rebooted Laptop with HS3
          4 Rans HS3 as "administrator"

          Error still exists...

          Devoir

          Comment


          • #6
            Log

            Blade,

            is there any log file or details I can send to help trouble shoot this?

            Devoir

            Comment


            • #7
              Do this:

              1. Shutdown HS3
              2. Edit the hspi_BLRoombaWifi.ini file in the config folder and change debugLevel=true and save INI file
              3. Restart HS3

              Once HS3 has been started for a minute or so go to the options page in the plugin and disable debug logging

              Attach the BLRoombaWifi-Detailed.log file zipped
              It is in the HS3 root folder
              I will check and see if there are any errors
              Cheers,
              Bob
              Web site | Help Desk | Feature Requests | Message Board

              Comment


              • #8
                Log file

                Blade many thanks I changed the hspi_BLRoombaWifi.ini statement = true

                I also noticed there were more than one Roomba.ini files in the screen shot. I only edited this one..


                Click image for larger version

Name:	roomba true.jpg
Views:	1
Size:	42.4 KB
ID:	1194779

                I am attaching the log file


                BLRoombaWifi-Detailed.txt


                Devoir

                Comment


                • #9
                  Your Blid and password does not look correct
                  Did you use dorita to get them?
                  Have you checked this thread

                  https://forums.homeseer.com/showthread.php?t=191518
                  Cheers,
                  Bob
                  Web site | Help Desk | Feature Requests | Message Board

                  Comment


                  • #10
                    roomba password

                    Blade,

                    The only thing i did was install your plug-in.......

                    I thought that was all that was required....

                    I will go to the Dorito site and try to follow it


                    Devoir

                    Comment


                    • #11
                      Dorita980 Success

                      Blade:

                      Many thanks for the direction:


                      I was able to follow your instructions. I installed a windows version of Node.js and NPM.

                      I also discovered when I set a static IP the password changed to something else..... thought that was interesting


                      Click image for larger version

Name:	dorita.jpg
Views:	1
Size:	49.4 KB
ID:	1194808



                      I was able to add the Roomba and now can control from this Plug-in....

                      Appreciate this


                      Devoir

                      Comment

                      Working...
                      X