Announcement

Collapse
No announcement yet.

No new device after install.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No new device after install.

    Hi!

    Im trying to get this plugin to work, been on the issue for a few days now...

    My problem is, it doesn't add any devices into my cars page no matter what I try to select from the config page.

    The plug does receive the cars information (I can see that from the trace log)

    Here is the log from when I try to add a device:
    Oct-02 11:06:49 Tesla Vehicles >>>> PluginConfigPage.postBackProc(TeslaVehicles_Configuration,ls tVehicleData_1054287195.close=3%7C4%7C5%7C6,ljcurfew,6)
    Oct-02 11:06:49 Tesla Vehicles >>>> PluginLogic.SelectPage(TeslaVehicles_Configuration)
    Oct-02 11:06:49 Tesla Vehicles >>>> PluginLogic.PostBackProc(TeslaVehicles_Configuration,lstVehi cleData_1054287195.close=3%7C4%7C5%7C6,ljcurfew,6)
    Oct-02 11:06:47 Tesla Vehicles >>>> PluginConfigPage.postBackProc(TeslaVehicles_Configuration,ls tVehicleData_1054287195_4=checked,ljcurfew,6)
    Oct-02 11:06:47 Tesla Vehicles >>>> PluginLogic.SelectPage(TeslaVehicles_Configuration)
    Oct-02 11:06:47 Tesla Vehicles >>>> PluginLogic.PostBackProc(TeslaVehicles_Configuration,lstVehi cleData_1054287195_4=checked,ljcurfew,6)
    Oct-02 11:06:46 Tesla Vehicles >>>> PluginConfigPage.postBackProc(TeslaVehicles_Configuration,ls tVehicleData_1054287195_5=checked,ljcurfew,6)
    Oct-02 11:06:46 Tesla Vehicles >>>> PluginLogic.SelectPage(TeslaVehicles_Configuration)
    Oct-02 11:06:46 Tesla Vehicles >>>> PluginLogic.PostBackProc(TeslaVehicles_Configuration,lstVehi cleData_1054287195_5=checked,ljcurfew,6)
    Oct-02 11:06:46 Tesla Vehicles >>>> PluginConfigPage.postBackProc(TeslaVehicles_Configuration,ls tVehicleData_1054287195_6=checked,ljcurfew,6)
    Oct-02 11:06:46 Tesla Vehicles >>>> PluginLogic.SelectPage(TeslaVehicles_Configuration)
    Oct-02 11:06:46 Tesla Vehicles >>>> PluginLogic.PostBackProc(TeslaVehicles_Configuration,lstVehi cleData_1054287195_6=checked,ljcurfew,6)
    Oct-02 11:06:42 Tesla Vehicles >>>> PluginConfigPage.BuildButton(btnReset,Reset your connection to the Tesla services,False,False)
    Oct-02 11:06:42 Tesla Vehicles >>>> PluginConfigPage.GetPagePlugin(TeslaVehicles_Configuration,l jcurfew,6,)
    Oct-02 11:06:42 Tesla Vehicles >>>> PluginLogic.SelectPage(TeslaVehicles_Configuration)
    Oct-02 11:06:42 Tesla Vehicles >>>> PluginLogic.GetPagePlugin(TeslaVehicles_Configuration,ljcurf ew,6,)
    Oct-02 11:06:04 Tesla Vehicles <<<< TeslaCommand.Execute
    Oct-02 11:06:04 Tesla Vehicles >>>> Vehicle(1054287195).UpdateHSDeviceValues(<TeslaData>,True)
    Oct-02 11:06:04 Tesla Vehicles >>>> Vehicle.UpdateResult(<TeslaCommand>, {"response":{"id":34092495560409830,"user_id":117509,"vehicl e_id":1054287195,"vin":"********************","display_name" :"Mogens","option_codes":"AD15,MDL3,PBSB,RENA,BT37,ID3W,RF3G ,S3PB,DRLH,DV2W,W39B,APF0,COUS,BC3B,CH07,PC30,FC3P,FG31,GLFR ,HL31,HM31,IL31,LTPB,MR31,FM3B,RS3H,SA3P,STCP,SC04,SU3C,T3CA ,TW00,TM00,UT3P,WR00,AU3P,APH3,AF00,ZCST,MI00,CDM0","color": null,"tokens":["*************","*************"],"state":"online","in_service":false,"id_s":"340924955604098 30","calendar_enabled":true,"api_version":6,"backseat_token" :************,"backseat_token_updated_at":null,"charge_state ":{"battery_heater_on":false,"battery_level":79,"battery_ran ge":184.94,"charge_current_request":16,"charge_current_reque st_max":16,"charge_enable_request":true,"charge_energy_added ":5.23,"charge_limit_soc":100,"charge_limit_soc_max":100,"ch arge_limit_soc_min":50,"charge_limit_soc_std":90,"charge_mil es_added_ideal":24.0,"charge_miles_added_rated":24.0,"charge _port_cold_weather_mode":false,"charge_port_door_open":false ,"charge_port_latch":"Engaged","charge_rate":0.0,"charge_to_ max_range":true,"charger_actual_current":0,"charger_phases": null,"charger_pilot_current":16,"charger_power":0,"charger_v oltage":1,"charging_state":"Disconnected","conn_charge_cable ":"<invalid>","est_battery_range":161.43,"fast_charger_brand ":"<invalid>","fast_charger_present":false,"fast_charger_typ e":"<invalid>","ideal_battery_range":184.94,"managed_chargin g_active":false,"managed_charging_start_time":null,"managed_ charging_user_canceled":false,"max_range_charge_counter":1," minutes_to_full_charge":0,"not_enough_power_to_heat":null,"s cheduled_charging_pending":false,"scheduled_charging_start_t ime":null,"time_to_full_charge":0.0,"timestamp":157000716420 8,"trip_charging":false,"usable_battery_level":78,"user_char ge_enable_request":null},"climate_state":{"battery_heater":f alse,"battery_heater_no_power":null,"climate_keeper_mode":"o ff","driver_temp_setting":22.0,"fan_status":0,"inside_temp": 16.7,"is_auto_conditioning_on":false,"is_climate_on":false," is_front_defroster_on":false,"is_preconditioning":false,"is_ rear_defroster_on":false,"left_temp_direction":0,"max_avail_ temp":28.0,"min_avail_temp":15.0,"outside_temp":12.5,"passen ger_temp_setting":22.0,"remote_heater_control_enabled":false ,"right_temp_direction":0,"seat_heater_left":0,"seat_heater_ right":0,"side_mirror_heaters":false,"smart_preconditioning" :false,"timestamp":1570007164208,"wiper_blade_heater":false} ,"drive_state":{"gps_as_of":1570006563,"heading":35,"latitud e":************,"longitude":************,"native_latitude":* ***********,"native_location_supported":1,"native_longitude" :************,"native_type":"wgs","power":0,"shift_state":nu ll,"speed":null,"timestamp":1570007164208},"gui_settings":{" gui_24_hour_time":true,"gui_charge_rate_units":"kW","gui_dis tance_units":"km/hr","gui_range_display":"Rated","gui_temperature_units":"C", "show_range_units":false,"timestamp":1570007164208},"vehicle _config":{"can_accept_navigation_requests":true,"can_actuate _trunks":true,"car_special_type":"base","car_type":"model3", "charge_port_type":"CCS","eu_vehicle":true,"exterior_color": "PearlWhite","has_air_suspension":false,"has_ludicrous_mode" :false,"key_version":2,"motorized_charge_port":true,"plg":fa lse,"rear_seat_heaters":0,"rear_seat_type":null,"rhd":false, "roof_color":"Glass","seat_type":null,"spoiler_type":"None", "sun_roof_installed":null,"third_row_seats":"<invalid>","tim estamp":1570007164208,"use_range_badging":true,"wheel_type": "Pinwheel18"},"vehicle_state":{"api_version":6,"autopark_sta te_v2":"unavailable","calendar_supported":true,"car_version" :"2019.32.2.2 da05838","center_display_state":0,"df":0,"dr":0,"ft":0,"is_u ser_present":false,"locked":true,"media_state":{"remote_cont rol_enabled":true},"notifications_supported":true,"odometer" :739.999066,"parsed_calendar_supported":true,"pf":0,"pr":0," remote_start":false,"remote_start_enabled":true,"remote_star t_supported":true,"rt":0,"sentry_mode":false,"sentry_mode_av ailable":true,"software_update":{"expected_duration_sec":270 0,"status":""},"speed_limit_mode":{"active":false,"current_l imit_mph":85.0,"max_limit_mph":90,"min_limit_mph":50,"pin_co de_set":false},"sun_roof_percent_open":null,"sun_roof_state" :"unknown","timestamp":1570007164208,"valet_mode":false,"val et_pin_needed":true,"vehicle_name":"Mogens"}}})
    Oct-02 11:06:04 Tesla Vehicles <<<< TeslaAPI.GetData=True

  • #2
    After you add the vehicle, did you go back to the config page and turn on the devices you want to see?

    Comment


    • #3
      Yup. Tried both many, none, a few.

      The device list is completely empty...

      Comment


      • #4
        Found the issue! Forgot to add the device types... Everything works now as it should...

        Comment

        Working...
        X