Announcement

Collapse
No announcement yet.

Updating to 1.5.2 but I get "Either no license or trial has expired" msg

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Updating to 1.5.2 but I get "Either no license or trial has expired" msg

    I'm trying to update to 1.5.2 (from 1.5.1) and I am getting "Unable to initialize interface Linktap :Either no license or trial has expired". It should be good. Any ideas why?
    FYI: I "Disabled" the plugin before installing (I do that every time, seems to help).

    Code:
     
    Sep-10 10:34:20 AM Updater Install/Update of package Tesla Vehicles failed.
    Sep-10 10:34:20 AM Updater Error Installation of package Tesla Vehicles failed. Try disabling the plugin first, then re-try the update.
    Sep-10 10:34:20 AM Updater Error Copying source to C:\Program Files (x86)\HomeSeer HS3\HSPI_SKWARE_TESLA_VEHICLES.exe, detailed error: The process cannot access the file 'C:\Program Files (x86)\HomeSeer HS3\HSPI_SKWARE_TESLA_VEHICLES.exe' because it is being used by another process.
    Sep-10 10:34:20 AM Updater Copying file: C:\Program Files (x86)\HomeSeer HS3\HSPI_SKWARE_TESLA_VEHICLES.exe
    Sep-10 10:34:20 AM Updater Installing package Tesla Vehicles
    Sep-10 10:34:20 AM Updater Update HSPI_SKWARE_TESLA_VEHICLES.exe downloaded successfully
    Sep-10 10:34:20 AM Updater Downloading update: Tesla Vehicles
    Sep-10 10:34:20 AM Updater Starting download of updates
    Sep-10 10:34:12 AM Plug-In Finished initializing plug-in Linktap
    Sep-10 10:34:12 AM Error (1) Unable to initialize interface Linktap :Either no license or trial has expired
    Sep-10 10:34:09 AM Info Plugin Tesla Vehicles with instance: has disconnected
    Sep-10 10:34:09 AM Plug-In Shutting down Plug-In: Tesla Vehicles

    #2
    There are 2 different issues here:
    1. You apparently are using a plugin called "Linktap". This is the plugin that has an expired trial, and has no relation to the Tesla plugin.
    2. There was an issue that I think I fixed in 1.5.2 with the plugin not shutting down properly
    I can't help you with #1

    But for #2, after you stop the plugin in HS, you'll need to go manually kill the process. Or stop HS altogether an manually delete the file (then add the plugin like it was new - don't worry, it won't hurt anything). I believe I fixed this issue in 1.5.2, but getting it to install can be a pain, I know.

    Comment


      #3
      Originally posted by shill View Post
      There are 2 different issues here:
      1. You apparently are using a plugin called "Linktap". This is the plugin that has an expired trial, and has no relation to the Tesla plugin.
      2. There was an issue that I think I fixed in 1.5.2 with the plugin not shutting down properly
      I can't help you with #1

      But for #2, after you stop the plugin in HS, you'll need to go manually kill the process. Or stop HS altogether an manually delete the file (then add the plugin like it was new - don't worry, it won't hurt anything). I believe I fixed this issue in 1.5.2, but getting it to install can be a pain, I know.
      LOL, sorry about #1. Delete which file?

      Comment


        #4
        The HSPI_SKWARE_TESLA_VEHICLES.EXE file in the root of your HS directory. Sorry for not specifying that earlier!

        Comment

        Working...
        X