Announcement

Collapse
No announcement yet.

Which license code to use for HS4?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Which license code to use for HS4?

    I just purchased this plug-in and received two license codes:

    Product: Tesla Vehicles and
    Product: Tesla Vehicles (HS4)


    I'm running HS4 and tried using the HS4 code. It gave me an error message, so I tried the other license. It worked.

    Now I'm wondering if I made a mistake by doing so. The plug-in was slow to find all of the controls and settings and seems a little flaky/incomplete in HS4 and with HS Touch. I stopped HS4 and restarted to see if that helped. It didn't. It sort of some times communicates properly with my Model S.

    I tried disabling the plug-in and removing it to try the HS4 license code on a re-install, but HS4 reported that it was already registered (in HS3 mode?).

    Any suggestions would be appreciated.

    #2
    The plugin is only an HS3 plugin (and HST has stated all HS3 plugins will work fine in HS4), but it works with both and in the plugin catalog it's defined as a free HS4 upgrade. That's all I know about license codes. For those specific issues/errors you'd need to contact HST.

    I would like to better understand what the "slow to find all of the controls and settings" means, as well as what seems flaky/incomplete. But I'll need much more descriptive examples, screenshots, and other information in order to help with that.

    Comment


      #3
      Thanks for your prompt reply!

      HS4 seems to be "discovering" things now. Initially, the Tesla devices only showed up on the HS3 device page...and it took them a while to get there. Now they're on the HS4 device page as well. Also, the functionality is improving in that the car seems to be responding to commands more reliably. Looks like I may have forgotten to take my "patience" pill this morning.

      BTW, is there any chance that controls for the pano roof and windows-up might be available in the near future?
      And I couldn't get the car to drive itself to my daughters' house either. Oops, wait, forgot to take my anti-crazy pill too.



      Comment


        #4
        I'm anxiously awaiting being able to send my car to wash itself.

        Did you turn those devices on in the options for your vehicle on the plugin config page? And did you turn on the check box to allow control of the windows?

        Comment


          #5
          Yes, the check box was checked. Not sure about any other check box. ‚Äč

          The windows allowing venting, but not closing is likely a Tesla SW safety issue. I can't close them from the Tesla phone app either. However, I CAN control the pano roof from the Tesla app. When using HS4 for the roof vent, I get these messages:

          12/4/2020 6:52:06 PM
          Legacy-Plugin
          Tesla Vehicles
          Invalid sunroof command: 'sun_roof_control_close' is no longer supported.


          12/4/2020 6:52:06 PM
          Legacy-Plugin
          Tesla Vehicles
          Please wait for the vehicle to be updated before issuing this command.


          12/4/2020 6:52:06 PM
          Legacy-Plugin
          Tesla Vehicles
          Invalid sunroof command: 'sun_roof_control_vent' is no longer supported.

          Click image for larger version

Name:	Settings.jpeg
Views:	64
Size:	17.6 KB
ID:	1438406
          Click image for larger version

Name:	Device settings.jpeg
Views:	57
Size:	13.7 KB
ID:	1438407
          Attached Files

          Comment


            #6
            They've changed the sunroof control a couple of times. And my 3 doesn't have one, so it's trial and error one build at a time to have any one else test it.

            As far as the windows, if you can't do it from the app, I can't do it either.

            Comment


              #7
              I'd be happy to test the sunroof control for you in a future update or series of beta tests.

              Does your 3 let you close windows? If it does, I'd also be happy to test that feature on my S.

              As I recall, the remote window close feature was removed from the S sometime before 2016.

              Comment


                #8
                I released 1.5.4 in the BETA section of the updater. This should fix the sunroof controls and also removes the "Close Windows" option if the vehicle is not a Model 3 or Model Y.

                Comment


                  #9
                  Thanks for the update. That fixed the sunroof vent and close issue!

                  Is there any chance that your plug-in could get the windows to close on an S? It would really be nice to "un-vent" the car.

                  Also, I don't seem to be able to name locations. Clicking in the "Name" field does nothing. Not a big deal, but I wonder what I might be doing wrong:

                  Click image for larger version

Name:	Location name.jpg
Views:	50
Size:	34.7 KB
ID:	1438495

                  Comment


                    #10
                    Originally posted by Haxster View Post
                    Is there any chance that your plug-in could get the windows to close on an S? It would really be nice to "un-vent" the car.
                    None whatsoever.

                    Comment


                      #11
                      Originally posted by Haxster View Post
                      Also, I don't seem to be able to name locations. Clicking in the "Name" field does nothing. Not a big deal, but I wonder what I might be doing wrong:

                      Click image for larger version

Name:	Location name.jpg
Views:	50
Size:	34.7 KB
ID:	1438495
                      I just tested this in HS3 and in the "Add" dialog, I'm able to click and type in the "Name" field. Are you not able to type there? (Note that this screen does not use the jquery pop-up text box, so you can just type like normal.)

                      Comment


                        #12
                        When I click in the Name field in HS4 and try to type, nothing goes in the field. I tried this in Firefox and Safari with the same results Could this be an HS4 compatibility issue?
                        I added a second location with the same results.

                        For me, I would consider this a low priority issue.

                        P.S.Just curious: Are you limited in implementing controls by what Tesla puts in their smartphone app; or are you allowed to go beyond this (e.g. window controls, easy entry)?

                        Comment


                          #13
                          Originally posted by Haxster View Post
                          When I click in the Name field in HS4 and try to type, nothing goes in the field. I tried this in Firefox and Safari with the same results Could this be an HS4 compatibility issue?
                          I added a second location with the same results.

                          For me, I would consider this a low priority issue.

                          P.S.Just curious: Are you limited in implementing controls by what Tesla puts in their smartphone app; or are you allowed to go beyond this (e.g. window controls, easy entry)?
                          It might be - I'll spin up my HS4 test environment and see if I can confirm.

                          All any of us 3rd party app developers can access are the APIs that the mobile app uses. So if you can't do it from the app, I can't do it either.

                          Comment

                          Working...
                          X