No announcement yet.

2019 - BLRing PI (Beta)

  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by winzone View Post

    Hi Dusball, Can you share more details on what you did? thanks.
    Sorry for the delay, but had the notifications messed up as I went on vacation, but here goes... And now I can't get screen shots properly, but having registered for (bear in mind, there's many a thread of more capable than me). Also, connect ifttt with HS and Ring services.

    So in HS, I've created two devices: "Imaginary Device: i Front Door" and "Imaginary Device: j Garage"
    (Event 1): Then, a resetting event (If Sunset, OR if turning off specific lights), turn "i" and "j" to off
    (Event 2 and more as wanted): Light on event (if "i" changed to on AND if light is off AND if time is nighttime), turn on appropriate light(s), then turn off "i" and light(s) and after a time (I chose 45 Seconds)

    1) From, while logged in, in the upper right, click on the down arrow, and SELECT "New Applet"
    2) Click on the blue "+this" in the middle of your screen
    3) Search/select Ring Service
    4) Choose the trigger (Motion or Ring), and appropriate device on next screen
    5) Click on the blue "+that"
    6) Select "Turn on a device"
    7) Choose the appropriate "Imaginary" device, then click create

    I found that Running an event directly from IFTTT made it tougher (?impossible) to pay mind to present status (if the lights are on, I don't want to run an event that ends up turning them off). Also, generally a short delay of less than 5 seconds.

    I think that makes some sense, if not, maybe I'll have the notifications setup right...


    • #32
      I am able to trigger a HS3 BLRing ring event reporting within 1-2 secs someone pushes the RING button. Unfortunately a BLRing motion event is reported in 1-2 minutes so not very helpful for me. I can currently view the recent history log but cannot view any of the videos with BLRing plugin but I believe this has been reported already.

      Is anyone else getting any better reporting time with a BLRing motion event?


      • #33
        Seems like the beta is no longer listed in the Beta section of the updater ... could the latest beta please be added back?


        • #34
          I have submitted the newest build to the updater - may take time for them to approve
          Web site | Help Desk | Feature Requests | Message Board


          • #35
            Thanks, I now have Version 2.0.31 installed. For some reason I had to uninstall the old version to update as "disable and update" failed. Anyway .31 is working much better than .27


            • #36
              Thanks for all the work Blade. I had the same issue updating and had to uninstall and re-install to get the update. I can see all of my motion videos now but still can't see a device created to use the motion to turn on a light or something. No worries, I just put a motion sensor out by the front door.


              • #37
                Thanks for your work on this. I hate to say it but I am still having problems. I uninstalled the old version and installed the new version and was able to see my videos again (yay), but then it stopped working and I started getting the "error not authorized" message. I also noticed that the activity log stopped updating.

                I disabled the plugin and re-enabled it and noticed that the activity log updated but I still could not access the most recent video from about an hour earlier (I didn't try a previous one). For a while it did nothing and then gave me the error message. I also tried to re-initialize the plug in under options and it hangs saying initialization in progress. When I disabled and re-enabled the plugin it then said initialized but when I tried to view the most recent video it again said "error not authorized". When I clicked on a motion alert from the previous day, however, the video played.

                So then I thought maybe its working now so I clicked on the most recent video and it pulled up a video box that was blank.

                Next (and this may be a clue) I refreshed my browser (this always clears the "error not authorized" messages) and tried to access the videos again. I could not access any of them, old or new. For a while it did nothing and then started giving the "error not authorized" messages.

                Could this have something to do with my browser; does the plug in place a necessary cookie there or something?

                Update: I closed the browser and re-opened it and was again able to pull up the older videos. The most recent one is still blank.


                • #38
                  It does not store any cookies in the browser
                  I sometimes see the unauthorized message and then it will work
                  I really wish Ring would publish their own api - it would make things much better
                  Web site | Help Desk | Feature Requests | Message Board


                  • #39
                    The other problem I have is that it just stops updating. For example, I went to the activity section of the plugin today and the last entry was July 5. I disabled the plugin and re-enabled it and then it updated to today.


                    • #40
                      Bob, I'm running v.31 and decided to re-initialize and it stuck in a permanent "Initialization in progress". I even dis-abled the PI and re-enabled it but my status in the BLRing - Options tab remains in a permanent "Initialization in progress", any suggestions? Mike

                      Update: after about 5 minutes later I finally got "Initialized" however when I go the Activity tab and select any Motion event I get {"error": "not authorized"} message
                      Computer: CUK Intel NUC7i7BNH
                      Op System: Windows 10 Pro - Work Station
                      HS Version: HS3 Pro Edition

                      Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.