Announcement

Collapse
No announcement yet.

Alarm Trigger Conditions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Alarm Trigger Conditions

    I have events that look for alarm triggers and do things based on the reason for the trigger (e.g., police, fire, auxiliary and water). The events are pretty simple. They test if either condition ("alarm [Alarm: Police]" and "alarm [Alarm: Police Panic]") is tripped, then take appropriate action. I have four scripts: fire and fire panic, police and police panic, auxiliary and auxiliary panic, and water.

    After I set them, when I come back into the event some time later, the conditions have changed. Right now the auxiliary trigger script says "alarm [Alarm: Water Alarm]" and "alarm [Alarm: Police Panic]"). I keep resetting them but they keep changing. Not sure if this is a real problem (I have to wait until the house is empty to test each type to see if it triggers), but when i originally built them they all worked correctly.

    Is there something I'm doing wrong?

    Thanks for your help,

    Joe

  • #2
    Originally posted by JPStokesSr View Post
    I have events that look for alarm triggers and do things based on the reason for the trigger (e.g., police, fire, auxiliary and water). The events are pretty simple. They test if either condition ("alarm [Alarm: Police]" and "alarm [Alarm: Police Panic]") is tripped, then take appropriate action. I have four scripts: fire and fire panic, police and police panic, auxiliary and auxiliary panic, and water.

    After I set them, when I come back into the event some time later, the conditions have changed. Right now the auxiliary trigger script says "alarm [Alarm: Water Alarm]" and "alarm [Alarm: Police Panic]"). I keep resetting them but they keep changing. Not sure if this is a real problem (I have to wait until the house is empty to test each type to see if it triggers), but when i originally built them they all worked correctly.

    Is there something I'm doing wrong?

    Thanks for your help,

    Joe
    I'm not seeing that. I setup a test event for:
    IF alarm [Alarm: Police] is tripped
    AND IF alarm [Alarm: Police Panic] is tripped

    I don't see it changing. I also used the Aux alarms as well.

    Do you remember what the circumstance are for it to change? (HS3 reboot, etc?)
    Which version of the plugin and HS3 are you running?
    Are you on Windows or Linux?

    Z

    Comment


    • #3
      I just set all four again, exited the web browser (chrome) and went back in. Auxiliary, Fire and Police changed to "Water Alarm" and "Police Panic", Water is still correct. Interestingly, i did them in that order, Auxiliary, Fire, Police then Water, so i looks like the Water update changed the first condition on the other 3 to Water Alarm, and Police update (done next to last) changed the second condition on the first two to "Police Panic". I'm not sure I ever noticed a pattern like that before, It might be as I go back and fix them out of order then get more jumbled up.

      I'm running HS3 is Pro Edition 3.0.0.435 (Windows) on a HomeTroller S6 Pro running Windows using version 3.1.13.10 of your add on.

      This add on is rock solid - this is the only issue I've had from it. I had thought it went away, but I noticed earlier this week that they didn't match, so I updated them and saw them wrong again, so I thought i'd ask.

      Comment


      • #4
        I just did some Windows updates and rebooted the computer. HS3 is back up and i looked at the events. All 4 have the first condition as Fire. The second condition on the first three is Police Panic (the 4th, Water, doesn't have a second condition).

        Comment


        • #5
          Can you send me a screen shot of the event(s) and the Concord plugin Control page.
          I'm not able to replicate the failure here.

          Also, goto the plugin Config page->Advanced Config->Debug Setup, and set the Log Triggers checkbox.
          Fix the event and then do whatever changes it back and attach the log. Turn off the debug after.

          Z

          Comment


          • #6
            Sorry for the delay - busy weekend

            Here are the screenshots and logs (hope I found the right ones). "Before Update" is when I opened HS3 today. Then I corrected the conditions and screenshot "After Update". Then I took down Chrome completely, started a new one, and brought back up HS3, and screenshot "After Kill and restart Chrome". "Capture 3" shows how I enabled the logs". They were originally ".log" but I couldn't upload them so I changed them to ".txt".

            Let me know if I missed something. I really appreciate the help.
            Attached Files

            Comment


            • #7
              Here's the log.
              Attached Files

              Comment


              • #8
                Thanks.
                It looks like you have duplicate events above. Is that just a cut/paste issue?? If not, can you remove the duplicates?

                Can you disable all but one event and then run the Trigger log again.

                So this occurs when you close the Events page and then reopen the event?

                Z

                Comment


                • #9
                  Sorry, the pictures ran together. The first group of 4 is "Capture before update", the second group is "Capture after kill and restart Chrome", and the third group is "Capture after Update". I figured out that if you hover over the picture, it shows the original file name. There's only four events.

                  The example I did above was update the conditions so they were correct (in picture "Capture after Update", then kill chrome completely, bring a new chrome back up and go to HS3, then open the events and look.

                  It was interesting that after I corrected the events, killed chrome, restarted chrome and went back into HS3, the first condition chanted to "Water Alarm". It's like the last thing I updated changed the others.

                  I don't think there's anything weird about my setup. It's a plain vanilla HomeTroller S6 Pro running Windows and HS3. I took a screenshot of my plugins and attached it.

                  I'll try to disable all but one and see what happens.

                  Click image for larger version

Name:	Plugins.JPG
Views:	18
Size:	85.9 KB
ID:	1277785


                  Comment


                  • #10
                    Let's just focus on one Event to keep it readable.
                    Better yet, disable all four existing events and create one new one with just the Fire Alarm (NO OR) and a generic HS3 Action (Speak "Test").

                    Also, why are you ORing with Police Panic? You'll get 4 alarms if it's triggered?

                    Z

                    Comment


                    • #11
                      With one event it doesn't seem to change. I turned on a second event and fixed the first value (Fire) and closed the event group and reopened the event group and the event, and the first condition on Auxiliary has been changed to Fire. Log attached.

                      I thought that the non-panic condition (Fire, Police and Auxiliary) were for a panel detected event (door alarm or fire sensor alarm, not sure what Auxiliary would be), and the Panic version (Fire Panic, Police Panic and Auxiliary Panic) were for a user forcing an alarm thru the console or a keyfob. Are Fire and Fire Panic the same? If so, i can just check for one. Maybe that will help.

                      CONCORD8.txt

                      Comment


                      • #12
                        Originally posted by JPStokesSr View Post
                        With one event it doesn't seem to change. I turned on a second event and fixed the first value (Fire) and closed the event group and reopened the event group and the event, and the first condition on Auxiliary has been changed to Fire. Log attached.

                        I thought that the non-panic condition (Fire, Police and Auxiliary) were for a panel detected event (door alarm or fire sensor alarm, not sure what Auxiliary would be), and the Panic version (Fire Panic, Police Panic and Auxiliary Panic) were for a user forcing an alarm thru the console or a keyfob. Are Fire and Fire Panic the same? If so, i can just check for one. Maybe that will help.

                        [ATTACH]n1277905[/ATTACH]
                        Something seems to be changing the Condition of that trigger. I still can't duplicate it here, so I'd like you to create two new events with only one Concord Trigger Alarm for each. LMK if it acts the same way.

                        I've also made an additional Debug statement in the EXE. I'll PM you the URL. Just stop the Concord plugin, rename the old Concord plugin EXE to HSPI_CONCORD.old and copy the new EXE into the main HS3 directory then restart the plugin.

                        Your HS3 version isn't the latest, but I don't remember .435 having any Event issues. You might consider updating if the above doesn't work.

                        Z

                        Comment


                        • #13
                          I disabled the old events and created a new group and two new events, Police and Fire. I put one trigger in and the speak for the action. It works fine. I shut down the browser and brought up a new on and everything stays right. So I created two more events for Auxiliary and Water with a speak action. All four work fine. I updated the event actions to match what I had in the original four events and it still works. So, I got brave and deleted the original four events, and then reassigned the new events to the original group. It all still works.

                          So, thinking about it (probably way too much), when I create events, I tend to create and copy a lot. I would bet that I originally created the first event, then copied it to create the second event and updated the conditions and actions, then the same for the third fourth event. I did this years ago after I first got HS3. Is it possible that the copy/paste might have caused the problem? If I get a chance tomorrow, I'll try to do that again and see what happens.

                          Do I just leave this executable in place, or should I go back to the original one. Also, do i only need one trigger event (Police) and not both (Police and Police Panic)?

                          Thanks for your help

                          Comment


                          • #14
                            Well, I couldn't wait - it was killin' me. I created a new event in a new group for police. Setup the condition for police alarm and the action as speak. Then I copied it. Modified the copy to Fire. Killed the browser, brought it back up and it's wrong (both say Fire). Seems like it's related to copying events.

                            Comment


                            • #15
                              Originally posted by JPStokesSr View Post
                              Well, I couldn't wait - it was killin' me. I created a new event in a new group for police. Setup the condition for police alarm and the action as speak. Then I copied it. Modified the copy to Fire. Killed the browser, brought it back up and it's wrong (both say Fire). Seems like it's related to copying events.
                              Makes sense. The clue would be the Condition value in the debug log. I suspect it's the same and it shouldn't be. I'd just not copy events (I never use that feature). I'll copy one and see if that's the magic sauce.
                              No probably using the new EXE, it only has one additional line of code and no functional difference.

                              Z

                              Comment

                              Working...
                              X