Announcement

Collapse
No announcement yet.

Vers 3_1_13_2 ready for testing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Vers 3_1_13_2 ready for testing

    Need someone to test 3_1_13_2 on Linux (Telefragger is doing Windows).
    Since the updater is "broken" with Dropbox links, PM me and I'll give you the direct link.

    More cleanup to address Panel comm lost and restarts. Also now displays Trouble alarms on the device page as well as the previously supported Log page.

    Thanks,
    Z

  • #2
    I'll take that updated link


    Also in the version I have, I see the following error. The dll is in bin/CONCORD so I am not sure why it isn't seeing it.

    01:05:01:4996:[CONCORD Error]->An unexpected error occurred in the InitConcord() function/subroutine: [System.TypeInitializationException: An exception was thrown by the type initializer for HSPI_CONCORD.dbModule ---> System.DllNotFoundException: SQLite.Interop.dll
    at (wrapper managed-to-native) System.Data.SQLite.UnsafeNativeMethods:sqlite3_config_none (System.Data.SQLite.SQLiteConfigOpsEnum)
    at System.Data.SQLite.SQLite3.StaticIsInitialized () [0x00000] in <filename unknown>:0
    at System.Data.SQLite.SQLiteLog.Initialize () [0x00000] in <filename unknown>:0
    at System.Data.SQLite.SQLiteConnection..ctor (System.String connectionString, Boolean parseViaFramework) [0x00000] in <filename unknown>:0
    at System.Data.SQLite.SQLiteConnection..ctor (System.String connectionString) [0x00000] in <filename unknown>:0
    at System.Data.SQLite.SQLiteConnection..ctor () [0x00000] in <filename unknown>:0
    at (wrapper remoting-invoke-with-check) System.Data.SQLite.SQLiteConnection:.ctor ()
    at HSPI_CONCORD.dbModule..cctor () [0x00000] in <filename unknown>:0
    --- End of inner exception stack trace ---
    at HSPI_CONCORD.devModule.InitConcord () [0x00000] in <filename unknown>:0 ]

    Comment


    • #3
      Originally posted by ramarnat View Post
      I'll take that updated link


      Also in the version I have, I see the following error. The dll is in bin/CONCORD so I am not sure why it isn't seeing it.

      01:05:01:4996:[CONCORD Error]->An unexpected error occurred in the InitConcord() function/subroutine: [System.TypeInitializationException: An exception was thrown by the type initializer for HSPI_CONCORD.dbModule ---> System.DllNotFoundException: SQLite.Interop.dll
      at (wrapper managed-to-native) System.Data.SQLite.UnsafeNativeMethods:sqlite3_config_none (System.Data.SQLite.SQLiteConfigOpsEnum)
      at System.Data.SQLite.SQLite3.StaticIsInitialized () [0x00000] in <filename unknown>:0
      at System.Data.SQLite.SQLiteLog.Initialize () [0x00000] in <filename unknown>:0
      at System.Data.SQLite.SQLiteConnection..ctor (System.String connectionString, Boolean parseViaFramework) [0x00000] in <filename unknown>:0
      at System.Data.SQLite.SQLiteConnection..ctor (System.String connectionString) [0x00000] in <filename unknown>:0
      at System.Data.SQLite.SQLiteConnection..ctor () [0x00000] in <filename unknown>:0
      at (wrapper remoting-invoke-with-check) System.Data.SQLite.SQLiteConnection:.ctor ()
      at HSPI_CONCORD.dbModule..cctor () [0x00000] in <filename unknown>:0
      --- End of inner exception stack trace ---
      at HSPI_CONCORD.devModule.InitConcord () [0x00000] in <filename unknown>:0 ]
      Did you (or did the Updater) put SQLite.Interop.dll and System.Data.SQLite.dll in the bin/Concord directory?

      Z

      Comment


      • #4
        Did you (or did the Updater) put the SQLite.Interop.dll and System.Data.SQLite.dll in the bin/Concord directory?
        The updater did.

        Ro

        Comment


        • #5
          Yeah windows version lookin good here...

          albeit I haven't been home but the alarm has..

          I gotta check my smoke.. prior to this version I did not have this message so maybe last one wasn't detecting things correctly... don't know but my panel does not say there is an issue... so I don't know what gives..


          .
          Attached Files
          HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

          HS - HS3 Pro Edition 3.0.0.435

          Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

          Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

          Comment


          • #6
            Originally posted by TeleFragger View Post
            Yeah windows version lookin good here...

            albeit I haven't been home but the alarm has..

            I gotta check my smoke.. prior to this version I did not have this message so maybe last one wasn't detecting things correctly... don't know but my panel does not say there is an issue... so I don't know what gives..
            .
            Run Debug Comms and look for the Sts=x for that device. It should be 8 if there really is a Trouble on it. It should show on your keypad as well. (ie *)

            LMK
            Z

            Comment


            • #7
              Sent from my Samsung Galaxy Note 3
              Attached Files
              HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

              HS - HS3 Pro Edition 3.0.0.435

              Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

              Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

              Comment


              • #8
                Originally posted by TeleFragger View Post
                Sent from my Samsung Galaxy Note 3
                Debug log?

                Z

                Comment


                • #9
                  Sorry been busy ill try tnight

                  Sent from my Samsung Galaxy Note 3
                  HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                  HS - HS3 Pro Edition 3.0.0.435

                  Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                  Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                  Comment


                  • #10
                    Originally posted by vasrc View Post
                    Need someone to test 3_1_13_2 on Linux (Telefragger is doing Windows).
                    Since the updater is "broken" with Dropbox links, PM me and I'll give you the direct link.

                    More cleanup to address Panel comm lost and restarts. Also now displays Trouble alarms on the device page as well as the previously supported Log page.

                    Thanks,
                    Z
                    Need one more Windows platform tester for Vers 3_1_13_2

                    Thanks,
                    Z

                    Comment


                    • #11
                      Sure. I'll be another tester on Windows. What do you need back from me?

                      I'm on ver 3.1.13.1 right now.

                      -Matt

                      Comment


                      • #12
                        Originally posted by mattm55 View Post
                        Sure. I'll be another tester on Windows. What do you need back from me?

                        I'm on ver 3.1.13.1 right now.

                        -Matt
                        PM me your email again, I've misplaced it, and I'll send you the Dropbox URL.
                        You'll just need the new EXE since you're already running.

                        Testing the Trouble function primarily, it should show up on the main device page now. If you have an event monitoring the Trouble/tamper alarms, all you'll need to do is look at the Panel log to find the detailed reason (ie tamper, low battery).

                        Thanks,
                        Z

                        Comment


                        • #13
                          sorry life has had me so busy but I i will get back to this soon...
                          promise..

                          weird thing is even though my smoke says tripped... so does the panel log (didnt screenshot it but saw it)... so not sure why i do not have a * on the keypad
                          HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                          HS - HS3 Pro Edition 3.0.0.435

                          Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                          Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                          Comment


                          • #14
                            Originally posted by TeleFragger View Post
                            sorry life has had me so busy but I i will get back to this soon...
                            promise..

                            weird thing is even though my smoke says tripped... so does the panel log (didnt screenshot it but saw it)... so not sure why i do not have a * on the keypad
                            Not a problem. I coincidentally had a Trouble alarm on our Iso Room smoke detector and the Log showed it as Low Battery (and they were), so I'm pretty sure it's working OK.

                            Z

                            Comment


                            • #15
                              Should this plug-in work on a HomeTroller Zee2? I can connect to the Concord4 panel but then I keep losing my connection and then reconnecting...

                              Oct-29 9:26:44 PM CONCORD Comm TimerHB: Communications Lost
                              Oct-29 9:26:44 PM CONCORD Debug InsertTracking() Enqueue: Zone (205), Now=1446175604, mSec=642, Event=Communications Lost
                              Oct-29 9:26:44 PM CONCORD Debug Setting Connection Status to: 0
                              Oct-29 9:26:43 PM CONCORD Comm TimerHB: Communications Restored
                              Oct-29 9:26:43 PM CONCORD Debug InsertTracking() Enqueue: Zone (205), Now=1446175603, mSec=941, Event=Communications Restored
                              Oct-29 9:26:43 PM CONCORD Debug Setting Connection Status to: 1
                              Oct-29 9:26:40 PM CONCORD Comm TimerHB: Communications Lost
                              Oct-29 9:26:40 PM CONCORD Debug InsertTracking() Enqueue: Zone (205), Now=1446175600, mSec=640, Event=Communications Lost
                              Oct-29 9:26:40 PM CONCORD Debug Setting Connection Status to: 0
                              Oct-29 9:26:39 PM CONCORD Comm TimerHB: Communications Restored
                              Oct-29 9:26:39 PM CONCORD Debug InsertTracking() Enqueue: Zone (205), Now=1446175599, mSec=938, Event=Communications Restored
                              Oct-29 9:26:39 PM CONCORD Debug Setting Connection Status to: 1
                              Oct-29 9:26:36 PM CONCORD Comm TimerHB: Communications Lost
                              Oct-29 9:26:36 PM CONCORD Debug InsertTracking() Enqueue: Zone (205), Now=1446175596, mSec=635, Event=Communications Lost
                              Oct-29 9:26:36 PM CONCORD Debug Setting Connection Status to: 0
                              Oct-29 9:26:35 PM CONCORD Comm TimerHB: Communications Restored
                              Oct-29 9:26:35 PM CONCORD Debug InsertTracking() Enqueue: Zone (205), Now=1446175595, mSec=934, Event=Communications Restored
                              Oct-29 9:26:35 PM CONCORD Debug Setting Connection Status to: 1
                              Oct-29 9:26:32 PM CONCORD Comm TimerHB: Communications Lost
                              Oct-29 9:26:32 PM CONCORD Debug InsertTracking() Enqueue: Zone (205), Now=1446175592, mSec=631, Event=Communications Lost
                              Oct-29 9:26:32 PM CONCORD Debug Setting Connection Status to: 0
                              Oct-29 9:26:31 PM CONCORD Comm TimerHB: Communications Restored
                              Oct-29 9:26:31 PM CONCORD Debug InsertTracking() Enqueue: Zone (205), Now=1446175591, mSec=934, Event=Communications Restored
                              Oct-29 9:26:31 PM CONCORD Debug Setting Connection Status to: 1
                              Oct-29 9:26:28 PM CONCORD Comm TimerHB: Communications Lost
                              Oct-29 9:26:28 PM CONCORD Debug InsertTracking() Enqueue: Zone (205), Now=1446175588, mSec=629, Event=Communications Lost
                              Oct-29 9:26:28 PM CONCORD Debug Setting Connection Status to: 0
                              Oct-29 9:26:27 PM CONCORD Comm TimerHB: Communications Restored
                              Oct-29 9:26:27 PM CONCORD Debug InsertTracking() Enqueue: Zone (205), Now=1446175587, mSec=930, Event=Communications Restored
                              Oct-29 9:26:27 PM CONCORD Debug Setting Connection Status to: 1
                              Oct-29 9:26:24 PM CONCORD Comm TimerHB: Communications Lost
                              Oct-29 9:26:24 PM CONCORD Debug InsertTracking() Enqueue: Zone (205), Now=1446175584, mSec=627, Event=Communications Lost

                              Comment

                              Working...
                              X