Announcement

Collapse
No announcement yet.

Vers 3_13_1_3 in Updater

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Vers 3_13_1_3 in Updater

    Ready for download in the Updater.

    Fixed:
    Leaving open file descriptors (more evident in Linux)
    Unstable code for the Disconnect and Connect button.
    Cleaned up Communication exceptions errors
    Addressed Com port connected but panel is not "talking" (usually on a PI)
    Display assigned Comm port in dropdown list if previously selected

    Z

  • #2
    Great. All set.

    Thanks.

    Comment


    • #3
      I updated to this latest version and communicated correctly but the zones were not loaded at all. This did not work for me and now the system does not work. How can i revert back?

      Comment


      • #4
        Originally posted by aagamb12 View Post
        I updated to this latest version and communicated correctly but the zones were not loaded at all. This did not work for me and now the system does not work. How can i revert back?
        Most likely the plugin is unable to read the database. Do you see any errors in the HS log when you startup?
        Also try stopping and restarting the plugin.

        To revert, you only need to replace the HSPI_CONCORD.exe with a backup.

        Z

        Comment


        • #5
          I got this error.. was coming here to check the boards...

          Dec-23 10:41:33 AM CONCORD Error An unexpected error occurred in the InitConcord() function/subroutine: [System.TypeInitializationException: The type initializer for 'HSPI_CONCORD.dbModule' threw an exception. ---> System.DllNotFoundException: Unable to load DLL 'sqlite3': The specified module could not be found. (Exception from HRESULT: 0x8007007E) at System.Data.SQLite.UnsafeNativeMethods.sqlite3_config_none(S QLiteConfigOpsEnum op) at System.Data.SQLite.SQLite3.StaticIsInitialized() at System.Data.SQLite.SQLiteLog.Initialize() at System.Data.SQLite.SQLiteConnection..ctor(String connectionString, Boolean parseViaFramework) at System.Data.SQLite.SQLiteConnection..ctor() at HSPI_CONCORD.dbModule..cctor() --- End of inner exception stack trace --- at HSPI_CONCORD.dbModule.LoadKeypadTable() at HSPI_CONCORD.devModule.InitConcord()]
          HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

          HS - HS3 Pro Edition 3.0.0.435

          Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

          Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

          Comment


          • #6
            Originally posted by TeleFragger View Post
            I got this error.. was coming here to check the boards...

            Dec-23 10:41:33 AM CONCORD Error An unexpected error occurred in the InitConcord() function/subroutine: [System.TypeInitializationException: The type initializer for 'HSPI_CONCORD.dbModule' threw an exception. ---> System.DllNotFoundException: Unable to load DLL 'sqlite3': The specified module could not be found. (Exception from HRESULT: 0x8007007E) at System.Data.SQLite.UnsafeNativeMethods.sqlite3_config_none(S QLiteConfigOpsEnum op) at System.Data.SQLite.SQLite3.StaticIsInitialized() at System.Data.SQLite.SQLiteLog.Initialize() at System.Data.SQLite.SQLiteConnection..ctor(String connectionString, Boolean parseViaFramework) at System.Data.SQLite.SQLiteConnection..ctor() at HSPI_CONCORD.dbModule..cctor() --- End of inner exception stack trace --- at HSPI_CONCORD.dbModule.LoadKeypadTable() at HSPI_CONCORD.devModule.InitConcord()]
            Says it can't find the System.Data.SQLite.dll file. It should be in the bin/CONCORD directory. Also check your main HS3 directory and see what the "Probing privatePath" value is in the HSPI_CONCORD.config.exe file.

            Also post the Updater text from the HS log for the CONCORD plugin.

            This shouldn't have changed from the previous version though.

            LMK,
            Z

            Comment


            • #7
              Originally posted by vasrc View Post
              Says it can't find the System.Data.SQLite.dll file. It should be in the bin/CONCORD directory.

              yes it is there

              Also check your main HS3 directory and see what the "Probing privatePath" value is in the HSPI_CONCORD.config.exe file.
              Code:
              <?xml version="1.0"?>
              	<configuration>
              		<runtime>
              			<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
              				<probing privatePath="bin/CONCORD;bin"/>
              			</assemblyBinding>
              		</runtime>
              		<startup useLegacyV2RuntimeActivationPolicy="true">
              			<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>
              		</startup>
              	</configuration>
              Also post the Updater text from the HS log for the CONCORD plugin.

              This shouldn't have changed from the previous version though.

              LMK,
              Z
              not sure what you mean by this one... which file?
              HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

              HS - HS3 Pro Edition 3.0.0.435

              Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

              Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

              Comment


              • #8
                Originally posted by TeleFragger View Post
                yes it is there



                Code:
                <?xml version="1.0"?>
                    <configuration>
                        <runtime>
                            <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
                                <probing privatePath="bin/CONCORD;bin"/>
                            </assemblyBinding>
                        </runtime>
                        <startup useLegacyV2RuntimeActivationPolicy="true">
                            <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>
                        </startup>
                    </configuration>
                not sure what you mean by this one... which file?
                What is in the HS log when you Update the PI. Just download the PI again and it should replace that file for you. You should see it replace in the log.

                LMK,
                Z

                Comment


                • #9
                  I get...

                  Dec-23 4:29:20 PM Error Building page: Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: chunkLength
                  HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                  HS - HS3 Pro Edition 3.0.0.435

                  Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                  Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                  Comment


                  • #10
                    Originally posted by TeleFragger View Post
                    I get...

                    Dec-23 4:29:20 PM Error Building page: Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: chunkLength
                    When you do what?
                    I need a bit more of the log before and after to put it in context.

                    Z

                    Comment


                    • #11
                      Sorry out shopping now.. ill reply later...

                      If i stop then start plugin i get that error

                      Sent from my Samsung Galaxy Note 3
                      HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                      HS - HS3 Pro Edition 3.0.0.435

                      Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                      Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                      Comment


                      • #12
                        Originally posted by vasrc View Post
                        When you do what?
                        I need a bit more of the log before and after to put it in context.

                        Z
                        ok I'm home and will be wrapping presents...

                        so you need what from me?
                        bit more of which log?
                        I got that error when I enabled the concord plugin from the plugins page...
                        HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                        HS - HS3 Pro Edition 3.0.0.435

                        Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                        Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                        Comment


                        • #13
                          Originally posted by TeleFragger View Post
                          ok I'm home and will be wrapping presents...

                          so you need what from me?
                          bit more of which log?
                          I got that error when I enabled the concord plugin from the plugins page...
                          Just disable (wait a minute for it to complete), then start it up again.
                          Post the Log of the PI starting up.

                          Z
                          (Wrapping presents?? Cutting it close huh ...

                          Comment


                          • #14
                            at this point.. how do I get the older one as I didn't backup... DOH...

                            right now concord plugin is down and tired of the alarm speaker beeping...
                            HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                            HS - HS3 Pro Edition 3.0.0.435

                            Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                            Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                            Comment


                            • #15
                              Originally posted by TeleFragger View Post
                              at this point.. how do I get the older one as I didn't backup... DOH...

                              right now concord plugin is down and tired of the alarm speaker beeping...
                              Try this link and extract the HSPI_CONCORD.exe and HSPI_CONCORD.exe.config files.

                              https://dl.dropboxusercontent.com/u/...dV3_1_13_2.zip

                              Z

                              Comment

                              Working...
                              X