Announcement

Collapse
No announcement yet.

Looking to integrate Concord System

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by vasrc View Post
    Couple of things..
    1. Is the sqlite3.dll file in the HS3 root directory?
    2. Try using Odd parity
    3. Are you sure the USB/Serial device is a DTE device (Pin 3 should show voltage (approx 5vdc). If not, then you'll need a null modem cable.

    I've just uploaded the latest Version 1_13_6, it has the sqlite3.dll file in it now.

    Z
    1. No sqlite3.dll in HS3 Root directory
    2. I tried Odd polarity. It became green and said "Connected to Concord 4". Then I went to retrieve zones and it went back to "Comm Port Initialized. NOT Connected to Concord Panel"
    3. Multi-meter shows 6.34V between pin 3 and 5.

    Is there a location for the download of 1_13_6 or do I wait until it shows up in updater?

    Comment


    • #17
      Originally posted by olag00 View Post
      1. No sqlite3.dll in HS3 Root directory
      2. I tried Odd polarity. It became green and said "Connected to Concord 4". Then I went to retrieve zones and it went back to "Comm Port Initialized. NOT Connected to Concord Panel"
      3. Multi-meter shows 6.34V between pin 3 and 5.

      Is there a location for the download of 1_13_6 or do I wait until it shows up in updater?
      It should already show up there. Try clicking on "Update Listing"
      It won't connect until you have the SQLite db accessed.

      Z

      Comment


      • #18
        Looks like everything is working! As an FYI, the latest version is 5 and not 6, but 6 still shows in updater. I went from v4 to v5.

        Thanks for the help!

        Comment


        • #19
          Originally posted by olag00 View Post
          Looks like everything is working! As an FYI, the latest version is 5 and not 6, but 6 still shows in updater. I went from v4 to v5.

          Thanks for the help!
          HS takes sometime to recognize the new version # sometimes. It should change to 6 shortly.
          Glad to hear it's working now.

          Z

          Comment


          • #20
            It appears the "panel control" device's "status graphics" page has Arm Stay and Arm Away swapped. I needed to set value 2 to Arm Stay and 3 to Arm Away. It was the other way originally.

            Not sure if this was just my system or if the plugin created it incorrectly.

            Comment


            • #21
              Originally posted by olag00 View Post
              It appears the "panel control" device's "status graphics" page has Arm Stay and Arm Away swapped. I needed to set value 2 to Arm Stay and 3 to Arm Away. It was the other way originally.

              Not sure if this was just my system or if the plugin created it incorrectly.
              It was one of the changes in Vers 6. Try deleting that device and it should be recreated correctly.

              Z

              Comment


              • #22
                Originally posted by vasrc View Post
                It was one of the changes in Vers 6. Try deleting that device and it should be recreated correctly.

                Z
                I just tried to update to 6 and I clicked the check mark to update and it says everything went correctly. Then when it refreshes the 6 version is still saying it is available. 5 is still stated when I do the update....

                Code:
                Apr-22 9:10:51 PM	 	CONCORD	InitConcord() Initializing Concord, Vers:3.1.13.5

                Comment


                • #23
                  This is the full log of update:

                  Code:
                  Apr-22 9:10:56 PM	 	Plug-In	Finished initializing plug-in CONCORD
                  Apr-22 9:10:56 PM	 	CONCORD	---------------------------------------------------
                  Apr-22 9:10:56 PM	 	CONCORD	Concord Initialization Complete!
                  Apr-22 9:10:55 PM	 	CONCORD	Check/Init Triggers
                  Apr-22 9:10:55 PM	 	CONCORD	Initializing COM3
                  Apr-22 9:10:55 PM	 	CONCORD Info	Initializing Timers
                  Apr-22 9:10:54 PM	 	CONCORD Info	Validating Zones/Devices
                  Apr-22 9:10:53 PM	 	CONCORD Info	Loading Zone Data from Database to memory
                  Apr-22 9:10:53 PM	 	CONCORD Info	Loading Zone Types
                  Apr-22 9:10:53 PM	 	CONCORD	Configuration Checks Complete
                  Apr-22 9:10:53 PM	 	CONCORD	Getting Concord Configuration
                  Apr-22 9:10:53 PM	 	CONCORD Info	Checking/Updating DB configuration
                  Apr-22 9:10:53 PM	 	CONCORD Info	Verifying User/Tracking tables
                  Apr-22 9:10:53 PM	 	CONCORD Info	Adding default Concord Plugin user(250)
                  Apr-22 9:10:53 PM	 	CONCORD Info	Adding default Concord Plugin user(255)
                  Apr-22 9:10:52 PM	 	CONCORD Info	Retrieving User Data
                  Apr-22 9:10:52 PM	 	CONCORD Info	Loading settings from hspi_Concord.ini
                  Apr-22 9:10:52 PM	 	CONCORD Info	LoadKeyPadTable() - filename=C:\Program Files (x86)\HomeSeer HS3\Data\CONCORD\keypadtable.txt
                  Apr-22 9:10:51 PM	 	CONCORD Info	Loading Keypad table
                  Apr-22 9:10:51 PM	 	CONCORD Info	Initializing Concord DB
                  Apr-22 9:10:51 PM	 	CONCORD	InitConcord() Initializing Concord, Vers:3.1.13.5
                  Apr-22 9:10:51 PM	 	CONCORD Debug	isLinux = False
                  Apr-22 9:10:51 PM	 	Info	Plugin CONCORD has connected. IP:127.0.0.1:52041
                  Apr-22 9:10:50 PM	 	Updater	Re-initializing plugin after update.
                  Apr-22 9:10:50 PM	 	Updater	Install/Update of package Concord 4 Security Panel was successful.
                  Apr-22 9:10:50 PM	 	Updater	Copying file: C:\Program Files (x86)\HomeSeer HS3\HSPI_CONCORD.exe.config
                  Apr-22 9:10:50 PM	 	Updater	Copying file: C:\Program Files (x86)\HomeSeer HS3\HSPI_CONCORD.exe
                  Apr-22 9:10:50 PM	 	Updater Warning	File exists, not overwriting: C:\Program Files (x86)\HomeSeer HS3\sqlite3.dll
                  Apr-22 9:10:50 PM	 	Updater Warning	File exists, not overwriting: C:\Program Files (x86)\HomeSeer HS3\bin\CONCORD\SQLite.Interop.dll
                  Apr-22 9:10:50 PM	 	Updater Warning	File exists, not overwriting: C:\Program Files (x86)\HomeSeer HS3\bin\CONCORD\System.Data.SQLite.dll
                  Apr-22 9:10:50 PM	 	Updater Warning	File exists, not overwriting: C:\Program Files (x86)\HomeSeer HS3\Data\CONCORD\keypadtable.txt
                  Apr-22 9:10:50 PM	 	Updater Warning	File exists, not overwriting: C:\Program Files (x86)\HomeSeer HS3\Data\CONCORD\CONCORDDB3.db
                  Apr-22 9:10:50 PM	 	Updater	Copying file: C:\Program Files (x86)\HomeSeer HS3\html\CONCORD\Concord_help.htm
                  Apr-22 9:10:50 PM	 	Updater Warning	File exists, not overwriting: C:\Program Files (x86)\HomeSeer HS3\Logs\CONCORD\CONCORD_default.log
                  Apr-22 9:10:50 PM	 	Updater Warning	File exists, not overwriting: C:\Program Files (x86)\HomeSeer HS3\Config\hspi_Concord.ini
                  Apr-22 9:10:50 PM	 	Updater	Extraction Complete.
                  Apr-22 9:10:50 PM	 	Updater	Extracting files from zip file: C:\Program Files (x86)\HomeSeer HS3\Updates3\Concord 4 Security Panel3.1.13.6\CONCORD_images.zip Destination: C:\Program Files (x86)\HomeSeer HS3\html\images\CONCORD\
                  Apr-22 9:10:43 PM	 	Updater	Installing package Concord 4 Security Panel
                  Apr-22 9:10:43 PM	 	Updater	Update HSPI_CONCORD.exe downloaded successfully
                  Apr-22 9:10:41 PM	 	Updater	Downloading update: Concord 4 Security Panel

                  Comment


                  • #24
                    Not sure if it's just the internal vers notation, or it didn't include in the Updater, so use this while I see why it's not there. Just replace the HSPI_CONCORD.exe file (stop the plugin first of course)

                    https://dl.dropboxusercontent.com/u/...PI_CONCORD.exe

                    Then delete the device. It should recreate correctly.

                    LMK,
                    Z

                    Comment


                    • #25
                      Found it.. The upload should now have Vers 6 in it

                      Z

                      Comment


                      • #26
                        Thanks. Now it shows 6 in the log and the device was created correctly.

                        Comment


                        • #27
                          Concord 4 Comm Port Initialized. NOT Connected to Concord Panel

                          Hi Everyone I was reading the forums but couldnt find a correct answer to my problem:

                          I have a Concord 4 connected to HS3 thru a usb-serial adapter
                          evrything workgs great for few hours but then i lose connection and the error i got is:
                          Comm Port Initialized. NOT Connected to Concord Panel

                          the only way to get the connection back is to disconnect and reconnect the usb-serial adapter, any ideas what it can be?
                          this is the log:

                          CONCORD Aug 26, 2016 4:33:45 PM Closing Comm Port Zone 205 Connection Status Partition 1
                          CONCORD Aug 26, 2016 1:33:07 PM Communications Lost Zone 205 Connection Status Partition 1
                          CONCORD Aug 26, 2016 1:01:59 PM Normal Zone 1 FRONT DOOR Partition 1
                          CONCORD Aug 26, 2016 11:30:00 AM Normal Zone 1 FRONT DOOR Partition 1
                          CONCORD Aug 26, 2016 10:45:43 AM Communications Initialized Zone 205 Connection Status Partition 1
                          CONCORD Aug 26, 2016 10:44:43 AM Communications Lost Zone 205 Connection Status Partition 1
                          CONCORD Aug 26, 2016 10:29:33 AM Communications Restored Zone 205 Connection Status Partition 1
                          CONCORD Aug 26, 2016 10:29:22 AM Initializing Comm Port Zone Chime Partition 1 CONCORD Aug 26, 2016 9:52:52 AM Communications Restored Zone 205 Connection Status Partition 1
                          CONCORD Aug 26, 2016 9:52:42 AM Initializing Comm Port Zone 205 Connection Status Partition 1
                          CONCORD Aug 26, 2016 12:08:42 AM Communications Restored Zone 205 Connection Status Partition 1
                          CONCORD Aug 26, 2016 12:08:31 AM Initializing Comm Port Zone 205 Connection Status Partition 1 C
                          ONCORD Aug 26, 2016 12:01:19 AM Communications Restored Zone 205 Connection Status Partition 1
                          CONCORD Aug 26, 2016 12:01:09 AM Initializing Comm Port Zone 205 Connection Status Partition 1

                          Thanks in adavance for your help

                          Comment


                          • #28
                            do you have a onboard serial port you could switch out to test against?

                            I have a serial port and used that for my alarm. Then I also added 2 x pci dual serial cards for more ports as I try to avoid usb adapters but that is just me...
                            HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                            HS - HS3 Pro Edition 3.0.0.435

                            Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                            Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                            Comment


                            • #29
                              Thanks for posting, I am using a usb adapter, I tried 2 different ones the last one looks like is working better I guess I will buy a pci adapter and give it a try.

                              I didnt have much faith on the usb adapter to beging with, do you recommend any particular serial pci card? Thanks

                              Comment


                              • #30
                                I use the Edgeport 4 port serial to usb thats documented in the doc. I has work flawlessly for me.

                                Set and forget. Others can weigh in on their hw with sucess. I got mine used on fleabay with all cables.

                                Matt

                                Comment

                                Working...
                                X