Announcement

Collapse
No announcement yet.

Error - connection lost

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error - connection lost

    I keep getting the follow errors in the log. I see others are getting them also. My network is fine, so must be something with the board?


    May-07 20:06:49 EnvisaLinkAdemco INFO Password OK
    May-07 20:06:49 EnvisaLinkAdemco INFO Reconnection OK
    May-07 20:06:49 EnvisaLinkAdemco INFO Trying to reconnect to: 192.168.3.201:4025
    May-07 20:06:38 EnvisaLinkAdemco INFO Connection Lost, will try to reconnect in 10 seconds
    May-07 20:06:38 EnvisaLinkAdemco ERROR Receiver::Run() A socket error has occured: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.
    May-07 20:06:38 EnvisaLinkAdemco INFO Reconnection OK
    May-07 20:06:38 EnvisaLinkAdemco INFO Trying to reconnect to: 192.168.3.201:4025
    May-07 20:06:27 EnvisaLinkAdemco INFO Connection Lost, will try to reconnect in 10 seconds
    May-07 20:06:27 EnvisaLinkAdemco ERROR Receiver::Run() A socket error has occured: Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
    May-07 20:02:47 EnvisaLinkAdemco INFO Zone 8 status change: Closed
    May-07 20:02:28 EnvisaLinkAdemco INFO Zone 8 status change: Opened

    I am hesitant to set the polling to 30 as I have triggers based open zone. I would, however, like to stop the motion detectors from logging. I went into the node for the motion detectors and set "Do not log commands for this device" thinking that would do it, but it does not. Can I turn off logging just for the motion detectors?

  • #2
    The disconnection problem seems to be a problem specific to the EnvisaLink Ademco firmware, I have reported it several times, but it has never been fixed:
    http://forum.eyez-on.com/FORUM/viewt...aa7aed29#p7984

    As long as the plugin successfully reconnect after some time, there is not much I can do.

    Regarding logging, the "Do not log commands for this device" won't work, but I can add a specific setting at the device level, I already did it for the DSC version so it won't be difficult.

    Comment


    • #3
      Understand about the firmware. Still having support, I am going to log a bug with them also. Maybe if enough of us have the issue, they will fix it.

      Thanks for the logging at the device level. This will greatly help.

      Comment


      • #4
        Logging option at device level is in version 3.0.0.19 available here
        by default every zone and partition log their status change at Info level, if you don't want those logs for a specific zone or partition, click on the device to edit it, you should see a new tab called "EnvisaLinkAdemco", then tick the "Do not log status change" checkbox on this tab.

        Comment


        • #5
          This is working great. Thanks.

          Question...

          On the plugin page, a new log showed up. What is the difference between to the 2 logs? You have the Log Level that was there before and now there is a Log to File and level that is new.

          Log settings
          Log Level
          Log to File
          File Log Level

          Comment


          • #6
            "Log Level" is for the logs written to the HS log database that you can access from View > Log

            If "Log to File" is ticked the logs are also written to the file Logs/EnvisaLinkAdemco.txt
            "File Log Level" is the level for the logs written to the file.

            This can be useful if let's say you want to troubleshoot a problem with the EnvisaLinkAdemco plugin, but you don't want debug logs to pollute your HS logs, in this case you can set "Log Level" to Info, and "File Log Level" to Debug.

            Comment


            • #7
              Thanks a ton. This works great. Thanks for the fast turn.

              Comment

              Working...
              X