Announcement

Collapse
No announcement yet.

Help

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help

    No matter state my vista system is in, the HS device says it is Armed-Maximum. The ademco lan url has the status right, but it never seems to get to HS. Can anyone help?

  • #2
    could you post the debug logs you get when you try to arm, and post a screenshot of the "status graphics" tab of your partition device

    Comment


    • #3
      Originally posted by spud View Post
      could you post the debug logs you get when you try to arm, and post a screenshot of the "status graphics" tab of your partition device
      I stopped and started the plugin and then restarted HS and now it's working again. I've seen this before. If it happens again I post logs.
      Thanx

      Comment


      • #4
        Wrong Password

        Hello,
        I successfully installed the Envisalink 4 on my Vista20P, and am able to login into its local webpage as well as the portal successfully. I configured the plugin but its not updating the device statuses and is unable to execute any commands to the panel. The log shows the "wrong password" error. I tried changing the password several times, but the error persists. Any help will be greatly appreciated.

        Comment


        • #5
          Originally posted by Srini Potluri View Post
          Hello,
          I successfully installed the Envisalink 4 on my Vista20P, and am able to login into its local webpage as well as the portal successfully. I configured the plugin but its not updating the device statuses and is unable to execute any commands to the panel. The log shows the "wrong password" error. I tried changing the password several times, but the error persists. Any help will be greatly appreciated.
          The password you need to set in the config page is the one you use to login into the local webpage. Did you set the interface type to EVL4 ?

          If you can't figure it out, please post the content of your EnvisaLinkAdemco.ini and capture a debug log of the plugin start.
          You can also try to change the password to something <= 6 characters to see if that helps.

          Comment


          • #6
            Password Error

            Hope the attached is what you needed. I x'ed out the password and the master code. I set the password to a 4 characters.
            Thnx for looking into this.

            .INI data:

            [ENVISALINK]
            type=EVL4
            host=192.168.0.105
            password=xxxx
            [PANEL]
            zone_count=53
            master_code=xxxx
            [GENERAL]
            log_to_file_enabled=True

            Log data:

            Oct-02 12:37:56 ERROR System.NullReferenceException: Object reference not set to an instance of an object.
            at HSPI_EnvisaLinkAdemco.EnvisaLinkAdemcoApp.Shutdown()
            Oct-02 12:38:02 INFO EnvisaLinkAdemco version 3.0.0.20
            Oct-02 12:38:03 DEBUG Partition Device Found: P:1
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:2
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:3
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:4
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:5
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:6
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:7
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:8
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:9
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:10
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:11
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:12
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:13
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:14
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:15
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:16
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:17
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:18
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:19
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:20
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:21
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:22
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:23
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:24
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:25
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:26
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:27
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:28
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:29
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:30
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:31
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:32
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:33
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:34
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:35
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:36
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:37
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:38
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:39
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:40
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:41
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:42
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:43
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:44
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:45
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:46
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:47
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:48
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:49
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:50
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:51
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:52
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:53
            Oct-02 12:38:03 DEBUG Zone Device Found: Z:1
            Oct-02 12:38:03 DEBUG Received: Login:

            Oct-02 12:38:03 DEBUG Request: SendKeystrokeString ****
            Oct-02 12:38:04 DEBUG Received: FAILED

            Oct-02 12:38:04 ERROR Wrong password
            Oct-02 12:38:04 DEBUG LoginFailed
            Oct-02 12:38:17 ERROR Object reference not set to an instance of an object.
            Oct-02 12:38:17 DEBUG Stack: at HSPI_EnvisaLinkAdemco.Partition.ExecuteRequest(TpiRequest req)
            Attached Files
            Last edited by Srini Potluri; October 2nd, 2016, 11:26 AM.

            Comment


            • #7
              well, as the log says, the problem is with the password.

              are you sure you use the correct password (i.e the one you use to log into the local webpage?
              make sure there is no trailing space when you enter it?
              How many characters do you use? Do you use any special character?

              Comment


              • #8
                Password Issue

                Hi Spud,

                I am able to login into EVL-4's local web page from the PC that runs HS3, and log in without any problems. The same password does not work in the plugin. I have re-entered the same password several times in the config page, making sure the characters are accurate, without any success.

                Comment


                • #9
                  this is odd, no other user has reported this kind of problem...

                  would you let me access your HS3 PC (through team viewer or another remote control software) so that I can take a look? You can pm me or email me at spud.webb.4@gmail.com

                  Comment


                  • #10
                    Turns out Srini's problem was the length of the password. It looks like with his EVL4 and firmware version 01.00.95A, the password length needs to be exactly 10 characters, anything else wouldn't work on his set up. I contacted the firmware developer, but he couldn't reproduce the problem.

                    So, please let me know if you are experiencing the same problem.

                    thanks

                    Comment


                    • #11
                      I’m having this exact same issue. And I have it every few weeks or couple months. No matter what, the system thinks I’m inputting the wrong password. I’ve even turned on debugging and see the log shows the correct password being passed. I can arm/disarm successfully from the local Envisalink page. Even one time the plugin logged in successfully but a few seconds later said “wrong password”. I’m including the log from when this happened. Really need this working so appreciate the help.

                      I’ve had a 5 digit alpha numeric that works fine (although this issue comes up on occasion). But I also tried a 4 digit and 6 digit password, same results. Password s for now 123456. The last thing I tried was rebooting the Envisilink via the Eyezon vendor page (Alarm Relay).
                      Nov-21 00:32:06 Event Event Trigger "Security Turn Off Alarm"
                      Nov-21 00:31:33 EnvisaLinkAdemco ERROR
                      Nov-21 00:31:33 EnvisaLinkAdemco ERROR Wrong password
                      Nov-21 00:31:33 Starting Plug-In Plugin EnvisaLinkAdemco started successfully in 20414 milliseconds
                      Nov-21 00:31:26 Plug-In Finished initializing plug-in EnvisaLinkAdemco
                      Nov-21 00:31:26 Starting Plug-In EnvisaLinkAdemco loaded in 15055 milliseconds
                      Nov-21 00:31:12 Starting Plug-In Initializing plugin EnvisaLinkAdemco ...
                      Nov-21 00:31:12 Info Plugin EnvisaLinkAdemco has connected. IP:127.0.0.1:40896
                      Nov-21 00:31:05 Info Plugin EnvisaLinkAdemco with instance: has disconnected
                      Nov-21 00:31:05 Plug-In Shutting down Plug-In: EnvisaLinkAdemco
                      Nov-21 00:30:48 EnvisaLinkAdemco DEBUG VirtualKeypadUpdate 01,8C08,08,00,ARMED ***STAY***
                      Nov-21 00:30:48 EnvisaLinkAdemco DEBUG Received: %00,01,8C08,08,00,ARMED ***STAY*** $
                      Nov-21 00:30:41 EnvisaLinkAdemco DEBUG EnvisaLinkZoneTimerDump 20E9A1F600000000BDF689F2000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 0000000000000000
                      Nov-21 00:30:41 EnvisaLinkAdemco DEBUG Received: %FF,20E9A1F600000000BDF689F200000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 00000000000000000000$
                      Nov-21 00:30:41 EnvisaLinkAdemco DEBUG CommandAck 02,00
                      Nov-21 00:30:41 EnvisaLinkAdemco DEBUG Received: ^02,00$
                      Nov-21 00:30:41 EnvisaLinkAdemco DEBUG Request: DumpZoneTimers ^02,$
                      Nov-21 00:30:38 EnvisaLinkAdemco DEBUG VirtualKeypadUpdate 01,8C08,08,00,ARMED ***STAY***
                      Nov-21 00:30:38 EnvisaLinkAdemco DEBUG Received: %00,01,8C08,08,00,ARMED ***STAY*** $
                      Nov-21 00:30:29 EnvisaLinkAdemco DEBUG VirtualKeypadUpdate 01,8C08,08,00,ARMED ***STAY***
                      Nov-21 00:30:29 EnvisaLinkAdemco DEBUG Received: %00,01,8C08,08,00,ARMED ***STAY*** $
                      Nov-21 00:30:19 EnvisaLinkAdemco DEBUG VirtualKeypadUpdate 01,8C08,08,00,ARMED ***STAY***
                      Nov-21 00:30:19 EnvisaLinkAdemco DEBUG Received: %00,01,8C08,08,00,ARMED ***STAY*** $
                      Nov-21 00:30:11 EnvisaLinkAdemco DEBUG EnvisaLinkZoneTimerDump 26E9A7F600000000C3F68FF2000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 0000000000000000
                      Nov-21 00:30:11 EnvisaLinkAdemco DEBUG Received: %FF,26E9A7F600000000C3F68FF200000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 00000000000000000000$
                      Nov-21 00:30:11 EnvisaLinkAdemco DEBUG CommandAck 02,00
                      Nov-21 00:30:11 EnvisaLinkAdemco DEBUG Received: ^02,00$
                      Nov-21 00:30:11 EnvisaLinkAdemco DEBUG Request: DumpZoneTimers ^02,$
                      Nov-21 00:30:09 EnvisaLinkAdemco DEBUG VirtualKeypadUpdate 01,8C08,08,00,ARMED ***STAY***
                      Nov-21 00:30:09 EnvisaLinkAdemco DEBUG Received: %00,01,8C08,08,00,ARMED ***STAY*** $
                      Nov-21 00:29:59 EnvisaLinkAdemco DEBUG VirtualKeypadUpdate 01,8C08,08,00,ARMED ***STAY***
                      Nov-21 00:29:59 EnvisaLinkAdemco DEBUG Received: %00,01,8C08,08,00,ARMED ***STAY*** $
                      Nov-21 00:29:49 EnvisaLinkAdemco DEBUG VirtualKeypadUpdate 01,8C08,08,00,ARMED ***STAY***
                      Nov-21 00:29:49 EnvisaLinkAdemco DEBUG Received: %00,01,8C08,08,00,ARMED ***STAY*** $
                      Nov-21 00:29:42 EnvisaLinkAdemco INFO 7 Upstairs Windows status change: Closed
                      Nov-21 00:29:42 EnvisaLinkAdemco INFO 6 Master Bedroom Door & Windows status change: Closed
                      Nov-21 00:29:42 EnvisaLinkAdemco INFO 5 Kitchen Laundry Office Door & Windows status change: Closed
                      Nov-21 00:29:42 EnvisaLinkAdemco INFO 4 Dining/Study Windows status change: Closed
                      Nov-21 00:29:42 EnvisaLinkAdemco INFO 3 Living Room Windows status change: Closed
                      Nov-21 00:29:41 EnvisaLinkAdemco INFO 2 Garage Entry status change: Closed
                      Nov-21 00:29:41 EnvisaLinkAdemco INFO 1 Front Door Entry status change: Closed
                      Nov-21 00:29:41 EnvisaLinkAdemco DEBUG EnvisaLinkZoneTimerDump 2CE9ADF600000000C9F695F2000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 0000000000000000
                      Nov-21 00:29:41 EnvisaLinkAdemco DEBUG Received: %FF,2CE9ADF600000000C9F695F200000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 00000000000000000000$
                      Nov-21 00:29:41 EnvisaLinkAdemco DEBUG CommandAck 02,00
                      Nov-21 00:29:41 EnvisaLinkAdemco DEBUG Received: ^02,00$
                      Nov-21 00:29:41 EnvisaLinkAdemco DEBUG Request: DumpZoneTimers ^02,$
                      Nov-21 00:29:41 EnvisaLinkAdemco DEBUG LoginOK
                      Nov-21 00:29:41 EnvisaLinkAdemco INFO Password OK
                      Nov-21 00:29:41 EnvisaLinkAdemco DEBUG Received: OK
                      Nov-21 00:29:41 EnvisaLinkAdemco DEBUG LoginInteraction
                      Nov-21 00:29:41 EnvisaLinkAdemco DEBUG Request: SendKeystrokeString 123456
                      Nov-21 00:29:41 EnvisaLinkAdemco DEBUG Received: Login:
                      Nov-21 00:29:41 Starting Plug-In Plugin EnvisaLinkAdemco started successfully in 21194 milliseconds
                      Nov-21 00:29:37 EnvisaLinkAdemco DEBUG Zone Device Found: Z:10
                      Nov-21 00:29:37 EnvisaLinkAdemco DEBUG Zone Device Found: Z:9
                      Nov-21 00:29:37 EnvisaLinkAdemco DEBUG Zone Device Found: Z:8
                      Nov-21 00:29:37 EnvisaLinkAdemco DEBUG Zone Device Found: Z:7
                      Nov-21 00:29:37 EnvisaLinkAdemco DEBUG Zone Device Found: Z:6
                      Nov-21 00:29:37 EnvisaLinkAdemco DEBUG Zone Device Found: Z:5
                      Nov-21 00:29:37 EnvisaLinkAdemco DEBUG Zone Device Found: Z:4
                      Nov-21 00:29:36 EnvisaLinkAdemco DEBUG Zone Device Found: Z:3
                      Nov-21 00:29:36 EnvisaLinkAdemco DEBUG Zone Device Found: Z:2
                      Nov-21 00:29:36 EnvisaLinkAdemco DEBUG Zone Device Found: Z:1
                      Nov-21 00:29:34 EnvisaLinkAdemco DEBUG User Access Device Found: U:1
                      Nov-21 00:29:33 Plug-In Finished initializing plug-in EnvisaLinkAdemco
                      Nov-21 00:29:33 Starting Plug-In EnvisaLinkAdemco loaded in 15048 milliseconds
                      Nov-21 00:29:28 EnvisaLinkAdemco DEBUG Partition Device Found: P:1
                      Nov-21 00:29:20 EnvisaLinkAdemco INFO EnvisaLinkAdemco version 3.0.0.31
                      Nov-21 00:29:20 Starting Plug-In Initializing plugin EnvisaLinkAdemco ...
                      Nov-21 00:29:20 Info Plugin EnvisaLinkAdemco has connected. IP:127.0.0.1:40870
                      Nov-21 00:29:11 Info Plugin EnvisaLinkAdemco with instance: has disconnected
                      Nov-21 00:29:11 Plug-In Shutting down Plug-In: EnvisaLinkAdemco
                      Nov-21 00:28:54 Z-Wave Device: Down Living Room Kids Table Lamp Volts 1 Set to 125.578 (125.578 Volts)
                      Nov-21 00:23:58 EnvisaLinkAdemco DEBUG LoginFailed
                      Nov-21 00:23:58 EnvisaLinkAdemco ERROR
                      Nov-21 00:23:58 EnvisaLinkAdemco ERROR Wrong password
                      Nov-21 00:23:58 EnvisaLinkAdemco DEBUG Received: FAILED
                      Nov-21 00:23:58 EnvisaLinkAdemco DEBUG LoginInteraction
                      Nov-21 00:23:58 EnvisaLinkAdemco DEBUG Request: SendKeystrokeString 071902
                      Nov-21 00:23:58 EnvisaLinkAdemco DEBUG Received: Login:
                      Nov-21 00:23:58 Starting Plug-In Plugin EnvisaLinkAdemco started successfully in 19683 milliseconds
                      Nov-21 00:23:54 EnvisaLinkAdemco DEBUG Zone Device Found: Z:10
                      Nov-21 00:23:54 EnvisaLinkAdemco DEBUG Zone Device Found: Z:9
                      Nov-21 00:23:54 EnvisaLinkAdemco DEBUG Zone Device Found: Z:8
                      Nov-21 00:23:54 EnvisaLinkAdemco DEBUG Zone Device Found: Z:7
                      Nov-21 00:23:54 EnvisaLinkAdemco DEBUG Zone Device Found: Z:6
                      Nov-21 00:23:54 EnvisaLinkAdemco DEBUG Zone Device Found: Z:5
                      Nov-21 00:23:54 EnvisaLinkAdemco DEBUG Zone Device Found: Z:4
                      Nov-21 00:23:54 EnvisaLinkAdemco DEBUG Zone Device Found: Z:3
                      Nov-21 00:23:54 EnvisaLinkAdemco DEBUG Zone Device Found: Z:2
                      Nov-21 00:23:54 EnvisaLinkAdemco DEBUG Zone Device Found: Z:1
                      Nov-21 00:23:52 EnvisaLinkAdemco DEBUG User Access Device Found: U:1
                      Nov-21 00:23:51 Plug-In Finished initializing plug-in EnvisaLinkAdemco
                      Nov-21 00:23:51 Starting Plug-In EnvisaLinkAdemco loaded in 15062 milliseconds
                      Nov-21 00:23:46 EnvisaLinkAdemco DEBUG Partition Device Found: P:1
                      Nov-21 00:23:38 EnvisaLinkAdemco INFO EnvisaLinkAdemco version 3.0.0.31
                      Nov-21 00:23:38 Starting Plug-In Initializing plugin EnvisaLinkAdemco ...
                      Nov-21 00:23:38 Info Plugin EnvisaLinkAdemco has connected. IP:127.0.0.1:40810
                      Nov-21 00:22:42 Error Displaying remotely connected interfaces: Object reference not set to an instance of an object.
                      Nov-21 00:22:40 Info Plugin EnvisaLinkAdemco with instance: has disconnected
                      Nov-21 00:22:40 Plug-In Shutting down Plug-In: EnvisaLinkAdemco
                      Nov-21 00:22:03 Z-Wave Device: Down Study TAHOE - Power Set to 84.304 (W)
                      Nov-21 00:22:03 Z-Wave Device: Down Study TAHOE - Watts Set to 84.304 (84.304 Watts)
                      Nov-21 00:22:03 Z-Wave Device: Down Study TAHOE - kW Hours Set to 1744.93 (1744.93 kW Hours)
                      Nov-21 00:19:00 EnvisaLinkAdemco ERROR
                      Nov-21 00:19:00 EnvisaLinkAdemco ERROR Wrong password
                      Nov-21 00:19:00 Starting Plug-In Plugin EnvisaLinkAdemco started successfully in 19116 milliseconds
                      Nov-21 00:18:54 Plug-In Finished initializing plug-in EnvisaLinkAdemco
                      Nov-21 00:18:54 Starting Plug-In EnvisaLinkAdemco loaded in 15057 milliseconds

                      Comment


                      • #12
                        Please try with a 10 character password and let me know

                        thanks

                        Comment

                        Working...
                        X