Announcement

Collapse
No announcement yet.

Bypass status not showing correctly

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • automateme
    started a topic Bypass status not showing correctly

    Bypass status not showing correctly

    I am running the latest version of the plugin 3.0.0.40. I cannot get the bypass status to be reflected correctly on the Device Management page. When I tap the "Bypass" button on the device management page, the Zone correctly bypasses on the alarm panel. The icon for the bypassed device also changes to "Bypassed" on the device management page. When I tap the bypass again, the zone returns to normal, but the icon on the device management page never changes back to "Active". I have restarted the plugin and restarted HS3, but the icon is stuck showing bypassed. Looking at the log when the plugin starts up, it shows that the plugin is recognizing the correct state of the zone.

    May-16 7:34:32 PM EnvisaLink INFO North Hallway Windows status change: Closed
    May-16 7:34:32 PM EnvisaLink INFO Family Room Windows status change: Closed
    May-16 7:34:32 PM EnvisaLink INFO Family Room Slider status change: Closed
    May-16 7:34:32 PM EnvisaLink INFO Nook Windows status change: Closed
    May-16 7:34:32 PM EnvisaLink INFO Kitchen Windows status change: Closed
    May-16 7:34:32 PM EnvisaLink INFO South Hallway Window status change: Closed
    Attached Files

  • Kitar
    replied
    Originally posted by spud View Post

    From you logs, each time you try to Bypass or Unbypass a zone, the system sends to the plugin a CodeRequired message to which the plugin automatically answers with the code you specified in the config page. Then the panel wrongly interpret that as a request to arm/disarm the panel. I'm not sure why it does that and does not interpret the code sent as the answered to the CodeRequired message.
    Anyway I think you can disable the needs to enter a user code to access the bypass feature.
    See for example in this programming guide:
    https://drive.google.com/file/d/0B71...hFVWhNXzA/view



    I wasn't aware of this feature until now, so it's set to OFF on my personal system, and I guess also on most users that uses this plugin.
    Yes exactly. My bypass does indeed require a user code.

    Next time I am near my system I will change that option. I think I can live without it. I will let you know the results.

    Thank you for checking that out.

    Leave a comment:


  • spud
    replied
    Originally posted by Kitar View Post

    I'm PM'ing you the log of pressing the Bypass with all zones closed. Please let me know if there is anything else I can assist with.

    edit: PM'd you 2 logs that cover most conditions
    From you logs, each time you try to Bypass or Unbypass a zone, the system sends to the plugin a CodeRequired message to which the plugin automatically answers with the code you specified in the config page. Then the panel wrongly interpret that as a request to arm/disarm the panel. I'm not sure why it does that and does not interpret the code sent as the answered to the CodeRequired message.
    Anyway I think you can disable the needs to enter a user code to access the bypass feature.
    See for example in this programming guide:
    https://drive.google.com/file/d/0B71...hFVWhNXzA/view

    Section [015] Third System Option Code

    [5] ON: a valid user code must be entered after pressing[*][1] to access the Bypass feature. OFF: a user code is not required.
    I wasn't aware of this feature until now, so it's set to OFF on my personal system, and I guess also on most users that uses this plugin.

    Leave a comment:


  • Kitar
    replied
    Originally posted by spud View Post

    Could you provide some debug logs please.
    I'm PM'ing you the log of pressing the Bypass with all zones closed. Please let me know if there is anything else I can assist with.

    edit: PM'd you 2 logs that cover most conditions

    Leave a comment:


  • spud
    replied
    Originally posted by Kitar View Post
    Spud,
    I wish it were that simple. I've read the user guide and set that option to enabled but it does not make any difference to the operation of the bypass.
    Pressing bypass on a closed door arms the alarm but the Status Devices still report Active. As far as I can tell the panel sees the bypass button as an Arm Stay button. As I mentioned pressing the Bypass button with a zone open leads to a Failure to Arm.

    The Status Devices show bypass state when I bypassed at the keypad. But when I disarm, the bypass status does not change back to Active.

    I've uploaded my panel with DLS to see if there is any unusual settings that might change the behavior.

    Thanks for any help you can provide.
    Could you provide some debug logs please.

    Leave a comment:


  • Kitar
    replied
    Spud,
    I wish it were that simple. I've read the user guide and set that option to enabled but it does not make any difference to the operation of the bypass.
    Pressing bypass on a closed door arms the alarm but the Status Devices still report Active. As far as I can tell the panel sees the bypass button as an Arm Stay button. As I mentioned pressing the Bypass button with a zone open leads to a Failure to Arm.

    The Status Devices show bypass state when I bypassed at the keypad. But when I disarm, the bypass status does not change back to Active.

    I've uploaded my panel with DLS to see if there is any unusual settings that might change the behavior.

    Thanks for any help you can provide.

    Leave a comment:


  • spud
    replied
    the bypass status is not supposed to show in the zone devices, some separate specific devices are created if you have "Create additional devices for zone bypassed status" checked in the config page.

    read the user guide

    Leave a comment:


  • Kitar
    replied
    Originally posted by spud View Post

    If your zones always report as closed, this looks like a different problem not limited to the Bypass feature.
    Could you give more details and post some debug logs?
    Hi Spud, my mistake the zone status is always reported correctly as either open or closed but it will not display "Bypass" in the device manager.


    Pressing bypass on Z02 with zone open = panel reports Not Ready and refuses to arm.
    Pressing bypass on Z02 with zone closed = panel Arms in stay mode. No zone bypasses are shown on the keypad, just the usual interior bypass for an Arm Stay.

    I can only initiate a bypass of the door zone from the keypad. In the picture below I bypassed the Garage Entry using the DSC keypad. The device manager zone does not show the bypass, but it does show armed and Z02 open.

    Click image for larger version

Name:	Cap.PNG
Views:	5
Size:	217.5 KB
ID:	1273709

    Leave a comment:


  • spud
    replied
    Originally posted by Kitar View Post
    Similar problem here.
    Envisalink 3 just updated to Ver .195 to see if this would solve the problem but it does not.

    The main problem seems to be the display in the device manager. The zone always reports closed.

    None of my Envisalink PI devices have an associated graphic for the -1000 Bypass state. Not sure if that makes a difference.

    Hitting the Bypass button on an exterior zone arms the panel in Stay Mode after the usual 30 second delay.

    Ideas appreciated.
    If your zones always report as closed, this looks like a different problem not limited to the Bypass feature.
    Could you give more details and post some debug logs?

    Leave a comment:


  • Kitar
    replied
    Similar problem here.
    Envisalink 3 just updated to Ver .195 to see if this would solve the problem but it does not.

    The main problem seems to be the display in the device manager. The zone always reports closed.

    None of my Envisalink PI devices have an associated graphic for the -1000 Bypass state. Not sure if that makes a difference.

    Hitting the Bypass button on an exterior zone arms the panel in Stay Mode after the usual 30 second delay.

    Ideas appreciated.

    Leave a comment:


  • automateme
    replied
    Originally posted by spud View Post
    You can ask them to force an update, if you give them the mac address of your EVL board.
    Wow! I sent in a support request through my EnvisaLink online account and received a response from support in 15 minutes. The support rep didn't really know what I was referring to with Bypass status not being reported correctly in Homeseer, but he went ahead and updated me to 195. I can report that the firmware update to 195 corrected the bypass issue for me as well.
    Last edited by automateme; June 1st, 2018, 07:07 AM.

    Leave a comment:


  • spud
    replied
    Originally posted by automateme View Post
    Good to see that I am not the only one experiencing this. My EVL3 is connected to my online account and stuck at 191. I wonder if there is any way to request a firmware update rather that waiting for it to eventually make it to my device. I will send in a support request to EnvisaLink and see if I get a response.
    You can ask them to force an update, if you give them the mac address of your EVL board.

    Leave a comment:


  • automateme
    replied
    Good to see that I am not the only one experiencing this. My EVL3 is connected to my online account and stuck at 191. I wonder if there is any way to request a firmware update rather that waiting for it to eventually make it to my device. I will send in a support request to EnvisaLink and see if I get a response.

    Leave a comment:


  • claude
    replied
    Originally posted by gerard927 View Post
    ... So from time to time, I add my EVL-3 back to my account to allow any firmware updates to push. Then I remove it again.

    When I did that this past week I got the new firmware, which fixed the bypass status issue. For me, at least.
    OK.

    I'm still on 01.12.191, so I guess patience until the update kicks in.

    Leave a comment:


  • gerard927
    replied
    I don't leave my EVL-3 connected to the EyezOn server. No one (besides me) needs to be able to remotely see what state my alarm is in. So from time to time, I add my EVL-3 back to my account to allow any firmware updates to push. Then I remove it again.

    When I did that this past week I got the new firmware, which fixed the bypass status issue. For me, at least.

    Leave a comment:

Working...
X