Announcement

Collapse
No announcement yet.

Trapping Arming STAY vs Arming AWAY

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trapping Arming STAY vs Arming AWAY

    Is there a way of trapping what kind of arming event is taking place?

    I can't seem to discriminate between arming stay and arming away.
    Once armed it does report the armed mode, but I am interested in the arming mode not the armed mode.

  • #2
    I don't think it's possible to differentiate between away and stay while the system is arming, sorry.

    Comment


    • #3
      I am also having that problem but I am ok with waiting till it has completed arming. I just want to run an event once the system is armed away or a different event if the system is armed stay. It's ok it it doesn't happen until after exit delay. Is there a way to do that? I can't find it as a trigger option.

      Comment


      • #4
        Originally posted by jterfehr2000 View Post
        I am also having that problem but I am ok with waiting till it has completed arming. I just want to run an event once the system is armed away or a different event if the system is armed stay. It's ok it it doesn't happen until after exit delay. Is there a way to do that? I can't find it as a trigger option.
        for this you can use the native trigger "this device changes and becomes..." and chose your partition device:

        Click image for larger version

Name:	eventwithdevicetrigger.png
Views:	1
Size:	4.1 KB
ID:	1188566

        Comment


        • #5
          Just to point out Spud's example above, I have two events setup to send Pushover alerts letting me know the house has been locked down. One for Away and one for stay.
          Attached Files

          Comment


          • #6
            Works like a charm..thanks from a newbie!

            Comment


            • #7
              Please indulge another perhaps newbie related question. I can't get the event below to fire when I disarm...any suggestions?
              Attached Files

              Comment


              • #8
                Could you post the debug logs you get when you disarm, I'd like to check that the plugin receives the disarmed message.

                Comment


                • #9
                  Jan-16 2:18:12 PM Device Control Device: EnvisaLink Partition 1 to Disarm (-1002) by/from: CAPI Control Handler
                  Jan-16 2:18:04 PM Device Control Device: EnvisaLink Partition 1 to Arm Stay (-1000) by/from: CAPI Control Handler
                  Jan-16 2:15:09 PM Device Control Device: EnvisaLink Partition 1 to Disarm (-1002) by/from: CAPI Control Handler
                  Jan-16 2:14:57 PM Device Control Device: EnvisaLink Partition 1 to Arm Away (-1001) by/from: CAPI Control Handler
                  Jan-16 2:00:53 PM Device Control Device: EnvisaLink Partition 1 to Disarm (-1002) by/from: CAPI Control Handler
                  Jan-16 2:00:48 PM Device Control Device: EnvisaLink Partition 1 to Arm Stay (-1000) by/from: CAPI Control Handler
                  Jan-16 1:59:18 PM Device Control Device: EnvisaLink Partition 1 to Disarm (-1002) by/from: CAPI Control Handler
                  Jan-16 1:59:08 PM Device Control Device: EnvisaLink Partition 1 to Arm Away (-1001)

                  Comment


                  • #10
                    sorry...here you go


                    Jan-16 2:22:18 PM EnvisaLink DEBUG CommandAcknowledge 000
                    Jan-16 2:22:18 PM EnvisaLink DEBUG Request: Poll
                    Jan-16 2:21:07 PM EnvisaLink DEBUG PartitionReadyForceArmingEnabled 1
                    Jan-16 2:21:07 PM EnvisaLink INFO Partition 1 status change: Ready - Force Arming Enabled
                    Jan-16 2:21:03 PM EnvisaLink DEBUG KeypadLedStatePartition1Only 81
                    Jan-16 2:21:03 PM EnvisaLink DEBUG PartitionDisarmed 1
                    Jan-16 2:21:02 PM EnvisaLink DEBUG CommandAcknowledge 040
                    Jan-16 2:21:02 PM EnvisaLink DEBUG Request: PartitionDisarmControl 13786
                    Jan-16 2:20:53 PM EnvisaLink DEBUG KeypadLedStatePartition1Only 8B
                    Jan-16 2:20:53 PM EnvisaLink DEBUG ExitDelayinProgress 1
                    Jan-16 2:20:53 PM EnvisaLink INFO Partition 1 status change: Exit Delay in Progress
                    Jan-16 2:20:52 PM EnvisaLink DEBUG CommandAcknowledge 031
                    Jan-16 2:20:52 PM EnvisaLink DEBUG Request: PartitionArmControlStayArm 1
                    Jan-16 2:20:31 PM EnvisaLink DEBUG postBackProc data: logtofileenabled=checked&id=logtofileenabled
                    Jan-16 2:18:59 PM EnvisaLink DEBUG postBackProc data: id=loglevel&loglevel=2
                    Jan-16 2:18:18 PM EnvisaLink INFO Partition 1 status change: Ready - Force Arming Enabled

                    Comment


                    • #11
                      everything looks ok, and I just tested a similar event on my system and it worked, so I don't know what's wrong

                      the logs you posted, are they filtered on "EnvisaLink" or is this all the logs?

                      maybe you have some group conditions that prevent the event to be fired?

                      try to recreate a simpler event in a new group with just one speak action.

                      Comment


                      • #12
                        It is inexplicably now firing as designed (I did nothing)....COMPUTERS!!!!

                        (perhaps my server sensed that the master programmer was on the case and straightened up)

                        Thanks for the help.

                        Comment

                        Working...
                        X