Announcement

Collapse
No announcement yet.

How to capture triggering zone when partition is in alarm

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to capture triggering zone when partition is in alarm

    What's the best way to report on the zone that triggered an alarm?

  • #2
    there is no easy way to do that, you would have to use scripting and scan all your zones to find opened ones

    this thread contains a script that doesn't do exactly what you want, but it could help you.

    Comment


    • #3
      Ok, was hoping the alarm sent the triggering zone number and that could be captured. Some non-violation zones may normally be open, but those can be skipped in a script used for an alarm event.

      Comment


      • #4
        I just recently purchased a DSC panel and got the envisalink stuff working. I know there is 100's of ways to skin a cat with this stuff, and I wanted to share how I personally did this request so that others looking may know. I did use the script that updates the Partition device with current zone opened. I have it going to a separate Virtual Device and changed my triggers. Basically HS will run the script to update the VD, only if the system received an "In Alarm" notification from the alarm. I have a delay in there of 2 seconds to give the script time to update the device before sending the notification.
        Attached Files

        Comment


        • #5
          Originally posted by waynehead99 View Post
          I just recently purchased a DSC panel and got the envisalink stuff working. I know there is 100's of ways to skin a cat with this stuff, and I wanted to share how I personally did this request so that others looking may know. I did use the script that updates the Partition device with current zone opened. I have it going to a separate Virtual Device and changed my triggers. Basically HS will run the script to update the VD, only if the system received an "In Alarm" notification from the alarm. I have a delay in there of 2 seconds to give the script time to update the device before sending the notification.
          Can you share the changes that you made to the script for your method. I like your approach to use a separate virtual device, and only run the script if the partition is in alarm.

          Comment


          • #6
            I was able to make the slight modifications to the script and setup the virtual device and event to behave the way that I needed. Everything is working well now.

            Comment


            • #7
              Originally posted by automateme View Post
              I was able to make the slight modifications to the script and setup the virtual device and event to behave the way that I needed. Everything is working well now.
              John, I apologize. I didn't see your initial request. If you have any other questions on what I did, I will watch for them.

              Comment


              • #8
                Originally posted by waynehead99 View Post
                John, I apologize. I didn't see your initial request. If you have any other questions on what I did, I will watch for them.
                No worries Wayne! It was good to dig into the script to see what it was doing. Thanks for the idea on using a separate virtual device.

                Comment


                • #9
                  I have 3 partitions and only want to send a text message when partition 1 goes into alarm (or a wrong code was entered). Do you still have to revert to scripts to achieve this? Btw, I am using the IT 100. I assume that doesn't make any difference.

                  Comment


                  • #10
                    Originally posted by mulu View Post
                    I have 3 partitions and only want to send a text message when partition 1 goes into alarm (or a wrong code was entered). Do you still have to revert to scripts to achieve this? Btw, I am using the IT 100. I assume that doesn't make any difference.
                    This is a forum for the EnvisaLink plugin which doesn't work with the IT100, so you may want to post in the plugin forum of the plugin you are actually using.

                    Comment


                    • #11
                      I am using the Envisalink 4 with this plug in, and I have created an event like the one pictured above by waynehead99 posted. I have purposely set my system into alarm to test it and it does not get the signal. When I look at the device list, Partition 1 shows Armed Away and does not change. There seems to be no indication that the alarm has been triggered. I have even waited for several minutes and no change. Am I missing something? Does this only work if I pay Envisalink the monthly monitoring fee?

                      Any insight would be greatly appreciated.

                      Comment


                      • #12
                        Originally posted by dsmasher View Post
                        I am using the Envisalink 4 with this plug in, and I have created an event like the one pictured above by waynehead99 posted. I have purposely set my system into alarm to test it and it does not get the signal. When I look at the device list, Partition 1 shows Armed Away and does not change. There seems to be no indication that the alarm has been triggered. I have even waited for several minutes and no change. Am I missing something? Does this only work if I pay Envisalink the monthly monitoring fee?

                        Any insight would be greatly appreciated.
                        You don't need to pay the monthly monitoring fee for this to work
                        When the system is set into alarm the Partition 1 device should change status and says "In Alarm"
                        Does arming/disarming work from the HS device management page?

                        From the config page of the plugin set the log level to Debug, and then set your system into alarm, then post the logs you get (VIEW > Log) here.

                        thanks

                        Comment


                        • #13
                          Thanks Spud, this is what I got...

                          Click image for larger version

Name:	Log Capture.JPG
Views:	11
Size:	168.0 KB
ID:	1257023

                          Comment


                          • #14
                            For some reasons, the panel does not send the PartitionInAlarm message to the plugin. I'm not sure if it is a problem with the EnvisaLink board or with the way your panel is configured.
                            I just tested this on my own system and I correctly get the the PartiionInAlarm message resulting in the partition device status changing to "In Alarm".

                            That being said you get the ZoneAlarm message, so you could use the ZoneAlarm trigger like in the screenshot below:
                            Click image for larger version

Name:	zonealarm.png
Views:	12
Size:	8.7 KB
ID:	1257095

                            Comment

                            Working...
                            X