Announcement

Collapse
No announcement yet.

bypass not working when code required option is ON

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • fleurys
    replied
    Everything now works perfectly. I had though to separate the actions and add the wait 1seconds twice... here's the complete bypass sequence:

    1) send keystroke string = *1
    2) wait 1 sec
    3) send keystroke string = **** <- master code here
    4) wait 1 sec
    5) send keystroke string = 04# <- zone to bypass here



    Thank you again.
    S.

    Leave a comment:


  • spud
    replied
    sorry for the delay
    could you try to insert a 1s or 2s wait action between the 2 "Send Keystroke String" action, another user said it was necessary in this thread: http://forums.homeseer.com/showthread.php?t=176603

    Leave a comment:


  • fleurys
    replied
    nobody ? SPUD ? **

    Leave a comment:


  • fleurys
    replied
    **BUMP***

    Leave a comment:


  • fleurys
    replied
    Originally posted by spud View Post
    Have you tried to split the string in two, and use 2 "Send Keystroke String" action?

    Just tried it, but it does not work... Looking at the logs, it seems that a 1 is being sent a t the beginning of the string which could be the problem ?

    I splitted the two command like so :
    1) *19999
    2) 02#

    and here's the log


    Jul-22 12:36:09 PM EnvisaLink DEBUG SystemError 010
    Jul-22 12:36:08 PM EnvisaLink DEBUG Request: CodeSend 9999
    Jul-22 12:36:08 PM EnvisaLink DEBUG CodeRequired
    Jul-22 12:36:08 PM EnvisaLink DEBUG KeypadLedStatePartition1Only 80
    Jul-22 12:36:08 PM EnvisaLink DEBUG SystemError 010
    Jul-22 12:36:08 PM EnvisaLink DEBUG CommandAcknowledge 071
    Jul-22 12:36:08 PM EnvisaLink DEBUG Request: SendKeystrokeString 102#
    Jul-22 12:36:08 PM EnvisaLink DEBUG Request: SendKeystrokeString 1*19999

    Leave a comment:


  • spud
    replied
    Originally posted by fleurys View Post
    Now I have tried what you suggested but it failed because the log says it must be 6 characters or less...

    Jul-21 3:08:34 PM EnvisaLink ERROR Invalid keystroke string: *1999902#. Keystroke string must be 6 character max, and must contains 1,2,...,9,*,# only

    S.
    Have you tried to split the string in two, and use 2 "Send Keystroke String" action?

    Leave a comment:


  • fleurys
    replied
    Originally posted by spud View Post
    Not sure what code you would like to use here?
    When the plug-in is requested for a code it always sends the one you have set up in the config page.

    Also, you can try to use a "Send Keystroke String" action from an event with the master code in it: *1<code>02#
    Does it work?


    Well, I would to see *1029999# be sent because this is what is needed to be sent when the option is set to on.

    I understand that the plug-in sends the master code when asked, but by the time this is sent, the previous command (the bypass) has already failed. So At that point when the master code is sent, it basically arms the system like if the code was sent when there is no command waiting for it.

    Now I have tried what you suggested but it failed because the log says it must be 6 characters or less...

    Jul-21 3:08:34 PM EnvisaLink ERROR Invalid keystroke string: *1999902#. Keystroke string must be 6 character max, and must contains 1,2,...,9,*,# only

    S.

    Leave a comment:


  • spud
    replied
    Originally posted by fleurys View Post

    Anyway to modify the code sent for the bypass ? I would really like to keep this added security option.
    Not sure what code you would like to use here?
    When the plug-in is requested for a code it always sends the one you have set up in the config page.

    Also, you can try to use a "Send Keystroke String" action from an event with the master code in it: *1<code>02#
    Does it work?

    Leave a comment:


  • fleurys
    replied
    Thanks....didn't see that one..
    S.

    Leave a comment:


  • sparkman
    replied
    Originally posted by fleurys View Post
    **BUMP***
    http://board.homeseer.com/showthread.php?t=182534

    Leave a comment:


  • fleurys
    replied
    **BUMP***

    Leave a comment:


  • fleurys
    started a topic bypass not working when code required option is ON

    bypass not working when code required option is ON

    Just installed the plugin and everything works like a charm except the bypass feature...

    Since I did not liked the fact that you could bypass a zone without being asked to authenticate, I have enabled the option in the DSC PC1616 which does require the master code to be entered. This option is described in the installation manual as being the following :

    Section 015 (Third system option code), Option 5, ON require a code, OFF does not

    So when I try to bypass any zone, it does not bypass it, but also arms the system with arm away comand..

    basically, in order for me to bypass a zone, I need to do the following:

    1) *1
    2) master code
    3) 02 (zone to be bypassed)
    4) #


    Here 's the debug log of the command :

    Jul-15 7:47:33 PM EnvisaLink INFO Partition 1 status change: Exit Delay in Progress
    Jul-15 7:47:33 PM EnvisaLink DEBUG ExitDelayinProgress 1
    Jul-15 7:47:33 PM EnvisaLink DEBUG KeypadLedStatePartition1Only 8B
    Jul-15 7:47:32 PM EnvisaLink INFO Partition 1 status change: Ready
    Jul-15 7:47:32 PM EnvisaLink DEBUG PartitionReady 1
    Jul-15 7:47:32 PM EnvisaLink DEBUG KeypadLedStatePartition1Only 81
    Jul-15 7:47:32 PM EnvisaLink DEBUG CommandAcknowledge 200
    Jul-15 7:47:31 PM EnvisaLink DEBUG Request: CodeSend **** Master code here !
    Jul-15 7:47:31 PM EnvisaLink DEBUG CodeRequired
    Jul-15 7:47:31 PM EnvisaLink DEBUG KeypadLedStatePartition1Only 80
    Jul-15 7:47:31 PM EnvisaLink DEBUG CommandAcknowledge 071
    Jul-15 7:47:31 PM EnvisaLink DEBUG Request: SendKeystrokeString 1*102#
    Jul-15 7:47:31 PM Device Control Device: EnvisaLink Porte Garage to Bypass (-1000) by/from: CAPI Control Handler


    Anyway to modify the code sent for the bypass ? I would really like to keep this added security option.

    Thanks.
Working...
X