Announcement

Collapse
No announcement yet.

What's the best way to trigger an event based on alarm being armed Away?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • What's the best way to trigger an event based on alarm being armed Away?

    Hi everyone,

    I'm trying to set it so that when the alarm is armed away, it changes Blue Iris's camera schedule to profile 2. When I tested it at home it worked, but I just armed the alarm and left, and now it shows it never updated anything. The log shows the event ran but then changed by itself again.

    Here's a screenshot of my event, basically I have it if the alarm changes status to armed away, change Blue Iris's profile: http://imgur.com/a/xSR8T

    Again this worked at home when I tested it but now that I've actually armed the alarm and left the house it didn't work! Here's the log from then, you can see the door open, at 3:00:41 the alarm changes to armed away, and my event triggers changing the profile to 1 as expected, however at 3:03:52 it says alarm status change armed away (as it does this literally every 4 or so minutes) and then it shows Blue-Iris setting profile to 2. No idea why it set the profile to 2, it doesn't show any events running to trigger that, any suggestions?


    Aug-07 3:05:20 PM EnvisaLink DEBUG CommandAcknowledge 000
    Aug-07 3:05:20 PM EnvisaLink DEBUG Request: Poll
    Aug-07 3:05:15 PM Blue-Iris Refreshing data from Blue Iris server
    Aug-07 3:05:00 PM weatherXML Check timer items
    Aug-07 3:04:21 PM Blue-Iris Setting profile to 2
    Aug-07 3:04:19 PM Blue-Iris Setting profile to 2
    Aug-07 3:04:19 PM Blue-Iris Successfully logged in to BlueIris server: Beach House (ver 4.4.1.0) as admin.
    Aug-07 3:04:00 PM weatherXML Check timer items
    Aug-07 3:03:52 PM EnvisaLink INFO DSC Alarm status change: Armed Away
    Aug-07 3:03:52 PM EnvisaLink DEBUG PartitionArmed 10
    Aug-07 3:03:52 PM EnvisaLink DEBUG KeypadLedStatePartition1Only 92
    Aug-07 3:03:52 PM EnvisaLink DEBUG KeypadLedflashStatePartition1Only 00
    Aug-07 3:03:52 PM EnvisaLink DEBUG KeypadLedStatePartition1Only 80
    Aug-07 3:03:51 PM EnvisaLink DEBUG VerboseTroubleStatus 40
    Aug-07 3:03:51 PM EnvisaLink DEBUG KeypadLedflashStatePartition1Only 10
    Aug-07 3:03:20 PM EnvisaLink DEBUG CommandAcknowledge 000
    Aug-07 3:03:20 PM EnvisaLink DEBUG Request: Poll
    Aug-07 3:03:00 PM weatherXML Check timer items
    Aug-07 3:02:01 PM weatherXML Check timer items
    Aug-07 3:01:20 PM EnvisaLink DEBUG CommandAcknowledge 000
    Aug-07 3:01:20 PM EnvisaLink DEBUG Request: Poll
    Aug-07 3:01:03 PM Blue-Iris Setting profile to 2
    Aug-07 3:01:00 PM weatherXML Triggers to check: 0
    Aug-07 3:01:00 PM weatherXML Check for last ran triggers
    Aug-07 3:01:00 PM weatherXML Check timer items
    Aug-07 3:00:41 PM Blue-Iris Setting profile to 1
    Aug-07 3:00:41 PM EnvisaLink INFO DSC Alarm status change: Armed Away
    Aug-07 3:00:41 PM Event Event Trigger "Security Cameras Set Blue Iris to Away Schedule when Away"
    Aug-07 3:00:41 PM EnvisaLink DEBUG PartitionArmed 10
    Aug-07 3:00:41 PM EnvisaLink DEBUG SpecialClosing 1
    Aug-07 3:00:41 PM EnvisaLink DEBUG KeypadLedStatePartition1Only 92
    Aug-07 3:00:15 PM Blue-Iris Refreshing data from Blue Iris server
    Aug-07 3:00:15 PM Blue-Iris Successfully logged in to BlueIris server: Beach House (ver 4.4.1.0) as admin.
    Aug-07 3:00:09 PM EnvisaLink DEBUG KeypadLedStatePartition1Only 93
    Aug-07 3:00:09 PM EnvisaLink INFO Kitchen Door status change: Closed
    Aug-07 3:00:09 PM EnvisaLink DEBUG ZoneRestored 002
    Aug-07 3:00:04 PM EnvisaLink DEBUG KeypadLedStatePartition1Only 92
    Aug-07 3:00:04 PM EnvisaLink INFO Kitchen Door status change: Opened
    Aug-07 3:00:04 PM EnvisaLink DEBUG ZoneOpen 002

  • #2
    when it shows Blue-Iris setting profile to 2, there is no EnvisaLink or Event trigger log lines, so I don't think this is a problem with the EnvisaLink plugin something else must caused the change to 2.

    Comment


    • #3
      I only have one event wihch is the one that sets Blue Iris with the EnvisaLink as the trigger as a test. Either way I think it's something with a battery as mentioned as I do get the yellow caution sign on the alarm. Just not sure what device is dead as the 2 wireless sensors say 3-5 year battery and they are 14 months old same with the main backup battery on the alarm which also says a few years for battery life. It says press < > on the keypad to view the zone with trouble but none of them show anything they all just say Ready and look normal. Haven't been home for a few days thoug hso will test after when I get back.

      What's interesting though is I made a virtual device called "House Status" with Home or Away. I then set a program same as above so that if the alarm says Ready, it changes it to Home, and if it's Away it changes that device to Away. This triggers only once and never again, so I have Blue Iris set to trigger based on the virtual device changing and it works perfectly. If I trigger it off the alarm directly it repeats it over and over.

      Comment

      Working...
      X