Announcement

Collapse
No announcement yet.

myQ Plugin Not Working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • myQ Plugin Not Working

    Hi, I installed the myQ plugin and completed the authentication details in the configuration link and nothing. I don't see myQ in my Devices List and there is no other indication that the plugin is working.

    What I've tried:
    • cycling the garage door with the myQ app on my phone several times (open/close);
    • cycling the garage door manually several times (open/close);
    • Uninstalled and re-installed the myQ plugin; and
    • restarted the HTZ.


    I'm new to z-Wave and the HTZ so have no idea what else to try.

    Any help or suggestions appreciated. Thanks, in advance!

    Current Date/Time: 1/22/2017 7:18:18 PM
    HomeSeer Version: HS3 ZEE S2 Edition 3.0.0.297
    Linux version: Linux HomeTrollerZeeS2 3.18.11-v7+ #781 SMP PREEMPT Tue Apr 21 18:07:59 BST 2015 armv7l GNU/Linux System Uptime: 0 Days 0 Hours 10 Minutes 38 Seconds
    IP Address: 192.168.1.239
    Number of Devices: 33
    Number of Events: 28
    Available Threads: 399

    Enabled Plug-Ins
    3.0.0.68: HSTouch Server
    1.0.16320.356: MyQ
    3.0.6167.15622: UltraWeatherWU3
    3.0.1.87: Z-Wave

  • #2
    Since my original post in trying to troubleshoot what is wrong I discovered the plug in had a update available so I installed that and tried cycling the door again. In the Manage Plugins it indicates the status is "OK" - still no luck.


    Current Date/Time: 1/23/2017 4:30:35 AM
    HomeSeer Version: HS3 ZEE S2 Edition 3.0.0.297
    Linux version: Linux HomeTrollerZeeS2 3.18.11-v7+ #781 SMP PREEMPT Tue Apr 21 18:07:59 BST 2015 armv7l GNU/Linux System Uptime: 0 Days 0 Hours 7 Minutes 55 Seconds
    IP Address: 192.168.1.239
    Number of Devices: 33
    Number of Events: 28
    Available Threads: 399

    Enabled Plug-Ins
    3.0.0.68: HSTouch Server
    1.0.16323.357: MyQ
    3.0.6167.15622: UltraWeatherWU3
    3.0.1.87: Z-Wave

    Comment


    • #3
      Sorry to hear you're having issues. Can you go into the plugin configuration page for the MyQ plugin and click the submit debug data button. Then come back here and private message me to let me know you have done it, and in the private message include the email address that your myq account is tied to. This is how I link the debug report specifically to you. Then I can review the debug information and see what is happening or not happening.

      Comment


      • #4
        Thank you. Debug data submitted, along with a portion of the log via PM with email address.

        Comment


        • #5
          The debug data indicates that your username/password are incorrect. However, I suspect that not to be the case. There is a known issue with the way the plugin logs into to the web service that certain characters in the password field simply won't work.

          I'm willing to bet your password has a % sign in it, that is the one character I've not been able to get working in a password yet. I'm still working to try and get this bug squashed, but in the meantime, you could just change your password to not include a % sign.

          Comment


          • #6
            Thank you - you are correct I have a % in the password. I will change the password and see if that solves the issue. I'll let you if I have success.

            Comment


            • #7
              Thank you! Your suggestion worked the plugin is fully operational now - very grateful for your assistance. Maybe a sticky telling newbies like me not to use % in their passwords would help others.

              Thanks again!

              Comment


              • #8
                Why would you even have and obscure character like '%' in your password for a garage door gateway. You do realize that one of two things can happen with MyQ: 1) MyQ inadvertently sends an "open all MyQ garage doors in the world" command and then you're screwed regardless of your password's obscurity; or 2) someone hacks into MyQ, finds out your password, logs into MyQ and opens up your garage door, assuming that you told Chamberlain your authentic home address (which I hope you had the common sense not to do), and sits in front of your house waiting to enter it (the easier method would be to just break the window when you're not at home.
                Last edited by sickpuppy; January 25th, 2017, 03:29 PM.

                Comment


                • #9
                  Thanks. One of the great things about these forums is you can learn all kinds of stuff and consider other's opinions.

                  Comment


                  • #10
                    I also had this issue and in my case it was corrected when I removed the @ symbol from my password. I guess we have all been trained well to use "strong" passwords

                    Comment


                    • #11
                      Originally posted by SJ Miller View Post
                      Thanks. One of the great things about these forums is you can learn all kinds of stuff and consider other's opinions.
                      I had the same problem, and ditto your response to sickpuppy.

                      Comment


                      • #12
                        Ok,

                        Same problem here, I updated my password to remove the special caracter and still not working. I have issues accessing the configuration page for the myq plugin since the upgrade to 1.2. After a complete restart of Homeseer I'm able a access the manage plugins and do everything I want but as soon as I try to access myq configuration all the plugin page stops being accessible.

                        I want to post my debug information but I'm not able to access the plugin configuration!

                        What should I do?

                        Thanks,

                        Comment


                        • #13
                          Originally posted by jpsavaria View Post
                          Ok,

                          Same problem here, I updated my password to remove the special caracter and still not working. I have issues accessing the configuration page for the myq plugin since the upgrade to 1.2. After a complete restart of Homeseer I'm able a access the manage plugins and do everything I want but as soon as I try to access myq configuration all the plugin page stops being accessible.

                          I want to post my debug information but I'm not able to access the plugin configuration!

                          What should I do?

                          Thanks,
                          Try deleting all the plugin settings for the plugin. You can do this by going to the config directory in the homeseer folder In there is a file called MYQ ini. Delete that file_ restarting the plugin.

                          Comment

                          Working...
                          X