Announcement

Collapse
No announcement yet.

Failed getting InterfaceStatus from MyQ

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • kingfetty
    replied
    Glad you're back up and running again.

    Leave a comment:


  • ult4dr
    replied
    Excellent. Thank you very much. Upgraded and all is well again!

    Thanks for the great and fast support.

    Leave a comment:


  • kingfetty
    replied
    Was able to recreate the issue and find it. New version posted. Turned out to be a dll dependency issue on the linux systems.

    Leave a comment:


  • ult4dr
    replied
    Just incase I am running

    Welcome to Ubuntu 16.04.3 LTS (GNU/Linux 4.4.0-101-generic x86_64)

    Thank you for your support.

    Leave a comment:


  • kingfetty
    replied
    Originally posted by ult4dr View Post
    Ok I have upgrade to the new version. 1.1.17325.305

    I have also upgrade Mono to the lastest.

    chris@ult4dr-Unix:~$ sudo mono -V
    [sudo] password for chris:
    Mono JIT compiler version 5.4.1.6 (tarball Wed Nov 8 20:37:08 UTC 2017)
    Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
    TLS: __thread
    SIGSEGV: altstack
    Notifications: epoll
    Architecture: amd64
    Disabled: none
    Misc: softdebug
    LLVM: supported, not enabled.
    GC: sgen (concurrent by default)

    Still getting the same error.

    Nov-21 11:55:22 AM Plug-In Finished initializing plug-in MyQ

    Nov-21 11:55:19 AM Info Plugin MyQ with instance: has disconnected

    Nov-21 11:55:19 AM MyQ Warn Connection to HomeSeer lost, shutting down plugin...

    Nov-21 11:55:19 AM MyQ HomeSeer shutting down MyQ plugin

    Nov-21 11:55:19 AM Error Initializing plug-in(1): MyQ Instance::Error on InitIO: Failure has occurred while loading a type.

    Nov-21 11:55:18 AM MyQ Initializing version 1.1.17325.305

    Nov-21 11:55:18 AM Info Plugin MyQ has connected. IP:127.0.0.1:52218
    Ok, let me throw this on my linux box and see if I can recreate the error. Unfortunately I can't pull any logs from the server because it's dying while trying to setup the logs.

    Leave a comment:


  • ult4dr
    replied
    Ok I have upgrade to the new version. 1.1.17325.305

    I have also upgrade Mono to the lastest.

    chris@ult4dr-Unix:~$ sudo mono -V
    [sudo] password for chris:
    Mono JIT compiler version 5.4.1.6 (tarball Wed Nov 8 20:37:08 UTC 2017)
    Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
    TLS: __thread
    SIGSEGV: altstack
    Notifications: epoll
    Architecture: amd64
    Disabled: none
    Misc: softdebug
    LLVM: supported, not enabled.
    GC: sgen (concurrent by default)

    Still getting the same error.

    Nov-21 11:55:22 AM Plug-In Finished initializing plug-in MyQ

    Nov-21 11:55:19 AM Info Plugin MyQ with instance: has disconnected

    Nov-21 11:55:19 AM MyQ Warn Connection to HomeSeer lost, shutting down plugin...

    Nov-21 11:55:19 AM MyQ HomeSeer shutting down MyQ plugin

    Nov-21 11:55:19 AM Error Initializing plug-in(1): MyQ Instance::Error on InitIO: Failure has occurred while loading a type.

    Nov-21 11:55:18 AM MyQ Initializing version 1.1.17325.305

    Nov-21 11:55:18 AM Info Plugin MyQ has connected. IP:127.0.0.1:52218

    Leave a comment:


  • kingfetty
    replied
    Originally posted by ult4dr View Post
    Hi There,

    Ever since upgrading to version 1.1.17325.299. I have been getting the following error. I have tried removing plugin and reinstalling. No go.

    WARNING: Failed getting InterfaceStatus from MyQ - the interface was not found in the list of active interfaces, the list may need to be refreshed.

    Snipit from the log file.

    Nov-21 8:44:19 AM Plug-In Finished initializing plug-in MyQ Nov-21 8:44:16 AM Info Plugin MyQ with instance: has disconnected Nov-21 8:44:16 AM MyQ Warn Connection to HomeSeer lost, shutting down plugin... Nov-21 8:44:16 AM MyQ HomeSeer shutting down MyQ plugin Nov-21 8:44:16 AM Error Initializing plug-in(1): MyQ Instance::Error on InitIO: Failure has occurred while loading a type. Nov-21 8:44:15 AM MyQ Initializing version 1.1.17325.298 Nov-21 8:44:14 AM Info Plugin MyQ has connected. IP:127.0.0.1:39642

    System:

    Current Date/Time: 2017-11-21 8:47:24 AM EST HomeSeer Version: HS3 Pro Edition 3.0.0.368 (Linux) Modules/Threads: 59 Modules, 56 Threads Available Threads: 2400 HomeSeer Memory Used: 129 Mbytes
    New version posted, see if that helps. If not let me know. It appears that it isn't getting past the new logging code initialization.

    What .net framework version is installed? 4.6 is needed if running windows. If on linux just the latest version of mono framework will do.

    Leave a comment:


  • ult4dr
    started a topic Failed getting InterfaceStatus from MyQ

    Failed getting InterfaceStatus from MyQ

    Hi There,

    Ever since upgrading to version 1.1.17325.299. I have been getting the following error. I have tried removing plugin and reinstalling. No go.

    WARNING: Failed getting InterfaceStatus from MyQ - the interface was not found in the list of active interfaces, the list may need to be refreshed.

    Snipit from the log file.

    Nov-21 8:44:19 AM Plug-In Finished initializing plug-in MyQ Nov-21 8:44:16 AM Info Plugin MyQ with instance: has disconnected Nov-21 8:44:16 AM MyQ Warn Connection to HomeSeer lost, shutting down plugin... Nov-21 8:44:16 AM MyQ HomeSeer shutting down MyQ plugin Nov-21 8:44:16 AM Error Initializing plug-in(1): MyQ Instance::Error on InitIO: Failure has occurred while loading a type. Nov-21 8:44:15 AM MyQ Initializing version 1.1.17325.298 Nov-21 8:44:14 AM Info Plugin MyQ has connected. IP:127.0.0.1:39642

    System:

    Current Date/Time: 2017-11-21 8:47:24 AM EST HomeSeer Version: HS3 Pro Edition 3.0.0.368 (Linux) Modules/Threads: 59 Modules, 56 Threads Available Threads: 2400 HomeSeer Memory Used: 129 Mbytes
Working...
X