Announcement

Collapse
No announcement yet.

Updated now not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ult4dr
    replied
    All good. It works again.

    Thank you!

    Leave a comment:


  • ult4dr
    replied
    Wonderful I will try that. Thank you for your support.

    I will let you know.

    Leave a comment:


  • kingfetty
    replied
    Try build .312 of the plugin (just uploaded) and see if that helps any.

    Leave a comment:


  • kingfetty
    replied
    For additional information, I am currently testing some builds that show promise.

    Leave a comment:


  • kingfetty
    replied
    Originally posted by ult4dr View Post
    Mono JIT compiler version 5.10.1.47 (tarball Tue Apr 17 15:12:35 UTC 2018)
    Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
    TLS: __thread
    SIGSEGV: altstack
    Notifications: epoll
    Architecture: amd64
    Disabled: none
    Misc: softdebug
    Interpreter: yes
    LLVM: supported, not enabled.
    GC: sgen (concurrent by default)
    Yeah, it's confirmed that 5.10.X breaks the NLog DLL that I use for logging. I've been looking for a fix and workaround for this. I may end up stripping out the logging feature. If you want you can either roll the Mono back to a previous release or just await a fix from me.

    Leave a comment:


  • ult4dr
    replied
    Mono JIT compiler version 5.10.1.47 (tarball Tue Apr 17 15:12:35 UTC 2018)
    Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
    TLS: __thread
    SIGSEGV: altstack
    Notifications: epoll
    Architecture: amd64
    Disabled: none
    Misc: softdebug
    Interpreter: yes
    LLVM: supported, not enabled.
    GC: sgen (concurrent by default)

    Leave a comment:


  • kingfetty
    replied
    Originally posted by ult4dr View Post
    Hello,

    I just updated the myq plugin the other day and now I getting an error when turning on the plugin,

    WARNING: Failed getting InterfaceStatus from MyQ - the interface was not found in the list of active interfaces, the list may need to be refreshed.

    Also seeing this in syslog:

    System.TypeInitializationException: The type initializer for 'HSPI_MyQ.Program' threw an exception. ---> NLog.NLogConfigurationException: Error when setting property 'Format' on Layout Renderer: ${date} ---> System.ArgumentException: Object of type 'System.ReadOnlySpan`1[System.Char]' cannot be converted to type 'System.String'.
    Apr 18 21:33:31 ult4dr-Unix mono[14496]: at System.RuntimeType.CheckValue (System.Object value, System.Reflection.Binder binder, System.Globalization.CultureInfo culture, System.Reflection.BindingFlags invokeAttr) [0x00071] in <9bbab8f8a2a246e98480e70b0839fd67>:0

    Thanks
    Based on this dump it's linux OS?
    What was the old version you were running?

    There is a known issue with the latest version of MONO and the NLog 3rd party DLL I use. What version of MONO are you running?

    Leave a comment:


  • ult4dr
    started a topic Updated now not working

    Updated now not working

    Hello,

    I just updated the myq plugin the other day and now I getting an error when turning on the plugin,

    WARNING: Failed getting InterfaceStatus from MyQ - the interface was not found in the list of active interfaces, the list may need to be refreshed.

    Also seeing this in syslog:

    System.TypeInitializationException: The type initializer for 'HSPI_MyQ.Program' threw an exception. ---> NLog.NLogConfigurationException: Error when setting property 'Format' on Layout Renderer: ${date} ---> System.ArgumentException: Object of type 'System.ReadOnlySpan`1[System.Char]' cannot be converted to type 'System.String'.
    Apr 18 21:33:31 ult4dr-Unix mono[14496]: at System.RuntimeType.CheckValue (System.Object value, System.Reflection.Binder binder, System.Globalization.CultureInfo culture, System.Reflection.BindingFlags invokeAttr) [0x00071] in <9bbab8f8a2a246e98480e70b0839fd67>:0

    Thanks

Working...
X