Announcement

Collapse
No announcement yet.

MyQ been broken since mid-november, spins on "Still Initializing"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MyQ been broken since mid-november, spins on "Still Initializing"

    I loved this plugin and willingly paid for it a while ago, and it's been zero maintenance for a while. But the multiple updates since mid-November have broken it, and it hasn't worked since. I've removed it, re-logged in, and tried everything I can think of, but it's been broken. I checked for a new MyQ device entry (it did that once on an update to the plug-in), but nothing new was created.

    The only obvious symptom is the spinning "Still Initializing" on the debug screen. I clicked the "Submit Debug Report" a couple of times, but not sure it did anything (there's no visual indication it did anything at all).

    FWIW, my iOS MyQ app works fine, and HomeKit integration works fine, and hasn't had (and still doesn't have) any issues.

    Running version 1.2020.103.1460 as of today, but it's been broken for a few months now, and there have been 3 or 4 updates in that time.

    Any thoughts? It looks like others are having similar problems.

    Thanks,
    Mark

  • #2
    Thanks for re-posting this. Ok, so the plugin is stuck in still initializing, which tells me it's crashing before it even starts, probably due to a missing DLL or conflicted DLL. We just need to find out which...


    Windows or Linux Homeseer?

    If running windows:

    On the plugin managment page there is a checkbox for developer mode. Disable the plugin, then enable the checkbox then re-enable the plugin. On the windows desktop of the homeseer box, you will see a console window appear called HSPI_MyQ.exe this is the plugin running, just not hidden. This will display detailed information about any crashing that is happening.

    If running linux:

    Stop the plugin.
    SSH into the Homeseer box
    CD to the Homeseer folder installation location
    launch the plugin:
    mono HSPI_MyQ.exe


    In both cases make note of any errors logged, or shown on screen. If you don't have luck with this, let me know and we'll come at it a different direction.

    Comment


    • #3
      Just did this, and here's the output:

      Code:
       sudo mono HSPI_MyQ.exe
      
      2020-01-10 15:04:23 |   INFO | Plugin: MyQ Instance:  starting...
      2020-01-10 15:04:23 |   INFO | Connecting to server at 127.0.0.1...
      2020-01-10 15:04:23 |   INFO | Host API Version: 3
      2020-01-10 15:04:23 |   INFO | Connected, initializing plugin...
      2020-01-10 15:04:24 |   INFO | Initializing version 1.2020.103.1460
      2020-01-10 15:04:38 |  ERROR | Method 'System.Net.Logging.get_On' not found.
      2020-01-10 15:04:43 |  ERROR | Method 'System.Net.Logging.get_On' not found.
      2020-01-10 15:04:47 |  ERROR | Method 'System.Net.Logging.get_On' not found.
      Code:
      mono --version
      Mono JIT compiler version 5.4.1.6 (2017-06/1f4613aa1ac Wed Oct 18 09:31:57 EDT 2017)
      Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
          TLS:           normal
          SIGSEGV:       altstack
          Notification:  kqueue
          Architecture:  amd64
          Disabled:      none
          Misc:          softdebug
          LLVM:          yes(3.6.0svn-mono-master/8b1520c8aae)
          GC:            sgen (concurrent by default)
      It just repeats that forever it seems.

      Thanks,
      Mark

      Comment


      • #4
        Ok, looks like there's a bug in that version of mono that prevents the correct DLL from being loaded from the referenced directory.

        Try deleting the System.Net.Http file from the homeseer/bin/myq folder and relaunch. The other option would be to update to the latest version of mono where the bug is fixed.

        Comment


        • #5
          Removing the DLL Net.Http.dll results in MyQ saying initialization exception.

          I’ll try to update mono tomorrow.

          Comment

          Working...
          X