Announcement

Collapse
No announcement yet.

Can't Connect t

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't Connect t

    Hi,
    I have the software installed correctly. I removed the incorrect exe that I had added. Now I can't connect. The picture below shows me connected to MyLiftMaster.com, and this is from the Raspberry Pi that I am running HomeSeer on. The other picture is trying to connect to the URL in one of the previous posts.
    Below are the messages from the error log.
    Date/Time Pri Type/Error Message/Source
    Mar-21 1:58:45 PM MyQ Warn Login attempts have repeatedly failed. Check Username/Password or select a different API type.
    Mar-21 1:58:41 PM MyQ Error Unable to reach internet, please check your network connectivity.
    Mar-21 1:58:37 PM MyQ Error Unable to reach internet, please check your network connectivity.
    Mar-21 1:58:33 PM MyQ Error Unable to reach internet, please check your network connectivity.
    Mar-21 1:58:29 PM MyQ Error Unable to reach internet, please check your network connectivity.
    Mar-21 1:58:25 PM MyQ Error Unable to reach internet, please check your network connectivity.
    Mar-21 1:58:19 PM Web Server Web Server authorized local login successful from: 10.0.0.35 User: richm@rlmtech.com
    Mar-21 1:58:15 PM Startup Start up complete.
    Mar-21 1:58:15 PM Info Latest BETA update available is:
    Mar-21 1:58:15 PM Info Latest update available is: 3.0.0.548
    Mar-21 1:58:14 PM Info System connected to MyHS Service successfully with license ID 99065.
    Mar-21 1:58:14 PM Info System connected to MyHS Service, waiting for acknowledge...
    Mar-21 1:58:14 PM Info Checking for updates...
    Mar-21 1:58:14 PM Startup Starting the HS3 Sentry EXE
    Mar-21 1:58:14 PM TTS Speak ():Welcome to Home-Seer
    Mar-21 1:58:14 PM Startup Scripting is OK and is now running Startup.vb
    Mar-21 1:58:14 PM Startup Starting HSSentry watchdog.
    Mar-21 1:58:14 PM Startup Starting Event Scheduler...
    Mar-21 1:58:10 PM Insteon External Device Registration complete.
    Mar-21 1:58:10 PM Startup Running the startup script Startup.vb
    Mar-21 1:58:10 PM Startup Starting Find service...
    Mar-21 1:58:10 PM Startup Updater services starting...
    Mar-21 1:58:10 PM Speech Listening for remote speaker connections on port 10401
    Mar-21 1:58:10 PM Startup Initializing Speaker Client Interface
    Mar-21 1:58:10 PM Startup Start automation engine...
    Mar-21 1:58:10 PM Startup HStouch server started, waiting for clients to connect.
    Mar-21 1:58:10 PM HSTouch Server Server started on port 10200
    Mar-21 1:58:10 PM Plug-In Finished initializing plug-in MyQ
    Mar-21 1:58:10 PM Starting Plug-In MyQ loaded in 2002 milliseconds
    Mar-21 1:58:10 PM Starting Plug-In Plugin MyQ started successfully in 220 milliseconds
    Mar-21 1:58:09 PM MyQ Initializing version 1.2020.226.875
    Mar-21 1:58:09 PM Starting Plug-In Initializing plugin MyQ ...
    Mar-21 1:58:09 PM Info Plugin MyQ has connected. IP:127.0.0.1:44652
    Attached Files

  • #2
    Which "Garage Door Type" Setting did you select? Can you submit a debug report.

    Comment


    • #3
      Liftmaster / Chamberlain is selected. And the debug was submitted.

      Comment


      • #4
        Not getting the debug from the plugin either, which also indicates the plugin is unable to reach the internet. The plugin simply emails me a zip file, but that's not making it out either.

        Comment


        • #5
          Hi,
          How can it not be connected to the internet? I downloaded the plugin, so I was able to get to the internet. The first picture on the original post above, shows me connect to the MyQ Dashboard. The second picture shows the response from the API that you had suggested in one of the other posts about connection issues. All of which indicates that I am connected to the internet from the raspberry pi. I was just playing Pandora on the Raspberry Pi that is running HomeSeer and your plugin. I went ahead and reinstalled the plugin but I still can't connect.
          From the log I see the following error from the plugin:
          Mar-21 7:23:07 PM Starting Plug-In Initializing plugin MyQ ...
          Mar-21 7:23:06 PM Starting Plug-In MyQ loaded in 15028 milliseconds
          Mar-21 7:22:53 PM Info Plugin MyQ has connected. IP:127.0.0.1:36474
          Mar-21 7:22:51 PM Warning I/O interface MyQ is down, executable is not running, restarting ...
          Mar-21 7:22:51 PM Error Posting back to plugin web page MyQ: Object reference not set to an instance of an object-> at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr) at (wrapper remoting-invoke) HomeSeerAPI.IPlugInAPI:PostBackProc (string,string,string,int) at Scheduler.proxyPage.postBackProc (Scheduler.StateObject& state, System.String Data) [0x00036] in <5edae07d49c94185903d1f484027d9ec>:0
          Mar-21 7:22:51 PM Info Plugin MyQ with instance: has disconnected
          Mar-21 7:22:51 PM MyQ Warn HTTP Connection Issue: Return Code 0
          Mar-21 7:22:51 PM MyQ Debug [{"Authentication":"password=5+orVQZ9b6WY30PhKSvK3/JPsz9nv0eX0z3Zb0vfPwA===+\u0000safeCode=True\u0000email=rich m@XXXXX.XXX\u0000API=LiftMaster","Logging":"LogLevel=Debug\u 0000File=True\u0000ForumName=RichM","Options":"PollInterval= 10000"}]
          Mar-21 7:22:50 PM MyQ Debug Gathered MyQ.ini configuration dump
          Mar-21 7:22:50 PM MyQ Debug Gathered HomeSeer device database dump
          Mar-21 7:22:47 PM MyQ Debug Updated ForumName (RichM)
          Mar-21 7:22:27 PM MyQ Warn Login attempts have repeatedly failed. Check Username/Password or select a different API type.

          Comment


          • #6
            I also tried disabling my other two plugins (Insteon and mcsMQTT) which didn't change anything. And if it helps the debug page shows:
            Click image for larger version  Name:	Capture.PNG Views:	0 Size:	38.5 KB ID:	1371759
            Attached Files

            Comment


            • #7
              try stopping the plugin and running it from the RPi command line.
              • Open a terminal window
              • change to the directory of the homeseer installation
              • run the plugin with mono.
              Code:
              cd /somedir/HomeSeer
              mono HSPI_MyQ.exe
              Once you do that, any errors it's encountering will echo to the command prompt. I'm thinking it's hitting an error that we're not seeing.

              Comment


              • #8
                Same errors that I have posted in the log! The only exception is when I clicked on the "Submit Debug Report" on the support page, it threw an exception. I did try to change the "Garage Door Type" a couple of times as well (you can see the changes in the log) to see if anything would change or error out.

                Comment


                • #9
                  File attached...
                  Attached Files

                  Comment


                  • #10
                    According to this, it's see a 0 response code which is what happens when the request times out trying to reach the internet. For some odd reason it's not able to reach out of the RPi to the internet. No API / Door Type will work until it can reach the internet. The same thing is also happening when you try to submit the debug report.

                    Comment


                    • #11
                      Oh well, if I can access HomeSeer from my phone(wifi turned off), as well as download new plugins I would think HomeSeer has Internet access. I can play Pandora on the Pi that HomeSeer is running on as well as access my LiftMaster.com Dashboard. And get a response from "https://api.myqdevice.com/api/v5/Login". I will look for another solution. Thanx for all your help.

                      Comment


                      • #12
                        I am having the same issue with Unable to reach internet, please check your network connectivity. in the log files on my . Request from Chrome to https://api.myqdevice.com/api/v5/Login gives Request Failed from another machine behind the same router/firewall (NAT). Should have tried before buying. Any help would be appreciated.

                        Click image for larger version

Name:	HS2log.JPG
Views:	78
Size:	107.1 KB
ID:	1372455

                        Comment


                        • #13
                          Changing the polling from 10000 to 300000 does not stick. Read elsewhere that MyQ can blocklist IPs due to too frequency API calls.

                          Comment


                          • #14
                            Ok, thanks for the bug report, I'll fix the polling interval not sticking in the next update.

                            As for the blacklisting, that has nothing to do with the polling rate. The polling rate is how often it should check for updates to the status of the doors. The blacklisting is if more than 6 API calls are made within the same second. In newer versions of the plugin, the client has an internal policer that will not allow it to exceed the 6 API calls per second interval. Feel free to set the polling rate to anything you feel is sufficient. I've found the 10 second default to be fine.

                            Comment


                            • #15
                              Thanks for the info about the how blocklist.
                              However, I am still unable to use the MyQ plugin because of the following error:
                              Unable to reach internet, please check your network connectivity
                              Which was the same as the report that started this thread.

                              What URL is attempting to be called? HTTP or HTTPS?
                              This would be useful in trying to troubleshoot.

                              Comment

                              Working...
                              X