Announcement

Collapse
No announcement yet.

Can't Connect - Blacklisted?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't Connect - Blacklisted?

    MYQ plugin - still initializing with rotating status indicator on the plugin debug screen.

    Homeseer S6 with Windows 7 embedded.

    Installed plugin, added Chamberlain login information and verified that it is correct. Re-started plugin and got the following error. The debug Logging Level log file shows follows:
    Mar-29 18:07:16 Starting Plug-In Plugin MyQ started successfully in 75 milliseconds
    Mar-29 18:07:16 Starting Plug-In MyQ loaded in 1005 milliseconds
    Mar-29 18:07:16 Plug-In Finished initializing plug-in MyQ
    Mar-29 18:07:20 MyQ Debug Initializing MyQ Controller
    Mar-29 18:07:20 MyQ Debug Initialize MyQ Controller. API: LiftMaster, User:XXX@gmail.com, Pass:XXX, Interval:10000
    Mar-29 18:07:20 MyQ Debug PolicedHttpClient finished initialization.
    Mar-29 18:07:20 MyQ Debug Created HTTP client. AppID:JVM/G9Nwih5BwKgNCjLxiFUQxQijAebyyg8QUHr7JOrP+tuPb8iHfRHKwTmDzHOu
    Mar-29 18:07:20 MyQ Debug Started PollTimer
    Mar-29 18:07:20 MyQ Debug Registered for device change events
    Mar-29 18:07:30 MyQ Debug Pausing PollTimer while updating device status
    Mar-29 18:07:30 MyQ Debug Poller interval normalized to 10000
    Mar-29 18:07:30 MyQ Debug AccountURL is null, have not authenticated yet
    Mar-29 18:07:30 MyQ Debug Session invalid, calling authentication attempt
    Mar-29 18:07:30 MyQ Debug LiftMaster: Login Attempt
    Mar-29 18:07:30 MyQ Debug Created credentials JSON data
    Mar-29 18:07:31 MyQ Debug Sent authentication post to MyQ server
    Mar-29 18:07:31 MyQ Debug Response Code: OK
    Mar-29 18:07:31 MyQ Debug Response Type: text/html; charset=utf-8
    Mar-29 18:07:31 MyQ Debug Unexpected return type, aborting login attempt
    Mar-29 18:07:31 MyQ Debug Unexpected Return DataType
    Mar-29 18:07:31 MyQ Error The MyQ API server has rejected our request to sign in. You may be black listed by the MyQ service.
    I tried manually using Chrome on the S6 to reach: https://api.myqdevice.com/api/v5/Login and received the following error:

    The requested URL was rejected. Please consult with your administrator.

    Your support ID is: 18134916635502493966

    //

    Thanks for any assistance you will offer.

  • #2
    I installed Mono on the HS6, restarted the S6 and disabled the plugin from the plug-ins / manage page. I then ran mono HSPI_MyQ.exe from a command line and the debug log indicated that after it "Created credentials JON data", mono crashed. I ran it again with the same result.

    Comment


    • #3
      Can you give me the error that was shown when it crashed?

      Comment


      • #4
        Thanks for the quick response. I appreciate it.

        After "Created credentials JSON data" Mono crashed with the message "mono.exe has stopped working". The problem detail information is:
        Problem signature:
        Problem Event Name: BEX
        Application Name: mono.exe
        Application Version: 0.0.0.0
        Application Timestamp: 5e399e8b
        Fault Module Name: StackHash_0a9e
        Fault Module Version: 0.0.0.0
        Fault Module Timestamp: 00000000
        Exception Offset: 000000bb
        Exception Code: c0000005
        Exception Data: 00000008
        OS Version: 6.1.7601.2.1.0.320.65
        Locale ID: 1033
        Additional Information 1: 0a9e
        Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
        Additional Information 3: 0a9e
        Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

        Read our privacy statement online:
        http://go.microsoft.com/fwlink/?link...8&clcid=0x0409

        If the online privacy statement is not available, please read our privacy statement offline:
        C:\Windows\system32\en-US\erofflps.txt

        Comment


        • #5
          Don't think you need mono on Windows ... ?

          Comment


          • #6
            Originally posted by zwolfpack View Post
            Don't think you need mono on Windows ... ?
            Correct, if windows, just run the HSPI_MyQ.exe

            Comment


            • #7
              Ok, so I went ahead and made myself feel stupid to save everyone else the trouble.

              I got the bright idea to try mono from trolling the forum and looking at other issues and then trying to fix / debug myself.

              I ran HSPI_MyQ.exe (in the c:\Program Files\HomeSeer HS3 directory) natively from a command prompt and it:
              ...
              Created credentials JSON data
              Sent authentication post to MyQ server
              Response Code: Unauthorized
              Login attempts have repeatedly failed . Check Username/Password or select a different API type.

              I had to ^C to end as it appeared to hang

              This response is different from the log file response posted above.

              I verified that I can login with the username / password I provided (which is shown in the debug mode.

              Thoughts?

              Comment


              • #8
                Make sure you're selected the correct "Garage Door Type" dropdown setting.

                Comment


                • #9
                  I changed each Garage Door Type and stopped / started the plugin.

                  API LiftMaster: Login attempts have repeatedly failed....
                  API Craftsman: ... Error (Displaying remotely connected interfaces: Object reference not set to an instance of an object) ... The MyQ API Server rejected our request to sign in.
                  API LegacyLiftMaster: Error (Displaying remotely connected interfaces...) ... Login attempts have repeatedly failed....
                  API Merlin: Login attempts have repeatedly failed....
                  API LegacyChamberlain: MyQ API server has rejected our request to sign in.

                  No joy.

                  Comment


                  • #10
                    My default assumption is that it is a Liftmaster / Chamberlain as it is a three year old opener. Polling interval is 10000 and I have also tried 30000.

                    Thanks.

                    Comment


                    • #11
                      In looking at the debug dump you submitted, it's definitely failing because the username/password is incorrect. Make sure you check the correct username/password, try re-entering them. If you're unsure if your password is being saved correctly, change the logging to debug, you should see the username/password it's using to login in the debug logs.

                      Code:
                      {
                          "code": "401.203",
                          "message": "Unauthorized",
                          "description": "The username or password you entered is incorrect. Try again."
                      }

                      Comment


                      • #12
                        I did a copy / paste of my username and password into www.chamberlain.com\login and was able to log in that way, so I am confident that the username / password being passed the the API is correct. That is unless the API portal and the web login portal are different.

                        Comment


                        • #13
                          I copied the username / password from the HomeSeer log file

                          Comment


                          • #14
                            Does the same username/password work on the MyQ app on your phone?

                            Comment


                            • #15
                              Eric,

                              No. You were absolutely right. Username / password. The phone MyQ app account was different.

                              First, thank you for your patience and assistance. It is sincerely appreciated.

                              Second, I purchased the app.

                              Thank you for the first rate support.

                              Regards,

                              Don

                              Comment

                              Working...
                              X