No announcement yet.

Napco Gemini Plugin USB-Serial on HT-SEL

  • Filter
  • Time
  • Show
Clear All
new posts

  • nfrobertson
    That's great news. Thanks for the reply back confirming this as I'm sure it will help others too.


    Leave a comment:

  • carp3d

    Thank you for your reply

    I was successfully able to populate the field with /dev/ttyUSB1 and get the panel connected.

    I thought i had tried that exact value the other day. This time it worked.

    Thanks again!

    Leave a comment:

  • nfrobertson
    On the Napco Gemini config page is a text box for setting the COM Port. That is used literally in code to open the System.IO.Ports.SerialPort class as below:
    myPort = New SerialPort(myConfig.COMPort, 9600, Parity.Even, 8, StopBits.One)
    In the Linux support sticky thread I mentioned I'm using an Oracle VM Virtualbox that maps a PC USB serial port to /dev/ttyUSB0 I also took a quick look over at Mark Sander's Insteon support forum as I know he works directly with Linux serial ports for that interface. Here is an example post where he also mentions /dev/ttyUSB0 or /dev/ttyUSB1 I would expect the value you put in the config page for the Napco Plugin here to be similar. Unfortunately I don't have a Hometroller-SEL so I don't have experience with how it might map the USB serial port to a device but per your example, it seems /dev/ttyUSB0 works with the ZWave plugin? I would then expect that to work with the Napco Gemini plugin assuming you have disabled the ZWave plugin as they both can't open the device at the same time.


    Leave a comment:

  • carp3d
    started a topic Napco Gemini Plugin USB-Serial on HT-SEL

    Napco Gemini Plugin USB-Serial on HT-SEL

    Having a problem getting the Napco Panel to connect.
    Currently using the USB-Serial to successfully connect a Z-Troller. In that interface setup there is a drop down with choices

    However in the NAPCO GEMINI plugin setup there's only a BLANK field.

    I have tried
    • /dev/ttyUSB1
    • ttyUSB1
    • COM1
    • 1

    No joy so far....

    Can anyone help with the connection here? How do i connect a Napco panel to the HomeTroller-SEL?

    Thanks in advance!


    Current Date/Time: 10/9/2017 11:01:26 AM
    HomeSeer Version: HS3 Standard Edition
    Linux version: Linux hometrollerSEL 3.16.0-031600-generic #201408031935 SMP Sun Aug 3 23:56:17 UTC 2014 i686 i686 i686 GNU/Linux System Uptime: 0 Days 17 Hours 59 Minutes 27 Seconds
    IP Address:
    Number of Devices: 27
    Number of Events: 0
    Available Threads: 199
    License: Registered
    License: 98051
    User Name and Access Level: (Admin)
    WAN IP Address:
    Web Server Port:
    Location: (Latitude) 42.22 (Longitude) 71.03

    Enabled Plug-Ins HSTouch Server Napco Gemini Z-Wave