Announcement

Collapse
No announcement yet.

NAPCO Plugin for HS3 does not work

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • NAPCO Plugin for HS3 does not work

    I want to upgrade from HS2 with Napco plugin to HS3 with Napco plugin, however the plugin is very unstable and crashes all the time. I can get Quick Loader for windows to work perfectly so I know I can communicate with my panel. Also, I can connect to my panel using HS2 with the original Napco plug in. My question is this, has anyone actually gotten this to work????

    Thanks!
    Jeff

  • #2
    Jeff,

    Thanks for your interest. I use this plugin for my home HS3 system so I do rely on it. There have been some minor tweaks since initial release but I do not experience crashes.

    What is your setup: panel model, GEM-AUTOMATION firmware level, PCI-MINI or GEM-RS232? What do you use to run HS3? Do you use a USB to serial adapter or a traditional serial port on the HS3 machine?

    Do you have debug turned on and assuming so can you post your debug log? This is usually found in C:\Program Files (x86)\HomeSeer HS3\Logs\NapcoDebug.log or from a copy/paste from the running HS3 log

    Nathan
    HS 3.0.0.435 (PRO)
    Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
    Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
    Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
    http://www.kazteel.com/

    Comment


    • #3
      Jeff,

      I just posted v3.0.0.4 of this plugin. This version includes retry logic around the "full status update" that is requested from the panel during startup. I don't know if this will help you or not. This was an enhancement I had included last week but hadn't published pending outcome of testing with another user.

      Nathan
      HS 3.0.0.435 (PRO)
      Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
      Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
      Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
      http://www.kazteel.com/

      Comment


      • #4
        I added additional protections around the serial port handling functions where I think an issue could occur. I've posted v3.0.0.5. If this still doesn't work for you then please post additional information about your setup along with debug logs. Thanks.
        HS 3.0.0.435 (PRO)
        Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
        Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
        Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
        http://www.kazteel.com/

        Comment

        Working...
        X