Announcement

Collapse
No announcement yet.

V2.6 "Ramping" ON Improperly?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • V2.6 "Ramping" ON Improperly?

    Since the update, my UPB switches from OmniPro2 and HS3/OmniPlugin have acquired a new behavior. They now "ramp up" instead of "instant". In some cases, this interferes and fails to turn a device on (fans, etc). I have confirmed the correct behavior exists when controlling devices from PCAccess. All I can assume/debug to is new behavior came with the 2.6 update. Is there a new behavior or switch setting that I'm unaware of? I think you already have my last log from the missing EE zones issue but will send anew if needed. Please let me know.

    Thanks, Jeff.

  • #2
    Originally posted by jchotz View Post
    Since the update, my UPB switches from OmniPro2 and HS3/OmniPlugin have acquired a new behavior. They now "ramp up" instead of "instant". In some cases, this interferes and fails to turn a device on (fans, etc). I have confirmed the correct behavior exists when controlling devices from PCAccess. All I can assume/debug to is new behavior came with the 2.6 update. Is there a new behavior or switch setting that I'm unaware of? I think you already have my last log from the missing EE zones issue but will send anew if needed. Please let me know.

    Thanks, Jeff.
    I noticed it also. But I really prefer it other than the optic shock I used to get when a light snapped on.
    <style></style>
    Last edited by avpman; April 1st, 2018, 09:34 AM.

    Comment


    • #3
      Thx for confirming. At least I'm not going out of my mind. I'm not opposed but some of my devices can't take it - fans, flour lites, etc. And, but why?

      Comment


      • #4
        Originally posted by jchotz View Post
        Thx for confirming. At least I'm not going out of my mind. I'm not opposed but some of my devices can't take it - fans, flour lites, etc. And, but why?
        IMHO there should be an option to ramp or not, by device, to handle devices that can't take it.
        <style></style>

        Comment


        • #5
          Here do not see ramping on with the V.26 of the Omni Plugin with one testing UPB switch. Works as instant on or off.

          The switch is manually configured via Upstart for a single tap ramp on and a double tap instant on and multiple scene links.

          When testing on and off via UPB the switch ramps on and there is an instant off.

          [ATTACH]67845[/ATTACH]

          Options in live PCA status are as before: (on is instant and off is instant)

          [ATTACH]67844[/ATTACH]

          Initially when I upgraded to V.26, disabled Omni Plugin and deleted all OMNI variables and any associated events.

          [ATTACH]67843[/ATTACH]

          This works as before - on turns lamp on instantly and off turns it off instantly.

          Logs shows following when turning lamp on

          4/3/2018 9:16:24 AM [2] [--> Unit 51 changed status. Updating Homeseer...]
          4/3/2018 9:16:24 AM [2] [here...]
          4/3/2018 9:16:24 AM [2] [-->Unsolicited: Unit=[51] status=[1]/[ON] type=[4]]
          4/3/2018 9:16:24 AM [2] [-->UNIT: desc=[] number=[51] name=[Hallway Back]]
          4/3/2018 9:16:24 AM [2] [---->Unit]
          4/3/2018 9:16:24 AM [2] [UNSOLICITED: ExtendedStatus]
          4/3/2018 9:16:24 AM [2] [Unit_On: unitId=51 ]
          4/3/2018 9:16:23 AM [2] [SetIOMulti: CC.Ref=[1745] CC.ControlValue=[255]]

          Log shows following when turning lamp off

          4/3/2018 9:17:33 AM [2] [--> Unit 51 changed status. Updating Homeseer...]
          4/3/2018 9:17:33 AM [2] [here...]
          4/3/2018 9:17:33 AM [2] [-->Unsolicited: Unit=[51] status=[0]/[OFF] type=[4]]
          4/3/2018 9:17:33 AM [2] [-->UNIT: desc=[] number=[51] name=[Hallway Back]]
          4/3/2018 9:17:33 AM [2] [---->Unit]
          4/3/2018 9:17:33 AM [2] [UNSOLICITED: ExtendedStatus]
          4/3/2018 9:17:32 AM [2] [Unit_Off: unitId=51 ]
          4/3/2018 9:17:32 AM [2] [SetIOMulti: CC.Ref=[1745] CC.ControlValue=[0]]
          Last edited by Pete; April 3rd, 2018, 09:35 AM.
          - Pete

          Auto mator
          Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
          Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
          HS4 Pro - V4.0.9.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
          HS4 Lite -

          X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

          Comment


          • #6
            In 2.6, I changed the command that sends a dim from Dim to Level. It's possible that the Level command is doing the ramping.

            The suggestion for adding this type of control at the device level is a good idea. I might be able to add that so you can toggle between Dim/Level.
            HS3Pro Running on a Raspberry Pi3
            68 Z-Wave Nodes, 174 Events, 326 Devices
            UPB modules via OMNI plugin/panel
            Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
            HSTouch Clients: 3 Android, 1 Joggler

            Comment


            • #7
              Originally posted by rmasonjr View Post
              In 2.6, I changed the command that sends a dim from Dim to Level. It's possible that the Level command is doing the ramping.

              The suggestion for adding this type of control at the device level is a good idea. I might be able to add that so you can toggle between Dim/Level.
              I like this idea also - might help fix my X10 dimming issues as they only respond to On,Off,Dim,Brighten, not Level. What about making the existing "dimmable" setting user-selectable, for devices that won't/can't dim at all?

              John

              Comment


              • #8
                Rob, how can I change that ramping behavior back to what it was previously?

                It's broken a number of my devices as they cannot accept a ramp on command - like fans, flour lites.

                See log below for device on & off.

                4/4/2018 4:59:58 PM [2] [here...]
                4/4/2018 4:59:58 PM [2] [--> Unit 14 changed status. Updating Homeseer...]
                4/4/2018 5:00:43 PM [2] [SetIOMulti: CC.Ref=[71] CC.ControlValue=[100]]
                4/4/2018 5:00:43 PM [2] [Unit_Dim: unitId=14 dimVal=100]
                4/4/2018 5:00:43 PM [2] [UNSOLICITED: ExtendedStatus]
                4/4/2018 5:00:43 PM [2] [---->Unit]
                4/4/2018 5:00:43 PM [2] [-->UNIT: desc=[] number=[14] name=[LR Fan Lite]]
                4/4/2018 5:00:43 PM [2] [-->Unsolicited: Unit=[14] status=[200]/[LEVEL 100%] type=[4]]
                4/4/2018 5:00:43 PM [2] [here...]
                4/4/2018 5:00:43 PM [2] [--> Unit 14 changed status. Updating Homeseer...]
                4/4/2018 5:00:48 PM [2] [SetIOMulti: CC.Ref=[71] CC.ControlValue=[0]]
                4/4/2018 5:00:48 PM [2] [Unit_Off: unitId=14 ]
                4/4/2018 5:00:48 PM [2] [UNSOLICITED: ExtendedStatus]
                4/4/2018 5:00:48 PM [2] [---->Unit]
                4/4/2018 5:00:48 PM [2] [-->UNIT: desc=[] number=[14] name=[LR Fan Lite]]
                4/4/2018 5:00:48 PM [2] [-->Unsolicited: Unit=[14] status=[0]/[OFF] type=[4]]
                4/4/2018 5:00:48 PM [2] [here...]
                4/4/2018 5:00:48 PM [2] [--> Unit 14 changed status. Updating Homeseer...]

                Comment


                • #9
                  Originally posted by jchotz View Post
                  Rob, how can I change that ramping behavior back to what it was previously?

                  It's broken a number of my devices as they cannot accept a ramp on command - like fans, flour lites.

                  See log below for device on & off.

                  4/4/2018 4:59:58 PM [2] [here...]
                  4/4/2018 4:59:58 PM [2] [--> Unit 14 changed status. Updating Homeseer...]
                  4/4/2018 5:00:43 PM [2] [SetIOMulti: CC.Ref=[71] CC.ControlValue=[100]]
                  4/4/2018 5:00:43 PM [2] [Unit_Dim: unitId=14 dimVal=100]
                  4/4/2018 5:00:43 PM [2] [UNSOLICITED: ExtendedStatus]
                  4/4/2018 5:00:43 PM [2] [---->Unit]
                  4/4/2018 5:00:43 PM [2] [-->UNIT: desc=[] number=[14] name=[LR Fan Lite]]
                  4/4/2018 5:00:43 PM [2] [-->Unsolicited: Unit=[14] status=[200]/[LEVEL 100%] type=[4]]
                  4/4/2018 5:00:43 PM [2] [here...]
                  4/4/2018 5:00:43 PM [2] [--> Unit 14 changed status. Updating Homeseer...]
                  4/4/2018 5:00:48 PM [2] [SetIOMulti: CC.Ref=[71] CC.ControlValue=[0]]
                  4/4/2018 5:00:48 PM [2] [Unit_Off: unitId=14 ]
                  4/4/2018 5:00:48 PM [2] [UNSOLICITED: ExtendedStatus]
                  4/4/2018 5:00:48 PM [2] [---->Unit]
                  4/4/2018 5:00:48 PM [2] [-->UNIT: desc=[] number=[14] name=[LR Fan Lite]]
                  4/4/2018 5:00:48 PM [2] [-->Unsolicited: Unit=[14] status=[0]/[OFF] type=[4]]
                  4/4/2018 5:00:48 PM [2] [here...]
                  4/4/2018 5:00:48 PM [2] [--> Unit 14 changed status. Updating Homeseer...]
                  Rob,
                  Can we have an option to select the ramping by device? I haven't used it on my fans yet because of this but I would really like for it to remain for the lights
                  <style></style>

                  Comment


                  • #10
                    Yes - the easiest way is just to roll back to the previous version. I'm still trying to see if there is a way in the API to handle this, but if not, there will be a selection on each device for Dim/Brighten/Level.
                    HS3Pro Running on a Raspberry Pi3
                    68 Z-Wave Nodes, 174 Events, 326 Devices
                    UPB modules via OMNI plugin/panel
                    Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
                    HSTouch Clients: 3 Android, 1 Joggler

                    Comment


                    • #11
                      I like that approach. Can we please have the "old" behavior as the default?

                      Comment

                      Working...
                      X