Announcement

Collapse
No announcement yet.

Event triggers multiple times

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by dlschwerin View Post
    What is your "Omni Omni Area Modes Area 1 (01)" ???? Trying to find something that has the arm night / day / vacation with disarm and cannot seem to find that device in my collection that I can set as arm / disarm / etc.

    Looked through all of the homeseer and OP2 areas for consoles to see if one of them had the omni arm / disarm feature
    Mine is the Area Mode for the alarm. Use your Area Mode device and you'll see all the arm and disarm modes.
    HS3Pro Running on a Raspberry Pi3
    68 Z-Wave Nodes, 174 Events, 326 Devices
    UPB modules via OMNI plugin/panel
    Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
    HSTouch Clients: 3 Android, 1 Joggler

    Comment


    • #17
      Originally posted by dlschwerin View Post
      What is the script code for the email body to pull data in to the email as to who armed / disarmed the system. is looks like you guys have by "$$DSR:824: $time $date or by $$DSR:1504: $time $date" in the email body
      Those are HS device replacement variables. Replace just the numbers with your device reference number for the 'codes' as this contained the last code that armed/disarmed the system.
      HS3Pro Running on a Raspberry Pi3
      68 Z-Wave Nodes, 174 Events, 326 Devices
      UPB modules via OMNI plugin/panel
      Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
      HSTouch Clients: 3 Android, 1 Joggler

      Comment


      • #18
        thank you ... I found in HS3 that the areas button was no clicked to the on position. Once I clicked it on it gave me my Omni Omni Area Modes Area 1 (01) with the ability to choose b/w arm / disarm / etc.

        for the device reference number piece ... going to plead ignorant on this because I cannot find that?

        thanks

        Comment


        • #19
          Originally posted by dlschwerin View Post
          thank you ... I found in HS3 that the areas button was no clicked to the on position. Once I clicked it on it gave me my Omni Omni Area Modes Area 1 (01) with the ability to choose b/w arm / disarm / etc.

          for the device reference number piece ... going to plead ignorant on this because I cannot find that?

          thanks
          Click on the device and the advanced tab.
          Or, I think you can hover over the link and the url might have it listed.
          HS3Pro Running on a Raspberry Pi3
          68 Z-Wave Nodes, 174 Events, 326 Devices
          UPB modules via OMNI plugin/panel
          Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
          HSTouch Clients: 3 Android, 1 Joggler

          Comment


          • #20
            Originally posted by dlschwerin View Post
            What is the script code for the email body to pull data in to the email as to who armed / disarmed the system. is looks like you guys have by "$$DSR:824: $time $date or by $$DSR:1504: $time $date" in the email body
            Take a look at this. It gives the replacement variables you can use.



            Comment


            • #21
              Originally posted by rmasonjr View Post

              Those are HS device replacement variables. Replace just the numbers with your device reference number for the 'codes' as this contained the last code that armed/disarmed the system.
              Following this thread, I decided to report via email the person who changes an area mode. I am unable to make it work.

              My problem is that the "codes" device in the OMNI device group is never updated. I can change an area mode to anything I want at the OP2 panel, and the device list updates the area mode properly. But the OMNI PI "codes" device value never changes.

              I am using OMNI PI v. 3.0.2.20.

              Click image for larger version

Name:	2019-12-26_20-20-39.jpg
Views:	27
Size:	9.7 KB
ID:	1349851

              I added the HS device selection for the users of interest, and I disabled, then re-enabled the OMNI PI:

              Click image for larger version

Name:	2019-12-26_20-19-06.jpg
Views:	31
Size:	61.9 KB
ID:	1349849

              I think the PI added the last two entries to the following status graphics when I selected them (above), but I could be wrong.

              Click image for larger version

Name:	2019-12-26_20-22-25.jpg
Views:	31
Size:	74.2 KB
ID:	1349848

              I manually set device "codes" to Lorie on the HS3 Device List Page (cf. first screen shot above), and the value of "codes" was set appropriately. "Status = Unknown" I don't understand.

              Click image for larger version

Name:	2019-12-26_20-25-37.jpg
Views:	31
Size:	214.8 KB
ID:	1349850

              Summary: I can set area modes at the OP2 control panel, and HS3 knows about it. But "codes" never changes, so I can't reference in an event the user who changed an area mode.

              Thanks in advance for any assistance.
              Attached Files

              Comment


              • #22
                Originally posted by ericg View Post

                Following this thread, I decided to report via email the person who changes an area mode. I am unable to make it work.


                Thanks in advance for any assistance.
                Enable logging in the OMNI config, then do an ARM, wait a few mins, then a DISARM.
                Capture those logs from the OMNI Logs page and send them to me.
                HS3Pro Running on a Raspberry Pi3
                68 Z-Wave Nodes, 174 Events, 326 Devices
                UPB modules via OMNI plugin/panel
                Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
                HSTouch Clients: 3 Android, 1 Joggler

                Comment


                • #23
                  Originally posted by rmasonjr View Post

                  Enable logging in the OMNI config, then do an ARM, wait a few mins, then a DISARM.
                  Capture those logs from the OMNI Logs page and send them to me.
                  I have no experience doing this. I'm using a HomeTroller, don't know much about WinSCP, either.

                  I think I got the log file. Tried forum "Upload Attachments", got:

                  Click image for larger version

Name:	2019-12-27_8-54-22.jpg
Views:	27
Size:	32.9 KB
ID:	1349935
                  So I renamed the log file, and tried again:

                  [ATTACH]n1349936[/ATTACH]

                  If this doesn't work for you, please send detailed transmittal instructions, and I'll try again.

                  Thanks.

                  Comment


                  • #24
                    Originally posted by ericg View Post

                    I have no experience doing this. I'm using a HomeTroller, don't know much about WinSCP, either.

                    I think I got the log file. Tried forum "Upload Attachments", got:

                    Click image for larger version

Name:	2019-12-27_8-54-22.jpg
Views:	27
Size:	32.9 KB
ID:	1349935
                    So I renamed the log file, and tried again:

                    [ATTACH]n1349936[/ATTACH]

                    If this doesn't work for you, please send detailed transmittal instructions, and I'll try again.

                    Thanks.
                    Thanks I got it...

                    To confirm - your current 'codes' devices does not contain Eric from 8:35a this morning?
                    HS3Pro Running on a Raspberry Pi3
                    68 Z-Wave Nodes, 174 Events, 326 Devices
                    UPB modules via OMNI plugin/panel
                    Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
                    HSTouch Clients: 3 Android, 1 Joggler

                    Comment


                    • #25
                      ok - ericg I see what it is...

                      User codes that are 'Master' are not allowed to be updated. I'm reviewing my comments in the code and I see that I added a note that the master code 'name' and a regular user 'name' could be the same and I wouldnt know which one to update.

                      I think what I'll do i make this INI-file driven for the next update so you can use it this way, or allow master codes to update the 'codes' device.

                      For a workaround, deactivate the device for Eric with the Master authority.
                      Add a User code to your OMNI, start/restart the plugin and activate the Eric device with User authority.
                      HS3Pro Running on a Raspberry Pi3
                      68 Z-Wave Nodes, 174 Events, 326 Devices
                      UPB modules via OMNI plugin/panel
                      Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
                      HSTouch Clients: 3 Android, 1 Joggler

                      Comment


                      • #26
                        Originally posted by rmasonjr View Post

                        Thanks I got it...

                        To confirm - your current 'codes' devices does not contain Eric from 8:35a this morning?
                        That's correct. There is only one 'codes' device that I can find. It still looks like this:

                        Click image for larger version

Name:	2019-12-27_9-37-18.jpg
Views:	26
Size:	10.2 KB
ID:	1349947

                        Comment


                        • #27
                          Originally posted by rmasonjr View Post
                          ok - ericg I see what it is...

                          For a workaround, deactivate the device for Eric with the Master authority.
                          Add a User code to your OMNI, start/restart the plugin and activate the Eric device with User authority.
                          I tried your workaround:
                          1. Deactivated the device for Eric with the Master authority.
                          2. Used PCA to add a new user "Ericg" with User authority.
                          3. Wrote the modified OMNI Setup to OP2.
                          4. Read Setup from OP2 and verified that new user "Ericg" has been added.
                          5. Disabled, then restarted the OMNI PI.
                          6. The OMNI PI doesn't see user "Ericg" that I added.
                          Click image for larger version

Name:	2019-12-27_10-17-35.jpg
Views:	29
Size:	60.5 KB
ID:	1349962

                          Did I miss a step?

                          Comment


                          • #28
                            Originally posted by ericg View Post

                            I tried your workaround:
                            1. Deactivated the device for Eric with the Master authority.
                            2. Used PCA to add a new user "Ericg" with User authority.
                            3. Wrote the modified OMNI Setup to OP2.
                            4. Read Setup from OP2 and verified that new user "Ericg" has been added.
                            5. Disabled, then restarted the OMNI PI.
                            6. The OMNI PI doesn't see user "Ericg" that I added.
                            Click image for larger version

Name:	2019-12-27_10-17-35.jpg
Views:	29
Size:	60.5 KB
ID:	1349962

                            Did I miss a step?
                            Yeah, that should have picked up the new code.
                            Inside the device status for the codes, is the old Eric still in there? If so, remove it.
                            HS3Pro Running on a Raspberry Pi3
                            68 Z-Wave Nodes, 174 Events, 326 Devices
                            UPB modules via OMNI plugin/panel
                            Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
                            HSTouch Clients: 3 Android, 1 Joggler

                            Comment

                            Working...
                            X