Announcement

Collapse
No announcement yet.

Beginner - Connecting Homeseer SW to Omnipro II Panel

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Beginner - Connecting Homeseer SW to Omnipro II Panel

    I just downloaded the trial version of the HS Pro SW and the OMNI plugin.
    When I entered the Config info (which I am certain is correct), the web interface tells me I need to "restart" the plugin.
    I could not find an explicit "restart," so I disabled/enabled the plugin (also tried quitting/restarting the HW Pro SW.
    I assume one or both of these actions caused a "restart" of the plugin.

    I then could not find any explicit way to download the OmniPro info (buttons, zones, outputs, etc).
    Is this supposed to happen automatically when the Omni plugin first loads?

    In any event, I dont think it did anything because I dont see any status items under buttons, zones, outputs, etc.
    Under Homeseer Devices (screenshot attached), it shows ERRORS (DCM and PANEL OFFLINE) - so I assume it didnt connect to the panel.

    In the Log (also attached), it references the OMNI plugin at 127.0.0.1: 54298, which makes me wonder whether the plugin is somehow on the wrong subnet.
    My PC and OmniPro II panel are all on my local subnet (192.168.1.x).

    Any idea how I can troubleshoot this and get the OMNI plugin to connect to my OmniPro II panel?
    Attached Files

    #2
    Hi, Dan,
    I may not be much help -- I'm pretty much a newbie, too -- but I do have an Omnipro II panel that works really great with HS3 via the OMNI plugin. I believe that, once you get things working, you will love it.
    You don't say whether you have the HAI/Leviton program "Dealer PC Access" available. If you do, that's where I'd start. If PC Access can't work with your OP II panel, then your problems have nothing to do with either HS3 or the OMNI plug-in. If you don't have PC Access, I suggest that you look into possible acquisition of this (Windows) program. I find it extremely useful.
    My DCM device entry looks like yours, so that is probably not your problem. However, my "connection" OMNI device shows a status of "PANEL CONNECTED," unlike yours. I think you need to fix that.
    Several people have noted that the OP II Ethernet connection technology is relatively old, and some folks have had trouble getting reliable communication with certain Ethernet switches. If you have (or can borrow) a different switch for the panel connection, the swap is an easy thing to try.
    Finally, if you aren't certain that the panel is actually there for communication, you can try an IP scanner to make sure the panel is active and Ethernet responsive. I use the (free) Windows program "Advanced IP Scanner" for this purpose. Make sure the IP address detected by the scanner matches the IP address you used in your OMNI plug-in's IP Configuration tab.
    I hope I haven't given you any bad information. If I have, some helpful expert will soon set you straight. Good luck!

    Comment


      #3
      DanielSiegel
      It looks like you are pretty close to getting it running. Hover over the Plugins menu, then OMNI, click on OMNI Logs. That will give you more detailed information about the plugin's startup.

      Once we get you connected and running, you go into the OMNI Config section and select the Units, Flags, Buttons, etc. that you want to bring into HS.
      Note that Zones must be "Named" in the panel. You can do this with PC Access (like eric mentioned) or you can name them via a controller. Only named devices will be picked up.

      post back and let us know...
      HS4Pro Running on a Raspberry Pi4
      68 Z-Wave Nodes, 175 Events, 359 Devices
      UPB modules via OMNI plugin/panel
      Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
      HSTouch Clients: 3 Android, 1 Joggler

      Comment


        #4
        Thanks. I am running PC Access on my internal network (192.168.1.x), and Trial HS Pro SW and my OmniPro II panel are also on that subnet.
        All of my Zones, Buttons, Units, etc are named.
        It's helpful to know that the OMNI device should show PANEL CONNECTED (not PANEL OFFLINE) once I get it working, and that the DCM device (not sure what that is) will still show as an error.

        Attached is my OMNI Log, which shows that it is not connecting. But I'm not sure why.
        The IP address is clearly reachable by ping, PC Access, etc.
        I am also attaching my Config info to see if I'm missing something.

        Would the Log show the same message regardless of the reason for failure (IP Address, Port, Encryption Key, etc)?
        Is the reference to the plugin at 127.0.0.1:54298 (in my HS Log above) an indication of any problem? Not sure how this is determined.
        Is there anything I need to do to get my panel to accept connections (eg, it is connected to PC Access and my iOS App - I tried quitting those in case there was an issue of multiple simultaneous connections)?

        Appreciate any troubleshooting steps. I'm at a loss. Thx
        Attached Files
        Last edited by DanielSiegel; October 12, 2018, 12:59 PM.

        Comment


          #5
          I'm an idiot!!! I was using the wrong IP address. Corrected it, restarted the HS SW and everything worked like a charm.
          Thanks so much for your help. Cant believe I did that (not the first time). Thx again.

          Comment


            #6
            Originally posted by DanielSiegel View Post
            I'm an idiot!!! I was using the wrong IP address. Corrected it, restarted the HS SW and everything worked like a charm.
            Thanks so much for your help. Cant believe I did that (not the first time). Thx again.
            Glad I'm not the only one to do stuff like this! ;-)

            Comment


              #7
              Did it. Thanks very much for that.

              Comment


                #8
                Not a problem Daniel.

                Good news getting the Omni Plugin running. Works great!!!
                - Pete

                Auto mator
                Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X
                Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
                HS4 Pro - V4.1.7.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
                HS4 Lite -

                X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                Comment

                Working...
                X