Announcement

Collapse
No announcement yet.

HS Database Unit Disassociation with Plugin DB

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    rmasonjr Very odd... I looked at devices that had 1 named entry and now they are showing 2 named entries!

    I did manage to find one that still showed 1 named entry. I removed it via the Plugin which also removed the HS device.

    1- device removed
    2- Event and script, done
    3- device recreated via plugin
    Device as created:
    Extra Data Store 2 Named entries, 0 UnNamed entries.

    Let's see...

    Comment


    • #17
      Just tried to set a light with HSTouch and nothing.

      Checked the plugin units page and the "enable" switch has turned red, it has disassociated. This is not the device I previously reported and created. The log entries only show:
      Jan-04 7:00:00 PM Event Running script statement immediately: &hs.SaveEventsDevices()
      No other related entries that I can see related.

      This device routinely disconnects:
      Reference ID 205
      Technology Address OMNI-Q56
      Status 0 = OFF
      Value 0 = "OFF"
      String
      Supports Status True
      Dimmable True
      Interface OMNI
      Extra Data Store 1 Named entries, 0 UnNamed entries.
      Device Type Internal Plug-In API, Type: Plug-In Type 4, SubType: DiningRmLite
      Device Type (String)
      Misc Settings Do Not Log, Show Values, Generate Voice Command, SET_DOES_NOT_CHANGE_LAST_CHANGE
      Device Image File images/HAI/hai.jpg
      Thumbnail Image File images/HAI/hai.jpg
      Relationship Status Child
      Associated Devices .Hidden OMNI Root Device
      Additional Display Data OMNI
      3.0.2.18
      A couple of days ago it showed 2 Named Entries. Odd.

      Otherwise, the system is ticking along fine.

      Comment


      • #18
        The script event has been running since 2-January. Nothing remarkable in the log file.
        Jan-09 3:00:00 PM Event Running script statement immediately: &hs.SaveEventsDevices()
        Jan-09 2:00:00 PM Event Running script statement immediately: &hs.SaveEventsDevices()
        Entries just like these every hour since 2-JAN.

        This device did become orphaned since setting everything back. I have not deleted it and reenabled it. Just letting it sit.
        Reference ID 205
        Technology Address OMNI-Q56
        Status 0 = OFF
        Value 0 = "OFF"
        String
        Supports Status True
        Dimmable True
        Interface OMNI
        Extra Data Store 1 Named entries, 0 UnNamed entries.
        Device Type Internal Plug-In API, Type: Plug-In Type 4, SubType: DiningRmLite
        Device Type (String)
        Misc Settings Do Not Log, Show Values, Generate Voice Command, SET_DOES_NOT_CHANGE_LAST_CHANGE
        Device Image File images/HAI/hai.jpg
        Thumbnail Image File images/HAI/hai.jpg
        Relationship Status Child
        Associated Devices .Hidden OMNI Root Device
        Additional Display Data OMNI
        3.0.2.18
        I checked 60 other units and they all have 2 Named entries and working fine. It's almost always this, DiningRmLite, device that dissociates but I have had others go away too and it will include this one.

        Comment


        • #19
          raprap
          v3.0.2.20 was released to the updater today. Give it a try when you see it...
          HS3Pro Running on a Raspberry Pi3
          64 Z-Wave Nodes, 168 Events, 280 Devices
          UPB modules via OMNI plugin/panel
          Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
          HSTouch Clients: 3 Android, 1 Joggler

          Comment


          • #20
            rmasonjr Thanks, much. I will look out for it.

            Does this update also address the dimming (or lack of) with ON/OFF or 0%/100% commands?

            i.e. Use slider or voice to set 50% (or any number other than 0% or 100%), UPB lights use the default rate but, if you turn the light ON or OFF or "dim/set" to 0% or 100% the light slams ON/OFF and disregards the default rate. Seems to be no difference with the Ramp? checkbox checked/unchecked.

            Comment


            • #21
              Originally posted by raprap View Post
              rmasonjr Thanks, much. I will look out for it.

              Does this update also address the dimming (or lack of) with ON/OFF or 0%/100% commands?

              i.e. Use slider or voice to set 50% (or any number other than 0% or 100%), UPB lights use the default rate but, if you turn the light ON or OFF or "dim/set" to 0% or 100% the light slams ON/OFF and disregards the default rate. Seems to be no difference with the Ramp? checkbox checked/unchecked.
              No dimming changes were made in this version.
              HS3Pro Running on a Raspberry Pi3
              64 Z-Wave Nodes, 168 Events, 280 Devices
              UPB modules via OMNI plugin/panel
              Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
              HSTouch Clients: 3 Android, 1 Joggler

              Comment

              Working...
              X