Announcement

Collapse
No announcement yet.

OMNI HS3 plug in fails to download and install

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • OMNI HS3 plug in fails to download and install

    I have windows 10, tried removing the legacy homeseer version of the plugin after purchasing this new version...have HS3 Pro

    I update the plugin page under mange plugins, check the omni plugin box then click on download/install and it tries but ends in a failure...

  • #2
    Try shutting down Homeseer and using file manager delete any reference to the legacy plugin - IE all DLL, INI files and subdirectories created by the legacy plugin.

    Start up Homeseer and install the Omni Plugin.
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
    HS4 Pro - V4.0.5.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
    HS4 Lite -

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

    Comment


    • #3
      just happened to look at the logs and it says that the hs3pro is old. have 3.0.0.96 need 3.0.0,297...not obvious how to do an upgrade without going the trial route and reload completely

      Comment


      • #4
        Not sure if there are plugin dependencies on the version of HS3. I am on V.534 Windows HS3 Pro (test) and Linux HS3 Pro (Production).

        That said shut down HS3, back up the HS3 directory first.

        1 - update HS3
        2 - install the new plugin

        If that doesn't work then post here your results.

        Not sure if you configured anything with legacy plugin (variables - scripts).
        - Pete

        Auto mator
        Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
        Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
        HS4 Pro - V4.0.5.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
        HS4 Lite -

        X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

        Comment


        • #5
          Jul-15 9:56:21 AM Updater Install/Update of package OMNI failed.
          Jul-15 9:56:21 AM Updater Error Installation of package OMNI failed. Try disabling the plugin first, then re-try the update.
          Jul-15 9:56:21 AM Updater Error This package requires version 3.0.0.297 of HomeSeer, and you have version 3.0.0.96 so the installation will not continue.
          Jul-15 9:56:21 AM Updater Installing package OMNI
          Jul-15 9:56:21 AM Updater Update hspi_omni.exe downloaded successfully
          Jul-15 9:56:20 AM Updater Downloading update: OMNI
          Jul-15 9:56:20 AM Updater Starting download of updates
          Jul-15 9:56:05 AM Info System registered with MyHomeSeer service successfully.

          Comment


          • #6
            Omni was disabled fyi

            Comment


            • #7
              i think the homeseer log is an hsd file? if so is there an offline reader?

              Comment


              • #8
                all good. upgraded to HS3 Pro Edition 3.0.0.534 (Windows), which allowed the OMNI plug in to load..fixed the config and now see the buttons and outputs I was looking for.

                Minor issues-

                1. CheckDevicesForUpgrade (Thermostat): Object reference not set to an instance of an object.]

                what does this mean--wrong version thermostat for the plugin? thermostat does not register

                2. I don't get an names_codes...panel codes for statusing

                Comment


                • #9
                  what does this mean--wrong version thermostat for the plugin?

                  No. If you see your thermostat with PCA then your should see it in the Omni Plugin. Try disabling plugin, reboot, enabling plugin.

                  I don't get an names_codes...panel codes for statusing

                  I am guessing that you have enabled the devices under the Omni configuration.
                  - Pete

                  Auto mator
                  Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                  Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                  HS4 Pro - V4.0.5.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
                  HS4 Lite -

                  X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                  Comment


                  • #10
                    I see the TSTAT with PCA albiet I don't have the first slot filled (removed the first for other reasons) only TSTAT2 is filled with a valid device.

                    disabling, reboot (assuming reboot of HS3) and enabling had no joy.

                    With respect to the panel codes, enabling the device under the omni config drop down in HS3 is correct and what I did for temperature sensors, humidity, buttons etc but nothing comes up for codes and TSTAT's to enable..is there another way via a config file?

                    Comment


                    • #11
                      I see the TSTAT with PCA albiet I don't have the first slot filled (removed the first for other reasons) only TSTAT2 is filled with a valid device.

                      You enter the thermostat ID in PCA. PCA does not automagically see the thermostat unless you have entered the thermostat ID first.

                      Thinking you need the installer version of PCA to do this.

                      See attached picture.

                      Click image for larger version  Name:	thermostat.jpg Views:	0 Size:	58.7 KB ID:	1315970
                      - Pete

                      Auto mator
                      Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                      Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                      HS4 Pro - V4.0.5.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
                      HS4 Lite -

                      X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                      Comment


                      • #12
                        Make sure all your thermostats, units, etc are all 'named' in PC Access. In your thermostat list above, thermostat 1 is named, but thermostat 2 is not.
                        Once named, they will show up in the plugin list.
                        HS3Pro Running on a Raspberry Pi3
                        64 Z-Wave Nodes, 168 Events, 280 Devices
                        UPB modules via OMNI plugin/panel
                        Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
                        HSTouch Clients: 3 Android, 1 Joggler

                        Comment


                        • #13
                          just named the first and second tstat rows (again ID 1 is unused). disabled and reenabled the plugin no joy...also no codes

                          Comment


                          • #14
                            Click image for larger version

Name:	Capture.PNG
Views:	62
Size:	65.0 KB
ID:	1316022
                            changed to this restarted an still no thermostat...fyi this is the installers ver of pca

                            Comment


                            • #15
                              Did you 'Write to Controller' after naming?
                              HS3Pro Running on a Raspberry Pi3
                              64 Z-Wave Nodes, 168 Events, 280 Devices
                              UPB modules via OMNI plugin/panel
                              Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
                              HSTouch Clients: 3 Android, 1 Joggler

                              Comment

                              Working...
                              X