Announcement

Collapse
No announcement yet.

Replaced HAI plugin with Omni and now Alexa doesn't recognize my devices

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Replaced HAI plugin with Omni and now Alexa doesn't recognize my devices

    I recently replaced my HAI plugin with Omni for my Omni Controller to work with Alexa / Echo. I did so because it seemed to stop working and normally I'm able to fix it by disabling and enabling the HAI plug in. That didn't work so I decided to delete the HAI plugin and when I went to re-install, realized that it was replaced by Omni. So I installed it and reconnected and enabled both the 'HomeSeer Home Automation Skill' and the 'HomeSeer SmartHome'. But now it seems that the 'HomeSeer SmartHome' skill doesn't work because I can't just tell Alexa to 'Turn on Kitchen Lights', like I used to. I have to say 'Alexa, tell HomeSeer to turn on Kitchen Lights'. Alexa also won't recognize devices when I go to scan.

    Did I miss installing or configuring something? Is this a license issue? Right now I only installed the Omni Plugin on a 30 day trial basis.

  • #2
    I would recommended a do-over
    Shut down HS. If you're on Windows, I included an uninstall app in your HomeSeer folder. Shut down HomeSeer and run that utility. It will uninstall the HAI/OMNI application.
    Alternatively, you can just remove everything with *HAI* or *OMNI* and accomplish the same thing.
    Next, download the OMNI plugin again from the HS store.
    Configure the plugin and just pick one device for now for HS control.
    Follow this guide for setting up Alexa control of your OMNI devices.
    http://communities.leviton.com/docs/DOC-5146

    I've never liked the "Tell HomeSeer to..." it's just not voice-friendly. Using the Smarthome API is much more intuitive.

    HS3Pro Running on a Raspberry Pi3
    64 Z-Wave Nodes, 168 Events, 280 Devices
    UPB modules via OMNI plugin/panel
    Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
    HSTouch Clients: 3 Android, 1 Joggler

    Comment


    • #3
      Originally posted by rmasonjr View Post
      I would recommended a do-over
      Shut down HS. If you're on Windows, I included an uninstall app in your HomeSeer folder. Shut down HomeSeer and run that utility. It will uninstall the HAI/OMNI application.
      Alternatively, you can just remove everything with *HAI* or *OMNI* and accomplish the same thing.
      Next, download the OMNI plugin again from the HS store.
      Configure the plugin and just pick one device for now for HS control.
      Follow this guide for setting up Alexa control of your OMNI devices.
      http://communities.leviton.com/docs/DOC-5146

      I've never liked the "Tell HomeSeer to..." it's just not voice-friendly. Using the Smarthome API is much more intuitive.
      I followed the link and have a question. It makes a good point that Alexa (or google or whatever) might not recognize abbreviations like "Guest Bdrm" and recommends changing the name in the home screen of HS to Guest Bedroom. I have the same problem with a UPB dimmer called Mstr Bedroom. Can I just change the name in the home screen of HS or do I have to go into Upstart and PC access and rename it to Master Bedroom in every program? Thanks.

      Comment


      • #4
        Alexa / Google only care about the name in HomeSeer, you only have to change it there.

        Comment


        • #5
          Thanks. My wife's android can now turn the lights on or off by voice. However, she cannot set dim level. Is there particular phrasing that should be used like "dim master bedroom to 50%" or "Ramp kitchen to 50%".

          Comment


          • #6
            Make sure the "Is Dimmable" box is checked and try "Alexa, set the master bedroom to 50%."

            Comment

            Working...
            X