Announcement

Collapse
No announcement yet.

No temperature reading for thermostat

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No temperature reading for thermostat

    I have an Omni IIe with one OmniStat 2 thermostat. PC Access shows all settings and readings correctly. While the Omni plug-in works correctly for all zones, units, and most everything else, it does not show the temperature for the thermostat (everything else is working fine) - see last line of the attached screen shot. I also have an outdoor temperature sensor and that one is working correctly. I'd appreciate some help to get this working.

    Thanks

    Click image for larger version

Name:	Thermostat.png
Views:	164
Size:	202.6 KB
ID:	1322451

  • #2
    In the plugin config, make sure that logging is set to DEBUG and let it run for the day.
    Later this afternoon, go into the OMNI -> OMNI Logs and email me the logs to robmasonjr67 at yahoo dot com

    I am curious if the OmniStat 2 temperature comes over in a different format or not.
    HS3Pro Running on a Raspberry Pi3
    68 Z-Wave Nodes, 174 Events, 326 Devices
    UPB modules via OMNI plugin/panel
    Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
    HSTouch Clients: 3 Android, 1 Joggler

    Comment


    • #3
      I'm having same issue with my omnistat2 units, but RC-80 works. The temperature works in HSTouch using "current temperature", but not "temperature" on the website. If you don't get what you need from klauss' logs let me know and I'll send a log from my setup.


      I'm have another issue with the HS3 Omnistat When I manually set "hold" on the physical thermostat it still shows hold "not set". The device setting show 0 as hold not set and 255 as hold set. When I manually set hold on the physical thermostat the hold status is "1". I can manually edit the device status options, but not sue if future updates will overwrite this. Could you investigate and address this in a future update?

      Guy
      Last edited by cowsr4eating; August 26, 2019, 03:24 PM. Reason: Edit: Correction: RC-80 DOES show the temperature, but the Omnistat2 units do not.

      Comment


      • #4
        Yep - I got his logs and I see the temperature is received from the omnistat2, but it's not updating HS correctly. Not sure what that could be. I need to dig further.
        Can you shoot me a log snippet where you set HOLD on the device?
        HS3Pro Running on a Raspberry Pi3
        68 Z-Wave Nodes, 174 Events, 326 Devices
        UPB modules via OMNI plugin/panel
        Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
        HSTouch Clients: 3 Android, 1 Joggler

        Comment


        • #5
          When enable debug logging and manually set hold at the physical thermostat nothing appears in the Omni logs. I see other activity, if I turn lights on, etc. Where I see the status is "1" is from the web portal:

          Click image for larger version

Name:	Omnihold.JPG
Views:	108
Size:	69.0 KB
ID:	1322868

          The status is "0" when hold is off and "255" when I set hold from HS3. These are also the only values set for the status graphic for this device. I can change the "hold" values to be a range 1-255, but I assume others have the same issue and better to resolve in the plugin defaults.

          Click image for larger version

Name:	omniholdstatus.JPG
Views:	96
Size:	122.3 KB
ID:	1322869

          Comment


          • #6
            while I was in the web UI it looks like the Omnistate2 thermostat issue is also in the "status graphic" range defaults. The omnistat2 range is -39.5 to 30.
            Click image for larger version

Name:	omnithermostat range.JPG
Views:	106
Size:	71.8 KB
ID:	1322872

            The RC-80 range is -30 to120
            Click image for larger version

Name:	rc-80.JPG
Views:	97
Size:	72.1 KB
ID:	1322873

            When I change the omnistat2 range to match the RC-80 the temperature is displayed in the web UI,

            Comment


            • #7
              I figured out how to fix the problem I reported. I turned the thermostat off in the Omni plug in ('Omni Config' -> 'Thermostat') and restarted HS3. I then deleted all references to the thermostat in HS3. Thereafter I turned the thermostat on again in the Omni plug in and restarted HS3. This created all new references for the thermostat - including a new one for the current temperature. Everything is working now.

              Comment


              • #8
                Click image for larger version

Name:	2FA549EF-87B4-48D1-9CD7-F501B659BE40.png
Views:	92
Size:	305.6 KB
ID:	1335366 this is what I see for my thermostat in the Alexa app. Can someone tell me what’s happening and what I need to do? Click image for larger version

Name:	F9239AF3-67CA-46E3-A7F0-A11320CF7BDB.png
Views:	99
Size:	310.0 KB
ID:	1335365

                Comment


                • #9
                  Originally posted by Chaser View Post
                  Click image for larger version

Name:	2FA549EF-87B4-48D1-9CD7-F501B659BE40.png
Views:	92
Size:	305.6 KB
ID:	1335366 this is what I see for my thermostat in the Alexa app. Can someone tell me what’s happening and what I need to do? Click image for larger version

Name:	F9239AF3-67CA-46E3-A7F0-A11320CF7BDB.png
Views:	99
Size:	310.0 KB
ID:	1335365
                  What is the issue you are having?
                  HS3Pro Running on a Raspberry Pi3
                  68 Z-Wave Nodes, 174 Events, 326 Devices
                  UPB modules via OMNI plugin/panel
                  Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
                  HSTouch Clients: 3 Android, 1 Joggler

                  Comment


                  • #10
                    When I establish a routine I can set average temperatures OK and my requests work. However that top picture was bothering me that it said “main floor temperature is off the current temperature is 24°F ” all of which is bogus. Are you saying I should totally Ignore this?

                    Comment


                    • #11
                      Mason I noticed that I cannot change the thermostat mode i.e. cool, Heat or auto With this addon. And in the Alexa routines the only choice I have is to set a specific temperature which in the case of auto mode is the average and in the case of cool or heat mode it is the actual cooling or heating temperature being requested.
                      Is there a way to reset the mode for the thermostat with your app? That way I can aim for an exact temperature instead of an average when it is stuck in the auto mode.
                      it would be also be good to be able to say “increase main floor temperature 2°“ Instead of setting a specific temperature.

                      Comment


                      • #12
                        Originally posted by Chaser View Post
                        When I establish a routine I can set average temperatures OK and my requests work. However that top picture was bothering me that it said “main floor temperature is off the current temperature is 24°F ” all of which is bogus. Are you saying I should totally Ignore this?
                        I've never seen that, so I'm not sure. If Amazon is reporting that temperature I'm not sure what it could be.

                        HS3Pro Running on a Raspberry Pi3
                        68 Z-Wave Nodes, 174 Events, 326 Devices
                        UPB modules via OMNI plugin/panel
                        Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
                        HSTouch Clients: 3 Android, 1 Joggler

                        Comment


                        • #13
                          Originally posted by Chaser View Post
                          Mason I noticed that I cannot change the thermostat mode i.e. cool, Heat or auto With this addon. And in the Alexa routines the only choice I have is to set a specific temperature which in the case of auto mode is the average and in the case of cool or heat mode it is the actual cooling or heating temperature being requested.
                          Is there a way to reset the mode for the thermostat with your app? That way I can aim for an exact temperature instead of an average when it is stuck in the auto mode.
                          it would be also be good to be able to say “increase main floor temperature 2°“ Instead of setting a specific temperature.
                          You dont have to set it to a specific temperature,
                          With Alexa, you can just say "Alexa, make the <thermostat name> warmer"
                          It will then report back what the current temperature is.
                          HS3Pro Running on a Raspberry Pi3
                          68 Z-Wave Nodes, 174 Events, 326 Devices
                          UPB modules via OMNI plugin/panel
                          Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
                          HSTouch Clients: 3 Android, 1 Joggler

                          Comment


                          • #14
                            I like being able to say that but it makes a lot of difference if the thermostat is set on auto instead of heat or cool. For instance when I say make it warmer In the auto mode it speaks of average between heating and cooling set temps. However if I say make it warmer in the Heat mode It sets the specific heat requested temperature.
                            so can I say there is no way to change the thermostat mode in this addon? I suggest you try it on your thermostat because it’s difficult for me to explain what happens in the different modes when requesting warmer or cooler —thank you for your help Mason

                            Comment


                            • #15
                              Originally posted by Chaser View Post
                              I like being able to say that but it makes a lot of difference if the thermostat is set on auto instead of heat or cool. For instance when I say make it warmer In the auto mode it speaks of average between heating and cooling set temps. However if I say make it warmer in the Heat mode It sets the specific heat requested temperature.
                              so can I say there is no way to change the thermostat mode in this addon? I suggest you try it on your thermostat because it’s difficult for me to explain what happens in the different modes when requesting warmer or cooler —thank you for your help Mason
                              Thermostat mode is not supported in the Smart Home API (V3 I think). So you cant control it directly on any thermostat.

                              You can, however, create a couple of virtual devices called Heat and Cool. Say "Alexa, turn on Heat" and have an event change your OMNI thermostat mode to Heat, etc.


                              HS3Pro Running on a Raspberry Pi3
                              68 Z-Wave Nodes, 174 Events, 326 Devices
                              UPB modules via OMNI plugin/panel
                              Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
                              HSTouch Clients: 3 Android, 1 Joggler

                              Comment

                              Working...
                              X