Announcement

Collapse
No announcement yet.

Event for Controlling Omni Button

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Event for Controlling Omni Button

    Ok, I enabled the a button in the Omni plugin which is a toggle that when selected toggles announcements on and off within the Omni. It works just fine within HS. I want to use my Echo device around the house to allow my Wife to say “Alexa, turn off Security Announcements” and vise/versa.
    I tried creating an event (has an on and off button) but when I select ON it turns OFF the announcements and when I select OFF it does nothing. The weird thing is that when I select ON again it toggles the announcements back ON.
    Also when I run a discovery from Alexa, it doesn’t find the event(s).

    Long story short, I just want a event that is discoverable via Amazon Alexa that will toggle the announcements on and off via a verbal command. Any idea what I’m doing wrong?

  • #2
    Suggest you create a flag instead because it will receive on and off commands. Buttons only accept commands to turn on.

    Comment


    • #3
      Well thats sounds good but Im not see the flag from my Omni Pro II. It's connected to HS and pulls everything over including the kitchen sink but I get no flags imported to HS. I have two flags in the Omni Pro II. The one I need is called "Announcement Flag" and is labeled #396. When I enable the Omni plugin and it finishes importing everything, I can see outputs going all the way up to 392 but nothing past #392. I have expansion enclosure checked as well. Any thoughts as to why Im not importing flags from the Omni?

      Comment


      • #4
        I use flags on my OMNI plugin with no difficulty. This may be your problem:

        You have to tell the OMNI plugin which Omni Pro 2 flags you want it to monitor and control. To do this, go to PLUG-INS -> OMNI -> OMNI Config.
        Then click the Flags tab. The right hand column of the table is labelled HS Device. Your OP2 flags should appear in the table. If the entry in the right hand column is red, it means that the OMNI plugin is ignoring that particular flag. Clicking on the HS Device entry toggles it from red to green, and back. Make the entry green, and the plugin should immediately allow you monitor and control access in HS3.

        Comment


        • #5
          Problem is that the HS doesn't see any of my flags. There are not being imported and Ive tried to re-enabling the plugin but that doesn't do it.

          Comment


          • #6
            Found issue. The flag unit name was left as default of "UNIT 396" although I had a description of "Announcement". The minute I change the name from the default to something else (in this case "Announcement") and reset the plugin, I now see the flag and will enable it to be controlled within HS. Hope this helps people in the future. My stupidness for leaving default values in Omni Pro.

            Comment


            • #7
              Originally posted by Homer-j-simpson137 View Post
              Found issue. The flag unit name was left as default of "UNIT 396" although I had a description of "Announcement". The minute I change the name from the default to something else (in this case "Announcement") and reset the plugin, I now see the flag and will enable it to be controlled within HS. Hope this helps people in the future. My stupidness for leaving default values in Omni Pro.
              Right. I remember rmasonjr saying that the OP2 API uses fixed data arrays for units, flags, buttons, etc. Of course, many of the slots are not being used for anything. The way that rmasonjr determines whether a specific slot is real, or just a placeholder, is by its name. If the name is "UNIT xxx", he assumes that the OP2 setup has not defined any use for that slot.

              Sorry I didn't think of that possibility.

              Comment


              • #8
                Sorry I'm late to the party, but you're right - only named OPII devices will make it into the plugin. This was done to keep the memory usage down in the plugin and the number of devices down in HS.
                HS3Pro Running on a Raspberry Pi3
                64 Z-Wave Nodes, 168 Events, 280 Devices
                UPB modules via OMNI plugin/panel
                Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
                HSTouch Clients: 3 Android, 1 Joggler

                Comment


                • #9
                  OK, new dilemma but similar problem ...I know HS and Omni and two separate devices. This being said I am having a heck of a time in Arming my systems to night mode from the Omni and then making sure that HS will not allow arming again or until disarmed. The goal here is to use Alexa voice command to say "Alexa, arm security system to night mode", and the Omni arms itself into night mode. To do this, I created created a virtual device called "Security Night Mode Switch" where I can voice activate this switch. So far so good, right.
                  Then I create an event that if the "Security Night Mode Switch" changes to "ON" then control device arm night. It arms the Omni in night mode just fine.

                  Now for the problem:
                  If I disarm the Omni from the HS, then Im fine, the "Security Night Mode Switch" get updated to "OFF". BUT, if I disarm the Omni from the Omni keypad, the "Security Night Mode Switch" in HS still shows "ON". Somehow I need away to update the HS switch with the right Omni status. Every time I think I got it, I put my Omni in a big loop and it arms or disarms itself over and over. I even created a flag in the Omni that shows in HS but for the life of me, I can't get the two systems to stay in sync ("Security Night Mode Switch" and Omni).
                  If you guys can think what the heck I'm doing wrong, I would appreciate a nudge in the right direction.

                  Comment


                  • #10
                    Originally posted by Homer-j-simpson137 View Post
                    Now for the problem:
                    If I disarm the Omni from the HS, then Im fine, the "Security Night Mode Switch" get updated to "OFF". BUT, if I disarm the Omni from the Omni keypad, the "Security Night Mode Switch" in HS still shows "ON". Somehow I need away to update the HS switch with the right Omni status. Every time I think I got it, I put my Omni in a big loop and it arms or disarms itself over and over. I even created a flag in the Omni that shows in HS but for the life of me, I can't get the two systems to stay in sync ("Security Night Mode Switch" and Omni).
                    If you guys can think what the heck I'm doing wrong, I would appreciate a nudge in the right direction.
                    You're very close. It sounds like you need one more event to switch your "Security Night Mode Switch" back to OFF.
                    Create an event where the trigger looks like this:
                    Click image for larger version

Name:	screenshot1.png
Views:	40
Size:	6.7 KB
ID:	1345457

                    Then, for the event action, set your "Security Night Mode Switch" device to OFF

                    This should keep your virtual device in sync with your panel.
                    HS3Pro Running on a Raspberry Pi3
                    64 Z-Wave Nodes, 168 Events, 280 Devices
                    UPB modules via OMNI plugin/panel
                    Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
                    HSTouch Clients: 3 Android, 1 Joggler

                    Comment


                    • #11
                      OK, I did it and it looked like it was working but I think I found a bug or something is wrong. I have a virtual device called "Security Away Mode Switch" and two events that are associated with this switch.

                      This event arms Omni if the "Security Away Mode Switch" changes to "On".

                      Click image for larger version

Name:	1.png
Views:	33
Size:	42.1 KB
ID:	1345721



                      This event keeps HS in sync with the Omni alarm status by changing the "Security Away Mode Switch" to "On" when it gets armed to "Arm Away" mode. I had to do this because if I armed the Omni from the Omni keypad, the HS "Security Away Mode Switch" wouldn't show "On".

                      Click image for larger version

Name:	2.png
Views:	21
Size:	42.4 KB
ID:	1345722

                      OK, just some pre-info for my Omni.
                      I have a zone that is bypassed permanently.

                      OK, this being said, when the config is like the above and I arm the Omni in "Away" mode from the Omni, it "UN-Bypasses" the zone immediately and then when the system finishes its 60 second countdown and arms in away mode, all heck breaks looses with alarms going off. In troubleshooting this, I found out that if I removed the "Armed From Omni Panel - Away Mode (Omni/HS Sync)" event, and ran the same scenario, the zone stays bypassed.

                      Any thoughts as to why my zone that is bypassed keeps getting UN-Bypassed when arming to Away mode.
                      PS, I don't have auto-bypass turned on in the Omni panel and when this happens, it immediately meaning the zone gets UN-Bypassed even before the 60 second countdown completes.












                      Comment


                      • #12
                        BTW, I have the same config in HS for Night mode and when setting the Omni in Night mode, the zone stays bypassed. Looks to be something about the Away config in HS.

                        Comment


                        • #13
                          I have a permanently bypassed zone in my OMNI and I dont see that behavior - mine works fine.

                          In looking at those 2 events, I can see how they would result in circular-firing. Dont you want to set that virtual switch to OFF after arming the system? If so, click the green '+' to add another action to set it to OFF.
                          HS3Pro Running on a Raspberry Pi3
                          64 Z-Wave Nodes, 168 Events, 280 Devices
                          UPB modules via OMNI plugin/panel
                          Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
                          HSTouch Clients: 3 Android, 1 Joggler

                          Comment


                          • #14
                            OK, I think I found something crazy here. I disabled all of my events except one. This one:

                            Click image for larger version

Name:	3.png
Views:	21
Size:	42.6 KB
ID:	1345861

                            If I set the Omni at the omni panel and in Away mode.... The same thing happens. My zone thats bypassed is UNBypassed.
                            I caught something in the Hs logs that might be of concern. Why am I see ing for my "Security Away Mode Switch":

                            Device: Unknown Unknown Security Away Mode Switch to On (100) by/from: CAPI Control Handler

                            And when I do the same command for my "Security Night Mode Switch" it looks like this:

                            Device: Unknown Unknown Security Night Mode Switch to On (100)


                            Whats this CAPI Control Handler and why am I only seeing it for this one virtual switch? Could this be the problem and if so, how to fix it?



                            Attached Files

                            Comment


                            • #15
                              OK, I think I tracked it down a bit further...See this image:

                              Click image for larger version

Name:	4.png
Views:	22
Size:	12.3 KB
ID:	1345864

                              If I disable all the events and then from the HS home screen change this drop-down to "Arm Away" then I get the same results...When the alarm starts counting down and it changes my bypassed zone to UNBypassed. Were to go from here ? This proves its in the HS, but where. It doesn't do this if I set the alarm to away mode from the omni. Only when setting it from HS.

                              Comment

                              Working...
                              X